summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-09 14:28:29 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-09 14:28:29 +0000
commit83fba541903f1270a0765ec34828b03144f68266 (patch)
tree81025740f2f825703b2f6e41c4db2f2ca700e227 /games-sports
parentMarking abiword-2.8.6 ppc64 for bug 326503 (diff)
downloadgentoo-2-83fba541903f1270a0765ec34828b03144f68266.tar.gz
gentoo-2-83fba541903f1270a0765ec34828b03144f68266.tar.bz2
gentoo-2-83fba541903f1270a0765ec34828b03144f68266.zip
Respect LDFLAGS. Bug #336541
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/race/ChangeLog8
-rw-r--r--games-sports/race/files/race-0.5-ldflags.patch11
-rw-r--r--games-sports/race/race-0.5.ebuild16
3 files changed, 25 insertions, 10 deletions
diff --git a/games-sports/race/ChangeLog b/games-sports/race/ChangeLog
index ee5713ee4fcd..bfaeab4f0fc4 100644
--- a/games-sports/race/ChangeLog
+++ b/games-sports/race/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/race
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/race/ChangeLog,v 1.8 2007/03/12 17:36:28 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/race/ChangeLog,v 1.9 2010/09/09 14:28:29 tupone Exp $
+
+ 09 Sep 2010; Tupone Alfredo <tupone@gentoo.org> race-0.5.ebuild,
+ +files/race-0.5-ldflags.patch:
+ Respect LDFLAGS. Bug #336541 by flameeyes@gentoo.org
12 Mar 2007; Tristan Heaven <nyhm@gentoo.org> race-0.5.ebuild:
Install menu entry, bug #160244
diff --git a/games-sports/race/files/race-0.5-ldflags.patch b/games-sports/race/files/race-0.5-ldflags.patch
new file mode 100644
index 000000000000..b1285a103631
--- /dev/null
+++ b/games-sports/race/files/race-0.5-ldflags.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2010-09-09 16:24:38.000000000 +0200
++++ Makefile 2010-09-09 16:24:58.000000000 +0200
+@@ -24,7 +24,7 @@
+ $(CC) src/messages.c -c `sdl-config --cflags`
+ $(CC) src/camera.c -c `sdl-config --cflags`
+
+- $(CC) main.o timing.o vector.o fifo.o ortho.o audio.o font.o \
++ $(CC) ${LDFLAGS} main.o timing.o vector.o fifo.o ortho.o audio.o font.o \
+ init.o textures.o terrain.o menu.o game.o hud.o messages.o \
+ camera.o \
+ -o $(BIN) -lGL -lGLU -lSDL_image -lSDL_mixer -lm `sdl-config --libs`
diff --git a/games-sports/race/race-0.5.ebuild b/games-sports/race/race-0.5.ebuild
index 7a7610af619a..d067956d4ca0 100644
--- a/games-sports/race/race-0.5.ebuild
+++ b/games-sports/race/race-0.5.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/race/race-0.5.ebuild,v 1.12 2007/03/13 23:25:53 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/race/race-0.5.ebuild,v 1.13 2010/09/09 14:28:29 tupone Exp $
+EAPI="2"
inherit eutils toolchain-funcs games
@@ -19,15 +20,14 @@ DEPEND="virtual/opengl
media-libs/sdl-image
media-libs/sdl-mixer"
-src_unpack() {
- unpack ${A}
- cd "${S}"/src
- epatch "${FILESDIR}"/${PV}-gentoo.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:g" \
-e "s:GENTOO_CONFDIR:${GAMES_SYSCONFDIR}:g" \
- *.c || die "sed failed"
- find "${S}"/data/ -type d -name .xvpics -print0 | xargs -0 rm -rf
+ src/*.c || die "sed failed"
+ find data/ -type d -name .xvpics -print0 | xargs -0 rm -rf
}
src_compile() {