summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-07-05 07:22:34 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-07-05 07:22:34 +0000
commitce8ae68f9df26a983d21b19096cb4d29d3b5c10c (patch)
tree07da3519bfdf36e3ece22c5b9bb59af47557e9b4 /games-sports/xmoto
parentFixed to not use mydoc. Dropped old version. (diff)
downloadgentoo-2-ce8ae68f9df26a983d21b19096cb4d29d3b5c10c.tar.gz
gentoo-2-ce8ae68f9df26a983d21b19096cb4d29d3b5c10c.tar.bz2
gentoo-2-ce8ae68f9df26a983d21b19096cb4d29d3b5c10c.zip
version bump thanks to Franz Fellner <fellner@gmx.de> in bug 184262
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-sports/xmoto')
-rw-r--r--games-sports/xmoto/ChangeLog7
-rw-r--r--games-sports/xmoto/files/digest-xmoto-0.3.16
-rw-r--r--games-sports/xmoto/xmoto-0.3.1.ebuild75
3 files changed, 87 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index 30fec540f684..3a489128bf7d 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.16 2007/06/18 18:04:03 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.17 2007/07/05 07:22:34 genstef Exp $
+
+*xmoto-0.3.1 (05 Jul 2007)
+
+ 05 Jul 2007; Stefan Schweizer <genstef@gentoo.org> +xmoto-0.3.1.ebuild:
+ version bump thanks to Franz Fellner <fellner@gmx.de> in bug 184262
18 Jun 2007; Stefan Schweizer <genstef@gentoo.org> xmoto-0.3.0.ebuild:
Add missing sqlite-3 depend thanks to Marco Squarcina <lavish@gmail.com> and
diff --git a/games-sports/xmoto/files/digest-xmoto-0.3.1 b/games-sports/xmoto/files/digest-xmoto-0.3.1
new file mode 100644
index 000000000000..a3c0ff526e83
--- /dev/null
+++ b/games-sports/xmoto/files/digest-xmoto-0.3.1
@@ -0,0 +1,6 @@
+MD5 1509555c6cfd71f5775ab1b997d4c8a3 svg2lvl-0.4.0.tar.gz 48766
+RMD160 84244cd82fc1ba0737207dfd64fd865dd9fcf032 svg2lvl-0.4.0.tar.gz 48766
+SHA256 ffda6cf46ba2fb2a280c1229bbc5b458b3ac72595cdfee0a269c0fcd099a9f13 svg2lvl-0.4.0.tar.gz 48766
+MD5 6c636acc65d8915828894086f0471e9e xmoto-0.3.1-src.tar.gz 16792096
+RMD160 8d2569fa6e58f16e7c0647ee16b444ad8851ee4e xmoto-0.3.1-src.tar.gz 16792096
+SHA256 6fc603529a3844f3d6e97cde76b08b96ebee32870e6b79f4e014f6a1334cd5b1 xmoto-0.3.1-src.tar.gz 16792096
diff --git a/games-sports/xmoto/xmoto-0.3.1.ebuild b/games-sports/xmoto/xmoto-0.3.1.ebuild
new file mode 100644
index 000000000000..651a512f7571
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.3.1.ebuild,v 1.1 2007/07/05 07:22:34 genstef Exp $
+
+inherit eutils games
+
+LVL="svg2lvl-0.4.0"
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/${PN}/${PV}/${P}-src.tar.gz
+ editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${LVL/*-}/${LVL}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls editor"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ net-misc/curl
+ dev-lang/lua
+ dev-games/ode
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )
+ editor? ( >=media-gfx/inkscape-0.45 )"
+DEPEND="${RDEPEND}
+ >=dev-db/sqlite-3
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:$(localedir):/usr/share/locale:' po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+ use editor && rm -f "${WORKDIR}"/${LVL}/{bezmisc,inkex}.py
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-localesdir=/usr/share/locale \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README TODO ChangeLog
+
+ doicon extra/xmoto.xpm
+ domenu extra/xmoto.desktop
+
+ prepgamesdirs
+
+ if use editor; then
+ insinto /usr/share/inkscape/extensions
+ doins "${WORKDIR}"/${LVL}/*.{inx,py,xml} || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use editor; then
+ elog "If you want to know how to create Xmoto levels"
+ elog "have a look at this Tutorial:"
+ elog "http://wiki.xmoto.free.fr/index.php?title=Inkscape-0.3.0#Tutorial"
+ elog "You can share your levels on the Xmoto homepage."
+ fi
+}