summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-24 14:51:22 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-24 14:51:22 +0000
commit77da821f07903c21ac86621803ecad9bcc248ed0 (patch)
tree51cfb6f4535cd48f6d67900433a33576a07b19ac /games-sports/xmoto
parentnew upstream release. (diff)
downloadgentoo-2-77da821f07903c21ac86621803ecad9bcc248ed0.tar.gz
gentoo-2-77da821f07903c21ac86621803ecad9bcc248ed0.tar.bz2
gentoo-2-77da821f07903c21ac86621803ecad9bcc248ed0.zip
Version bump thanks to Franz Fellner <fellner@gmx.de> in bug 159016, works now with -j2, bug 147725
(Portage version: 2.1.2_rc3-r8)
Diffstat (limited to 'games-sports/xmoto')
-rw-r--r--games-sports/xmoto/ChangeLog8
-rw-r--r--games-sports/xmoto/files/digest-xmoto-0.2.43
-rw-r--r--games-sports/xmoto/xmoto-0.2.4.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index a519f50d93f8..c813f05391d2 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.9 2006/12/16 08:51:12 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.10 2006/12/24 14:51:22 genstef Exp $
+
+*xmoto-0.2.4 (24 Dec 2006)
+
+ 24 Dec 2006; <stefan@gentoo.org> +xmoto-0.2.4.ebuild:
+ Version bump thanks to Franz Fellner <fellner@gmx.de> in bug 159016, works
+ now with -j2, bug 147725
*xmoto-0.2.2-r1 (16 Dec 2006)
diff --git a/games-sports/xmoto/files/digest-xmoto-0.2.4 b/games-sports/xmoto/files/digest-xmoto-0.2.4
new file mode 100644
index 000000000000..e064bf70ef39
--- /dev/null
+++ b/games-sports/xmoto/files/digest-xmoto-0.2.4
@@ -0,0 +1,3 @@
+MD5 78f776695a664b855e3659df25cc6d82 xmoto-0.2.4-src.tar.gz 5972103
+RMD160 9bf0483d3f838082963af99a4b534d20b27fd353 xmoto-0.2.4-src.tar.gz 5972103
+SHA256 67bd0dfb5442a290c1290b34461e1f7924e53c8282b7360c29d3f6c425457605 xmoto-0.2.4-src.tar.gz 5972103
diff --git a/games-sports/xmoto/xmoto-0.2.4.ebuild b/games-sports/xmoto/xmoto-0.2.4.ebuild
new file mode 100644
index 000000000000..9e73abe401b2
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.2.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.2.4.ebuild,v 1.1 2006/12/24 14:51:22 genstef Exp $
+
+inherit games
+
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ net-misc/curl
+ dev-lang/lua
+ dev-games/ode
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:$(localedir):/usr/share/locale:' po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-localesdir=/usr/share/locale \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README TODO ChangeLog
+
+ doicon extra/xmoto.xpm
+ domenu extra/xmoto{,-edit}.desktop
+
+ prepgamesdirs
+
+ # please portage, QA Notice: you should let portage compress '${realname}' for you
+ cd ${D}/usr/share/man/*
+ gunzip *
+}