summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2009-05-26 22:49:36 +0000
committerJoe Peterson <lavajoe@gentoo.org>2009-05-26 22:49:36 +0000
commitb9de4fa61455fe52fecc273bb52f2c3d0d257f4f (patch)
tree3d81f4396cab3fe2900a3fa54c91b020ce33d8fa /games-simulation
parentFix build issues. Per bug #271325. (diff)
downloadgentoo-2-b9de4fa61455fe52fecc273bb52f2c3d0d257f4f.tar.gz
gentoo-2-b9de4fa61455fe52fecc273bb52f2c3d0d257f4f.tar.bz2
gentoo-2-b9de4fa61455fe52fecc273bb52f2c3d0d257f4f.zip
New package: Second Life viewer
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/secondlife/ChangeLog15
-rw-r--r--games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-memset-error.patch12
-rw-r--r--games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-printf-format-error.patch11
-rw-r--r--games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-uninitialized-gdkcolor.patch10
-rw-r--r--games-simulation/secondlife/files/secondlife-disable-ndof.patch10
-rw-r--r--games-simulation/secondlife/files/secondlife-fix-cmake-include-path.patch10
-rw-r--r--games-simulation/secondlife/metadata.xml8
-rw-r--r--games-simulation/secondlife/secondlife-1.23.2_rc2.ebuild141
8 files changed, 217 insertions, 0 deletions
diff --git a/games-simulation/secondlife/ChangeLog b/games-simulation/secondlife/ChangeLog
new file mode 100644
index 000000000000..42876c0556d1
--- /dev/null
+++ b/games-simulation/secondlife/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for games-simulation/secondlife
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/secondlife/ChangeLog,v 1.1 2009/05/26 22:49:36 lavajoe Exp $
+
+*secondlife-1.23.2_rc2 (26 May 2009)
+
+ 26 May 2009; Joe Peterson <lavajoe@gentoo.org>
+ +secondlife-1.23.2_rc2.ebuild,
+ +files/secondlife-1.23.2_rc2-fix-memset-error.patch,
+ +files/secondlife-1.23.2_rc2-fix-printf-format-error.patch,
+ +files/secondlife-1.23.2_rc2-fix-uninitialized-gdkcolor.patch,
+ +files/secondlife-disable-ndof.patch,
+ +files/secondlife-fix-cmake-include-path.patch, +metadata.xml:
+ New package: Second Life viewer
+
diff --git a/games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-memset-error.patch b/games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-memset-error.patch
new file mode 100644
index 000000000000..edff470da052
--- /dev/null
+++ b/games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-memset-error.patch
@@ -0,0 +1,12 @@
+--- linden/indra/llmessage/lltemplatemessagereader.cpp~ 2009-05-20 15:26:15.000000000 -0600
++++ linden/indra/llmessage/lltemplatemessagereader.cpp 2009-05-25 21:56:50.000000000 -0600
+@@ -676,8 +676,7 @@
+
+ // default to 0s.
+ U32 size = mvci.getSize();
+- std::vector<U8> data(size);
+- memset(&(data[0]), 0, size);
++ std::vector<U8> data(size, 0);
+ cur_data_block->addData(mvci.getName(), &(data[0]),
+ size, mvci.getType());
+ }
diff --git a/games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-printf-format-error.patch b/games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-printf-format-error.patch
new file mode 100644
index 000000000000..c99b5302b3da
--- /dev/null
+++ b/games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-printf-format-error.patch
@@ -0,0 +1,11 @@
+--- linden/indra/newview/llappviewerlinux.cpp~ 2009-05-20 15:26:19.000000000 -0600
++++ linden/indra/newview/llappviewerlinux.cpp 2009-05-25 23:24:31.000000000 -0600
+@@ -188,7 +188,7 @@
+ for (i = 0; i < size; i++)
+ {
+ // the format of the StraceFile is very specific, to allow (kludgy) machine-parsing
+- fprintf(StraceFile, "%-3d ", i);
++ fprintf(StraceFile, "%-3ld ", (long) i);
+ fprintf(StraceFile, "%-32s\t", "unknown");
+ fprintf(StraceFile, "%p ", stackarray[i]);
+ fprintf(StraceFile, "%s\n", strings[i]);
diff --git a/games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-uninitialized-gdkcolor.patch b/games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-uninitialized-gdkcolor.patch
new file mode 100644
index 000000000000..e51edaeea883
--- /dev/null
+++ b/games-simulation/secondlife/files/secondlife-1.23.2_rc2-fix-uninitialized-gdkcolor.patch
@@ -0,0 +1,10 @@
+--- linden/indra/llwindow/llwindowsdl.cpp~ 2009-05-20 15:26:16.000000000 -0600
++++ linden/indra/llwindow/llwindowsdl.cpp 2009-05-25 21:42:55.000000000 -0600
+@@ -2195,6 +2195,7 @@
+ orig_color.red = guint16(65535 * *r);
+ orig_color.green= guint16(65535 * *g);
+ orig_color.blue = guint16(65535 * *b);
++ orig_color.pixel = 0;
+ color = orig_color;
+
+ gtk_color_selection_set_previous_color (colorsel, &color);
diff --git a/games-simulation/secondlife/files/secondlife-disable-ndof.patch b/games-simulation/secondlife/files/secondlife-disable-ndof.patch
new file mode 100644
index 000000000000..5c9506d71555
--- /dev/null
+++ b/games-simulation/secondlife/files/secondlife-disable-ndof.patch
@@ -0,0 +1,10 @@
+--- linden/indra/newview/CMakeLists.txt~ 2009-05-20 15:26:16.000000000 -0600
++++ linden/indra/newview/CMakeLists.txt 2009-05-25 22:12:33.000000000 -0600
+@@ -30,7 +30,6 @@
+ include(LScript)
+ include(Linking)
+ include(Mozlib)
+-include(NDOF)
+ include(GooglePerfTools)
+ include(TemplateCheck)
+ include(UI)
diff --git a/games-simulation/secondlife/files/secondlife-fix-cmake-include-path.patch b/games-simulation/secondlife/files/secondlife-fix-cmake-include-path.patch
new file mode 100644
index 000000000000..bf7d9d2ec83a
--- /dev/null
+++ b/games-simulation/secondlife/files/secondlife-fix-cmake-include-path.patch
@@ -0,0 +1,10 @@
+--- linden/indra/cmake/FindXmlRpcEpi.cmake~ 2009-05-20 15:26:14.000000000 -0600
++++ linden/indra/cmake/FindXmlRpcEpi.cmake 2009-05-25 15:04:07.000000000 -0600
+@@ -22,6 +22,7 @@
+
+ IF (XMLRPCEPI_LIBRARY AND XMLRPCEPI_INCLUDE_DIR)
+ SET(XMLRPCEPI_LIBRARIES ${XMLRPCEPI_LIBRARY})
++ INCLUDE_DIRECTORIES(${XMLRPCEPI_INCLUDE_DIR})
+ SET(XMLRPCEPI_FOUND "YES")
+ ELSE (XMLRPCEPI_LIBRARY AND XMLRPCEPI_INCLUDE_DIR)
+ SET(XMLRPCEPI_FOUND "NO")
diff --git a/games-simulation/secondlife/metadata.xml b/games-simulation/secondlife/metadata.xml
new file mode 100644
index 000000000000..fa0705095167
--- /dev/null
+++ b/games-simulation/secondlife/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>lavajoe@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/games-simulation/secondlife/secondlife-1.23.2_rc2.ebuild b/games-simulation/secondlife/secondlife-1.23.2_rc2.ebuild
new file mode 100644
index 000000000000..45919bd0e70d
--- /dev/null
+++ b/games-simulation/secondlife/secondlife-1.23.2_rc2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/secondlife/secondlife-1.23.2_rc2.ebuild,v 1.1 2009/05/26 22:49:36 lavajoe Exp $
+
+inherit eutils multilib games versionator
+
+SECONDLIFE_REVISION=120719
+SECONDLIFE_RELEASE_DIR=2009/05
+SECONDLIFE_MAJOR_VER=$(get_version_component_range 1-2)
+SECONDLIFE_MINOR_VER=$(get_version_component_range 3)
+SECONDLIFE_MINOR_VER=${SECONDLIFE_MINOR_VER/rc/}
+MY_P="slviewer-src-viewer-${SECONDLIFE_MAJOR_VER}.${SECONDLIFE_MINOR_VER}-r${SECONDLIFE_REVISION}"
+
+DESCRIPTION="The Second Life (an online, 3D virtual world) viewer"
+HOMEPAGE="http://secondlife.com/"
+SRC_URI="http://secondlife.com/developers/opensource/downloads/${SECONDLIFE_RELEASE_DIR}/${MY_P}.tar.gz http://secondlife.com/developers/opensource/downloads/${SECONDLIFE_RELEASE_DIR}/slviewer-artwork-viewer-${SECONDLIFE_MAJOR_VER}.${SECONDLIFE_MINOR_VER}-r${SECONDLIFE_REVISION}.zip http://secondlife.com/developers/opensource/downloads/${SECONDLIFE_RELEASE_DIR}/slviewer-linux-libs-viewer-${SECONDLIFE_MAJOR_VER}.${SECONDLIFE_MINOR_VER}-r${SECONDLIFE_REVISION}.tar.gz mirror://sourceforge/xmlrpc-epi/xmlrpc-epi-0.54.tar.gz http://s3.amazonaws.com/viewer-source-downloads/install_pkgs/glh_linear-linux-20080613.tar.bz2"
+
+LICENSE="GPL-2-with-Linden-Lab-FLOSS-exception Epinions"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-libs/glibc
+ sys-apps/dbus
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ >=x11-libs/gtk+-2.0
+ x11-libs/libXinerama
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error
+ dev-libs/openssl
+ dev-libs/apr
+ dev-libs/apr-util
+ dev-libs/boost
+ dev-libs/elfio
+ dev-libs/expat
+ dev-util/cmake
+ media-libs/freetype
+ media-libs/libogg
+ media-libs/libsdl
+ media-libs/libvorbis
+ media-libs/gstreamer
+ media-plugins/gst-plugins-meta
+ media-libs/fmod
+ media-libs/jpeg
+ media-libs/openjpeg
+ net-libs/gnutls
+ net-misc/curl
+ net-dns/c-ares
+ sys-libs/zlib
+ virtual/libstdc++
+ virtual/glu
+ virtual/opengl
+ media-libs/openal
+ media-libs/freealut"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/linden"
+
+use amd64 && ARCH_LIBS_DIR="x86_64-linux"
+use x86 && ARCH_LIBS_DIR="i686-linux"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix cmake include path (so it can find xmlrpc includes)
+ epatch "${FILESDIR}/${PN}-fix-cmake-include-path.patch"
+
+ # Disable NDOF (joystick) that will not compile
+ epatch "${FILESDIR}/${PN}-disable-ndof.patch"
+
+ # Fix uninitialized GdkColor
+ epatch "${FILESDIR}/${P}-fix-uninitialized-gdkcolor.patch"
+
+ # Fix memset used with constant zero length parameter error
+ epatch "${FILESDIR}/${P}-fix-memset-error.patch"
+
+ # Fix printf format type error
+ epatch "${FILESDIR}/${P}-fix-printf-format-error.patch"
+
+ # Move extra glh include file into place.
+ # NOTE: This is hackish, since it had to be downloaded from the SL site
+ # separately as part of the batch used when *not* building the
+ # viewer standalone (this ebuild *does* build it standalone).
+ mv ../indra/llwindow/glh indra/llwindow || die
+ rm -r ../indra || die
+
+ # Add local paths to the xmlrpc-epi cmake files.
+ # NOTE: This lib is downloaded separately, since it is
+ # not available in Gentoo.
+ sed -i -e"s:/usr/local/include:${S}/libraries/${ARCH_LIBS_DIR}/include /usr/local/include:" indra/cmake/FindXmlRpcEpi.cmake || die
+ sed -i -e"s:/usr/lib:${S}/libraries/${ARCH_LIBS_DIR}/lib_release_client /usr/lib:" indra/cmake/FindXmlRpcEpi.cmake || die
+
+ # Make 3rd party package area for xmlrpc-epi
+ mkdir -p libraries/${ARCH_LIBS_DIR}/include || die
+ mkdir libraries/${ARCH_LIBS_DIR}/lib_release_client || die
+}
+
+src_compile() {
+ # First, build xmlrpc-epi
+ cd "${WORKDIR}/xmlrpc-epi-"*
+
+ econf
+ emake || die
+
+ # Copy relevant files from xmlrpc-epi to 3rd party package area
+ rm src/.libs/libxmlrpc-epi.la || die
+ cp src/libxmlrpc-epi.la src/.libs || die
+ mkdir "${S}"/libraries/${ARCH_LIBS_DIR}/include/xmlrpc-epi || die
+ cp -dR src/*.h "${S}"/libraries/${ARCH_LIBS_DIR}/include/xmlrpc-epi || die
+ cp -dR src/.libs/libxmlrpc* "${S}"/libraries/${ARCH_LIBS_DIR}/lib_release_client || die
+
+ # Now build the Second Life viewer
+ cd "${S}/indra"
+
+ ./develop.py --standalone configure || die
+ ./develop.py --standalone build || die
+}
+
+src_install() {
+ cd "${S}"/indra/viewer-*/newview/packaged || die
+
+ dodoc README-*.txt licenses.txt || die
+ rm README-*.txt licenses.txt || die
+
+ dodir /usr/lib/${PN} || die
+ cp -dR "${S}"/libraries/${ARCH_LIBS_DIR}/lib_release_client/libxml* "${D}"/usr/lib/${PN} || die
+ #cp -dR bin secondlife *.sh "${D}"/usr/lib/${PN} || die
+ #rm -r bin secondlife *.sh || die
+ cp -dR * "${D}"/usr/lib/${PN} || die
+ chmod o-x "${D}"/usr/lib/${PN}/bin/* "${D}"/usr/lib/${PN}/secondlife "${D}"/usr/lib/${PN}/*.sh || die
+ chgrp games "${D}"/usr/lib/${PN}/bin/* "${D}"/usr/lib/${PN}/secondlife "${D}"/usr/lib/${PN}/*.sh || die
+
+ games_make_wrapper secondlife "./secondlife --set VersionChannelName Gentoo" /usr/lib/${PN} /usr/lib/${PN}
+ make_desktop_entry secondlife "Second Life" /usr/share/${PN}/secondlife_icon.png
+
+ prepgamesdirs
+}