summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-05-31 20:55:43 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-05-31 20:55:43 +0000
commitb2ba941eec2c554506e4fab87068d634be73305a (patch)
treed28a3cab6f8a60e723d4f48055b5e9d87974d697 /games-simulation
parentDo not break on ppc64 any more; use patch from previous versions (diff)
downloadgentoo-2-b2ba941eec2c554506e4fab87068d634be73305a.tar.gz
gentoo-2-b2ba941eec2c554506e4fab87068d634be73305a.tar.bz2
gentoo-2-b2ba941eec2c554506e4fab87068d634be73305a.zip
Added menu entry. Bug #160248 Fixed compilation for gcc-4.1.2
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/searchandrescue/ChangeLog12
-rw-r--r--games-simulation/searchandrescue/files/digest-searchandrescue-0.8.2-r16
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc412.patch56
-rw-r--r--games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild78
4 files changed, 150 insertions, 2 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index f02eaf6b1045..83d2a29304c8 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-simulation/searchandrescue
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.12 2006/12/06 20:24:46 wolf31o2 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.13 2007/05/31 20:55:43 tupone Exp $
+
+*searchandrescue-0.8.2-r1 (31 May 2007)
+
+ 31 May 2007; Tupone Alfredo <tupone@gentoo.org>
+ +files/searchandrescue-0.8.2-gcc412.patch,
+ +searchandrescue-0.8.2-r1.ebuild:
+ Added menu entry. Bug #160248 by Pacho Ramos
+ Fixed compilation error & warnings with gcc-4.1.2
06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
searchandrescue-0.8.2.ebuild:
diff --git a/games-simulation/searchandrescue/files/digest-searchandrescue-0.8.2-r1 b/games-simulation/searchandrescue/files/digest-searchandrescue-0.8.2-r1
new file mode 100644
index 000000000000..a2a324ed546b
--- /dev/null
+++ b/games-simulation/searchandrescue/files/digest-searchandrescue-0.8.2-r1
@@ -0,0 +1,6 @@
+MD5 f3304fe2e91f329b8494897c398f26f3 SearchAndRescue-0.8.2.tar.bz2 613500
+RMD160 dda13ebcc1a7c7085322b0ed664e6bc9f5d4a2df SearchAndRescue-0.8.2.tar.bz2 613500
+SHA256 6f0ca44497b5a8d7b0f563bf27f5669166d0338512f6246994e84165d153efb3 SearchAndRescue-0.8.2.tar.bz2 613500
+MD5 3ac0e91b0b3360c4be17fcb5564feca8 SearchAndRescue-data-0.8.2.tar.bz2 7232214
+RMD160 d4c0b04850b754f896601ac09ad6eb895f081fc5 SearchAndRescue-data-0.8.2.tar.bz2 7232214
+SHA256 808bbc351b76a2d1f4ed2ae0270426a966819b8278a200501071e2067467a873 SearchAndRescue-data-0.8.2.tar.bz2 7232214
diff --git a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc412.patch b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc412.patch
new file mode 100644
index 000000000000..48384693f4ee
--- /dev/null
+++ b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc412.patch
@@ -0,0 +1,56 @@
+--- sar/string.cpp.old 2007-05-31 21:48:38.000000000 +0200
++++ sar/string.cpp 2007-05-31 21:48:50.000000000 +0200
+@@ -3,7 +3,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+
+-extern char *tzname[2];
++extern "C" char *tzname[2];
+
+ #include <time.h>
+ #include "../include/os.h"
+--- sar/explosion.c.old 2007-05-31 22:02:05.000000000 +0200
++++ sar/explosion.c 2007-05-31 22:02:15.000000000 +0200
+@@ -1,4 +1,5 @@
+ #include <stdlib.h>
++#include <string.h>
+ #include "v3dtex.h"
+ #include "obj.h"
+ #include "objutils.h"
+--- sar/fire.c.old 2007-05-31 22:03:08.000000000 +0200
++++ sar/fire.c 2007-05-31 22:03:34.000000000 +0200
+@@ -1,4 +1,5 @@
+ #include <stdlib.h>
++#include <string.h>
+ #include "v3dtex.h"
+ #include "obj.h"
+ #include "objutils.h"
+--- sar/sardraw.c.old 2007-05-31 22:13:32.000000000 +0200
++++ sar/sardraw.c 2007-05-31 22:13:57.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <math.h>
++#include <string.h>
+
+ #ifdef __MSW__
+ # include <windows.h>
+--- sar/sardrawmessages.c.old 2007-05-31 22:14:43.000000000 +0200
++++ sar/sardrawmessages.c 2007-05-31 22:15:02.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <math.h>
++#include <string.h>
+
+ #ifdef __MSW__
+ # include <windows.h>
+--- sar/sardrawrunway.c.old 2007-05-31 22:17:02.000000000 +0200
++++ sar/sardrawrunway.c 2007-05-31 22:17:35.000000000 +0200
+@@ -1,5 +1,6 @@
+ #include <math.h>
+ #include <sys/types.h>
++#include <string.h>
+
+ #ifdef __MSW__
+ # include <windows.h>
diff --git a/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild b/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..64852d7a7597
--- /dev/null
+++ b/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild,v 1.1 2007/05/31 20:55:43 tupone Exp $
+
+inherit eutils games
+
+MY_PN=SearchAndRescue
+DESCRIPTION="Helicopter based air rescue flight simulator"
+HOMEPAGE="http://wolfpack.twu.net/SearchAndRescue/"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${MY_PN}-${PV}.tar.bz2
+ ftp://wolfpack.twu.net/users/wolfpack/${MY_PN}-data-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="joystick"
+
+RDEPEND="x11-libs/libXxf86vm
+ x11-libs/libXmu
+ x11-libs/libXi
+ x11-libs/libXpm
+ virtual/opengl
+ virtual/glu
+ media-libs/yiff
+ joystick? ( media-libs/libjsw )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${MY_PN}-${PV}.tar.bz2
+ mkdir data ; cd data
+ unpack ${MY_PN}-data-${PV}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc33.patch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-gcc412.patch
+ bunzip2 sar/man/${MY_PN}.6.bz2
+ sed -i \
+ -e '/FeatureCFLAGS.*march/s:=.*:=:g' sar/platforms.ini \
+ || die "sed failed"
+ sed -i \
+ -e "1i\#include <stdio.h>
+ " sar/gctl.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+
+ use joystick \
+ && myconf="--enable=libjsw" \
+ || myconf="--disable=libjsw"
+
+ # NOTE: not an autoconf script
+ ./configure Linux \
+ --prefix="${GAMES_PREFIX}" \
+ ${myconf} \
+ || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dogamesbin sar/${MY_PN} || die "dogamesbin failed"
+ doman sar/man/${MY_PN}.6
+ insinto /usr/share/icons/
+ doins sar/icons/*.{ico,xpm}
+ dodoc AUTHORS HACKING README
+ newicon sar/icons/SearchAndRescue.xpm ${PN}.xpm
+ cd "${WORKDIR}/data"
+ dodir "${GAMES_DATADIR}/${MY_PN}"
+ cp -r * "${D}/${GAMES_DATADIR}/${MY_PN}/" || die "cp failed"
+ make_desktop_entry SearchAndRescue "SearchAndRescue" \
+ /usr/share/pixmaps/${PN}.xpm
+ prepgamesdirs
+}