summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-02-08 16:25:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-02-08 16:25:56 +0000
commit6796ac1d08d613cde40f18a10ff5d10fd7bcd3ea (patch)
tree9c2d8c4e594dcff3d73be2b13e34be4f0775ab66 /games-simulation
parentold (diff)
downloadgentoo-2-6796ac1d08d613cde40f18a10ff5d10fd7bcd3ea.tar.gz
gentoo-2-6796ac1d08d613cde40f18a10ff5d10fd7bcd3ea.tar.bz2
gentoo-2-6796ac1d08d613cde40f18a10ff5d10fd7bcd3ea.zip
Fix building on non-x86_32 platforms (bug #430448)
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/searchandrescue/ChangeLog6
-rw-r--r--games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index 6a63b908288c..cd736a522b1c 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/searchandrescue
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.41 2014/02/08 16:02:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.42 2014/02/08 16:25:56 mr_bones_ Exp $
+
+ 08 Feb 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ searchandrescue-1.5.0.ebuild:
+ Fix building on non-x86_32 platforms (bug #430448)
08 Feb 2014; Michael Sterrett <mr_bones_@gentoo.org>
-files/searchandrescue-1.4.0-build.patch, -searchandrescue-1.4.0.ebuild:
diff --git a/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild b/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild
index e796fa8e8369..ae2d775ba1a1 100644
--- a/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild
+++ b/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild,v 1.4 2013/12/24 12:51:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild,v 1.5 2014/02/08 16:25:56 mr_bones_ Exp $
EAPI=5
inherit eutils flag-o-matic toolchain-funcs games
@@ -42,9 +42,13 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${P}-build.patch
+ rm pconf/pconf || die
+ sed -i -e '/Wall/s/$/ $(CFLAGS)/' pconf/Makefile || die
}
src_configure() {
+ emake CC=$(tc-getCC) -C pconf pconf # Needed for the configure script
+
append-flags -DNEW_GRAPHICS -DHAVE_SDL_MIXER
export CPP="$(tc-getCXX)"
export CPPFLAGS="${CXXFLAGS}"