summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-09-17 10:47:40 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-09-17 10:47:40 +0000
commit4b5a6442546505b565a690746a9db4c310a3f865 (patch)
tree6c4799e52ad43324df786d379367a4d5a5d504db /games-simulation
parentAdd support for Mercury deep profiler. (diff)
downloadgentoo-2-4b5a6442546505b565a690746a9db4c310a3f865.tar.gz
gentoo-2-4b5a6442546505b565a690746a9db4c310a3f865.tar.bz2
gentoo-2-4b5a6442546505b565a690746a9db4c310a3f865.zip
Version bump. Bug #139938
(Portage version: 2.1.1)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/planets/ChangeLog7
-rw-r--r--games-simulation/planets/files/digest-planets-0.1.123
-rw-r--r--games-simulation/planets/planets-0.1.12.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/games-simulation/planets/ChangeLog b/games-simulation/planets/ChangeLog
index 5ab719a796e8..1c840631b28a 100644
--- a/games-simulation/planets/ChangeLog
+++ b/games-simulation/planets/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/planets
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/ChangeLog,v 1.9 2006/05/24 21:44:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/ChangeLog,v 1.10 2006/09/17 10:47:40 tupone Exp $
+
+*planets-0.1.12 (17 Sep 2006)
+
+ 17 Sep 2006; <tupone@gentoo.org> +planets-0.1.12.ebuild:
+ Version bump. Bug #139938 by Michael Vogt
24 May 2006; Michael Sterrett <mr_bones_@gentoo.org>
planets-0.1.10.ebuild:
diff --git a/games-simulation/planets/files/digest-planets-0.1.12 b/games-simulation/planets/files/digest-planets-0.1.12
new file mode 100644
index 000000000000..120eca816835
--- /dev/null
+++ b/games-simulation/planets/files/digest-planets-0.1.12
@@ -0,0 +1,3 @@
+MD5 4b99c7010190c2f369496d14f12c3cc6 planets-0.1.12.tgz 50010
+RMD160 e634b643411cdbfa9b6bbbbf8d862ba179ac962d planets-0.1.12.tgz 50010
+SHA256 a895f04c64fd061ac866d32a0356beb8a687022a7cb773c86c8d7d8b084f6ad9 planets-0.1.12.tgz 50010
diff --git a/games-simulation/planets/planets-0.1.12.ebuild b/games-simulation/planets/planets-0.1.12.ebuild
new file mode 100644
index 000000000000..a1a696c7db78
--- /dev/null
+++ b/games-simulation/planets/planets-0.1.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/planets-0.1.12.ebuild,v 1.1 2006/09/17 10:47:40 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="a simple interactive planetary system simulator"
+SRC_URI="http://planets.homedns.org/dist/${P}.tgz"
+HOMEPAGE="http://planets.homedns.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/tcl
+ dev-lang/tk"
+DEPEND="${RDEPEND}
+ dev-lang/ocaml"
+
+pkg_setup() {
+ # response to bug #134257
+ if ! built_with_use dev-lang/ocaml tcltk ; then
+ eerror "${PN} doesn't build properly if"
+ eerror "dev-lang/ocaml is built without tcltk support."
+ die "Please emerge dev-lang/ocaml with USE=tcltk"
+ fi
+ games_pkg_setup
+}
+
+src_compile() {
+ make clean
+ make planets || die "make failed"
+}
+
+src_install() {
+ dogamesbin planets || die "dogamesbin failed"
+ doman planets.1
+ dodoc CREDITS CHANGES TODO KEYBINDINGS.txt README
+ prepgamesdirs
+}