summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2012-01-21 15:57:35 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2012-01-21 15:57:35 +0000
commit803662b82c1ab5de20401b4f8ef043ec90b9f0a3 (patch)
tree9e80ca10ed6c9c7ac7c662f30d621195c3548c21 /games-simulation/fgrun/fgrun-1.6.0.ebuild
parentFix installing pam_systemd.so to /lib*/security. Also, backport a few other f... (diff)
downloadgentoo-2-803662b82c1ab5de20401b4f8ef043ec90b9f0a3.tar.gz
gentoo-2-803662b82c1ab5de20401b4f8ef043ec90b9f0a3.tar.bz2
gentoo-2-803662b82c1ab5de20401b4f8ef043ec90b9f0a3.zip
Version bump, remove old, fixes bug 398247
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation/fgrun/fgrun-1.6.0.ebuild')
-rw-r--r--games-simulation/fgrun/fgrun-1.6.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-simulation/fgrun/fgrun-1.6.0.ebuild b/games-simulation/fgrun/fgrun-1.6.0.ebuild
new file mode 100644
index 000000000000..48ac430cd940
--- /dev/null
+++ b/games-simulation/fgrun/fgrun-1.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.6.0.ebuild,v 1.1 2012/01/21 15:57:35 reavertm Exp $
+
+EAPI=3
+inherit autotools eutils multilib games
+
+DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
+HOMEPAGE="http://sourceforge.net/projects/fgrun"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-games/openscenegraph-3.0.1
+ sys-libs/zlib
+ x11-libs/fltk:1[opengl,threads]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-games/simgear-2
+ >=dev-libs/boost-1.34
+"
+RDEPEND="${COMMON_DEPEND}
+ >=games-simulation/flightgear-2
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.5.2-fltk.patch"
+ AT_M4DIR=. eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS
+ prepgamesdirs
+}