summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-07-26 10:28:31 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-07-26 10:28:31 +0000
commitc8c57f5137b7b2f2ed11d78bc87c4a993f2ccfed (patch)
tree4c627a8d14912636d949464130bed34b783f2799 /games-rpg
parentx86 stable per bug 376369 (diff)
downloadgentoo-2-c8c57f5137b7b2f2ed11d78bc87c4a993f2ccfed.tar.gz
gentoo-2-c8c57f5137b7b2f2ed11d78bc87c4a993f2ccfed.tar.bz2
gentoo-2-c8c57f5137b7b2f2ed11d78bc87c4a993f2ccfed.zip
Enabling translation. Bug #211203
(Portage version: 2.1.10.7/cvs/Linux i686)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/bass/ChangeLog6
-rw-r--r--games-rpg/bass/bass-1.2-r1.ebuild5
-rw-r--r--games-rpg/bass/files/scummvmGetLang.sh19
3 files changed, 27 insertions, 3 deletions
diff --git a/games-rpg/bass/ChangeLog b/games-rpg/bass/ChangeLog
index 5759f2dc3a42..352acbd7df37 100644
--- a/games-rpg/bass/ChangeLog
+++ b/games-rpg/bass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/bass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/bass/ChangeLog,v 1.12 2011/02/13 17:54:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/bass/ChangeLog,v 1.13 2011/07/26 10:28:31 tupone Exp $
+
+ 26 Jul 2011; Tupone Alfredo <tupone@gentoo.org> bass-1.2-r1.ebuild,
+ +files/scummvmGetLang.sh:
+ Enabling translation. Bug #211203 by Pacho Ramos
13 Feb 2011; Raúl Porcel <armin76@gentoo.org> bass-1.2-r1.ebuild:
Drop sparc keywords, move to ~ppc as scummvm is not stable
diff --git a/games-rpg/bass/bass-1.2-r1.ebuild b/games-rpg/bass/bass-1.2-r1.ebuild
index a53b6b386ab7..22fc60dd5727 100644
--- a/games-rpg/bass/bass-1.2-r1.ebuild
+++ b/games-rpg/bass/bass-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/bass/bass-1.2-r1.ebuild,v 1.4 2011/02/13 17:54:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/bass/bass-1.2-r1.ebuild,v 1.5 2011/07/26 10:28:31 tupone Exp $
inherit eutils games
@@ -22,7 +22,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/bass-cd-${PV}
src_install() {
- games_make_wrapper bass "scummvm -f -p \"${GAMES_DATADIR}/${PN}\" sky" .
+ games_make_wrapper bass "scummvm -f -p \"${GAMES_DATADIR}/${PN}\" -q\$(scummvmGetLang.sh) sky" .
+ dogamesbin "${FILESDIR}"/scummvmGetLang.sh
insinto "${GAMES_DATADIR}"/${PN}
doins sky.* || die "doins failed"
dodoc readme.txt
diff --git a/games-rpg/bass/files/scummvmGetLang.sh b/games-rpg/bass/files/scummvmGetLang.sh
new file mode 100644
index 000000000000..b313cc7d81da
--- /dev/null
+++ b/games-rpg/bass/files/scummvmGetLang.sh
@@ -0,0 +1,19 @@
+tmplang="$LANG"
+test "$LC_MESSAGES" != "" && tmplang="$LC_MESSAGES"
+test "$LC_ALL" != "" && tmplang="$LC_ALL"
+test "$LANGUAGE" != "" && tmplang="$LANGUAGE"
+
+lang=`echo $tmplang|cut -d "_" -f 1`
+
+case $lang in
+ en)
+ lang=gb
+ echo $tmplang | grep en_US &>/dev/null && lang=en
+ ;;
+ de|fr|it|pt|es|se)
+ ;;
+ *)
+ lang=gb
+ ;;
+esac
+echo $lang