summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-09-19 16:43:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-09-19 16:43:31 +0000
commitb5da58d8edfb0f7e744f2ea6053b951e7d63dc35 (patch)
tree47bbaabbaea57456b6136434462aa1dcc515f68d /games-rpg
parentadd tmw-0.0.21 for now (diff)
downloadgentoo-2-b5da58d8edfb0f7e744f2ea6053b951e7d63dc35.tar.gz
gentoo-2-b5da58d8edfb0f7e744f2ea6053b951e7d63dc35.tar.bz2
gentoo-2-b5da58d8edfb0f7e744f2ea6053b951e7d63dc35.zip
version bump
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/tmw/ChangeLog7
-rw-r--r--games-rpg/tmw/files/digest-tmw-0.0.216
-rw-r--r--games-rpg/tmw/tmw-0.0.21.ebuild53
3 files changed, 65 insertions, 1 deletions
diff --git a/games-rpg/tmw/ChangeLog b/games-rpg/tmw/ChangeLog
index f9ba9ae6b1ca..fba06ffda899 100644
--- a/games-rpg/tmw/ChangeLog
+++ b/games-rpg/tmw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/tmw
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.18 2006/08/01 22:26:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.19 2006/09/19 16:43:31 mr_bones_ Exp $
+
+*tmw-0.0.21 (19 Sep 2006)
+
+ 19 Sep 2006; Michael Sterrett <mr_bones_@gentoo.org> +tmw-0.0.21.ebuild:
+ version bump
01 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org> tmw-0.0.20.ebuild:
needs guichan-0.4
diff --git a/games-rpg/tmw/files/digest-tmw-0.0.21 b/games-rpg/tmw/files/digest-tmw-0.0.21
new file mode 100644
index 000000000000..d4adb36edcaf
--- /dev/null
+++ b/games-rpg/tmw/files/digest-tmw-0.0.21
@@ -0,0 +1,6 @@
+MD5 e13a748b8e279fa694db5eb14ac4a8a9 tmw-0.0.21.tar.gz 3363620
+RMD160 ff94073c229e37d5c6ff48a87a231fcd860d73f6 tmw-0.0.21.tar.gz 3363620
+SHA256 180470d0d3e0977ef3f0bb8990b2aa12c5d6325b0086a955fdbff914dcf82bb3 tmw-0.0.21.tar.gz 3363620
+MD5 54ccc5d114eeb70d2bcb866e1e686c25 tmw-Magick-Real.ogg 840811
+RMD160 d293aff31cc3f2b57bbb9a91c7b444c4fda5c375 tmw-Magick-Real.ogg 840811
+SHA256 9cd8ffc59689fadb35884309cab14cc1c23ed1061fadec26b875688d2bbff13b tmw-Magick-Real.ogg 840811
diff --git a/games-rpg/tmw/tmw-0.0.21.ebuild b/games-rpg/tmw/tmw-0.0.21.ebuild
new file mode 100644
index 000000000000..b803398c71cd
--- /dev/null
+++ b/games-rpg/tmw/tmw-0.0.21.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.21.ebuild,v 1.1 2006/09/19 16:43:31 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A fully free and open source MMORPG game with the looks of \"old-fashioned\" 2D RPG"
+HOMEPAGE="http://themanaworld.org/"
+SRC_URI="mirror://sourceforge/themanaworld/${P}.tar.gz
+ mirror://gentoo/tmw-Magick-Real.ogg"
+# http://riekale.com/~rotonen/tmw/data/music/Magick%20-%20Real.ogg"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND=">=dev-games/physfs-1.0.0
+ opengl? ( virtual/opengl )
+ dev-libs/libxml2
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-net
+ net-misc/curl
+ >=dev-games/guichan-0.5.0"
+
+pkg_setup() {
+ games_pkg_setup
+ if ! built_with_use dev-games/guichan sdl ; then
+ eerror "dev-games/guichan needs to be built with USE=sdl"
+ die "please re-emerge guichan with USE=sdl"
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cp "${DISTDIR}"/tmw-Magick-Real.ogg . || die
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.0.12-desktop.patch
+}
+
+src_compile() {
+ egamesconf $(use_with opengl) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ insinto "${GAMES_DATADIR}"/${PN}/data/music
+ newins "${WORKDIR}"/tmw-Magick-Real.ogg "Magick - Real.ogg" || die
+ dodoc AUTHORS ChangeLog NEWS README
+ prepgamesdirs
+}