summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-10-27 22:42:20 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-10-27 22:42:20 +0000
commita8208e17f18ad1bbb1951d86fb97e5ce2040f2db (patch)
tree9cfa02bad48e6ac1be7d5df9b929960d8e650e8f /games-puzzle
parentstable ppc64, bug 244526 (diff)
downloadgentoo-2-a8208e17f18ad1bbb1951d86fb97e5ce2040f2db.tar.gz
gentoo-2-a8208e17f18ad1bbb1951d86fb97e5ce2040f2db.tar.bz2
gentoo-2-a8208e17f18ad1bbb1951d86fb97e5ce2040f2db.zip
Fixing font loading problem. Bug #162048
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xblockout/ChangeLog9
-rw-r--r--games-puzzle/xblockout/files/xblockout-1.1.5-font.patch46
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.5-r1.ebuild56
3 files changed, 110 insertions, 1 deletions
diff --git a/games-puzzle/xblockout/ChangeLog b/games-puzzle/xblockout/ChangeLog
index 563369e8bcb0..ec7cbf8362fc 100644
--- a/games-puzzle/xblockout/ChangeLog
+++ b/games-puzzle/xblockout/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-puzzle/xblockout
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/ChangeLog,v 1.18 2008/07/22 18:55:08 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/ChangeLog,v 1.19 2008/10/27 22:42:20 tupone Exp $
+
+*xblockout-1.1.5-r1 (27 Oct 2008)
+
+ 27 Oct 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/xblockout-1.1.5-font.patch, +xblockout-1.1.5-r1.ebuild:
+ Fixing font loading problem. Bug #162048 by NorthLite
+ amd64 added again.
22 Jul 2008; Santiago M. Mola <coldwind@gentoo.org>
xblockout-1.1.5.ebuild:
diff --git a/games-puzzle/xblockout/files/xblockout-1.1.5-font.patch b/games-puzzle/xblockout/files/xblockout-1.1.5-font.patch
new file mode 100644
index 000000000000..bb0302963bdc
--- /dev/null
+++ b/games-puzzle/xblockout/files/xblockout-1.1.5-font.patch
@@ -0,0 +1,46 @@
+--- initmenu.c.old 2008-10-27 23:23:43.000000000 +0100
++++ initmenu.c 2008-10-27 23:22:52.000000000 +0100
+@@ -408,19 +408,17 @@
+ XCharStruct overall_return ;
+
+ m->xfont = XLoadQueryFont( x->display , opt->thefont ) ;
+- m->font = XLoadFont( x->display , opt->thefont ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font=%s\n", opt->thefont) ;
+ }
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"Some problems when loading a font... trying others\n") ;
+ m->xfont = XLoadQueryFont( x->display ,
+ "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- m->font = XLoadFont( x->display ,
+- "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ m->font = m->xfont->fid;
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"You haven't -*-*-*-*-*-*-*-*-*-*-*-*-*-*\n");
+ fprintf(stderr,"Have you A font?\n");
+@@ -428,17 +426,17 @@
+ exit(1) ;
+ }
+ }
++ m->font = m->xfont->fid;
+ m->xfont2 = XLoadQueryFont( x->display , opt->thefont2 ) ;
+- m->font2 = XLoadFont( x->display , opt->thefont2 ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font2=%s\n", opt->thefont2) ;
+ }
+- if ( m->font2==BadAlloc || m->font2==BadName || m->xfont2==0 )
++ if ( m->xfont2==0 )
+ {
+- m->font2 = m->font ;
+ m->xfont2 = m->xfont ;
+ }
++ m->font2 = m->xfont2->fid;
+
+ xgc.background = x->back_pixel ;
+ xgc.foreground = opt->backcolor!=7 ? x->white_pixel : x->black_pixel;
diff --git a/games-puzzle/xblockout/xblockout-1.1.5-r1.ebuild b/games-puzzle/xblockout/xblockout-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..b7c83c95810a
--- /dev/null
+++ b/games-puzzle/xblockout/xblockout-1.1.5-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.1.5-r1.ebuild,v 1.1 2008/10/27 22:42:20 tupone Exp $
+
+inherit flag-o-matic eutils games
+
+DESCRIPTION="X Window block dropping game in 3 Dimension"
+HOMEPAGE="http://www710.univ-lyon1.fr/ftp/xbl/xbl.html"
+SRC_URI="http://www710.univ-lyon1.fr/~exco/XBL/xbl-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXext"
+
+S=${WORKDIR}/xbl-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-font.patch
+
+ sed -i \
+ -e 's:-lm:-lm -lX11:' \
+ -e '/DGROUP_GID/d' \
+ -e "s:-g$:${CFLAGS}:" \
+ Makefile.in || die "sed failed"
+}
+
+src_compile() {
+ # Don't know about other archs. --slarti
+ use amd64 && filter-flags "-fweb"
+
+ egamesconf || die
+ emake \
+ USE_SETGID= \
+ SCOREDIR="${GAMES_DATADIR}/${PN}" \
+ RESOURCEDIR="${GAMES_DATADIR}/${PN}" \
+ || die "emake failed"
+}
+
+src_install() {
+ newgamesbin bl xbl || die "newgamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins Xbl.ad Xbl || die "doins failed"
+
+ newman xbl.man xbl.6
+ dodoc README xbl-README
+ dohtml *.html *.gif
+
+ prepgamesdirs
+}