summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-07 21:32:51 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-07 21:32:51 +0000
commit62d2f873c879406886e9330435ae7585571d4453 (patch)
tree4f1f435d8fc6f37c692d1cb8ee360e09f59dbd74 /games-puzzle/kiki
parentInstall inside /usr/libexec to workaround multilib problems, and fix cups-con... (diff)
downloadgentoo-2-62d2f873c879406886e9330435ae7585571d4453.tar.gz
gentoo-2-62d2f873c879406886e9330435ae7585571d4453.tar.bz2
gentoo-2-62d2f873c879406886e9330435ae7585571d4453.zip
Fix for gcc-4.1
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'games-puzzle/kiki')
-rw-r--r--games-puzzle/kiki/ChangeLog6
-rw-r--r--games-puzzle/kiki/files/digest-kiki-0.9.0-r12
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch10
-rw-r--r--games-puzzle/kiki/kiki-1.0.2.ebuild3
4 files changed, 19 insertions, 2 deletions
diff --git a/games-puzzle/kiki/ChangeLog b/games-puzzle/kiki/ChangeLog
index 17291e99c2aa..bc9efecd5739 100644
--- a/games-puzzle/kiki/ChangeLog
+++ b/games-puzzle/kiki/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/kiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.8 2006/03/16 20:45:24 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.9 2006/05/07 21:32:51 tupone Exp $
+
+ 07 May 2006; <Tupone@gentoo.org> +files/kiki-1.0.2-gcc41.patch,
+ kiki-1.0.2.ebuild:
+ Fix for gcc-4.1
*kiki-1.0.2 (16 Mar 2006)
diff --git a/games-puzzle/kiki/files/digest-kiki-0.9.0-r1 b/games-puzzle/kiki/files/digest-kiki-0.9.0-r1
index 1f8c68b9ed64..330397ecfbd5 100644
--- a/games-puzzle/kiki/files/digest-kiki-0.9.0-r1
+++ b/games-puzzle/kiki/files/digest-kiki-0.9.0-r1
@@ -1 +1,3 @@
MD5 60ec6bdf0196c9c934f683d3bf7a12ea kiki-src-0.9.0.tgz 2978977
+RMD160 4afe5ba12765f42e612014ebceca7f520dfefdbb kiki-src-0.9.0.tgz 2978977
+SHA256 610e8a131833d0c8a2fcbb0105aa3153c9961cccc530a7685d7f268bb7bbc1e4 kiki-src-0.9.0.tgz 2978977
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch b/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch
new file mode 100644
index 000000000000..05bdd3707ec7
--- /dev/null
+++ b/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch
@@ -0,0 +1,10 @@
+--- src/main/KikiPythonWidget.h.old 2006-05-07 23:14:09.000000000 +0200
++++ src/main/KikiPythonWidget.h 2006-05-07 23:17:20.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include "KikiPos.h"
+ #include <KTextField.h>
+
++class KikiPython;
+ class KikiPythonWidget : public KTextField
+ {
+ friend class KikiPython;
diff --git a/games-puzzle/kiki/kiki-1.0.2.ebuild b/games-puzzle/kiki/kiki-1.0.2.ebuild
index a519068d8ac3..adf6d5c6e740 100644
--- a/games-puzzle/kiki/kiki-1.0.2.ebuild
+++ b/games-puzzle/kiki/kiki-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2.ebuild,v 1.1 2006/03/16 20:45:25 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2.ebuild,v 1.2 2006/05/07 21:32:51 tupone Exp $
inherit eutils python games
@@ -25,6 +25,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch
# There are CVS directories in the tgz file
rm -rf $(find -name CVS -type d)
rm -rf $(find -name .cvsignore)