summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-11 00:25:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-11 00:25:45 +0000
commit085b26769519ba69979716ddf745acece118d220 (patch)
treeee991bb58936bf31d64c756610f9d9e9a214f3c1 /games-puzzle/groundhog
parentVersion bump. (diff)
downloadgentoo-2-085b26769519ba69979716ddf745acece118d220.tar.gz
gentoo-2-085b26769519ba69979716ddf745acece118d220.tar.bz2
gentoo-2-085b26769519ba69979716ddf745acece118d220.zip
EAPI=2
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/groundhog')
-rw-r--r--games-puzzle/groundhog/ChangeLog7
-rw-r--r--games-puzzle/groundhog/groundhog-1.4.ebuild20
2 files changed, 17 insertions, 10 deletions
diff --git a/games-puzzle/groundhog/ChangeLog b/games-puzzle/groundhog/ChangeLog
index 39b6495e48c9..bdfc5b844c91 100644
--- a/games-puzzle/groundhog/ChangeLog
+++ b/games-puzzle/groundhog/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/groundhog
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/ChangeLog,v 1.14 2008/10/14 18:20:22 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/ChangeLog,v 1.15 2009/09/11 00:25:45 mr_bones_ Exp $
+
+ 11 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org> groundhog-1.4.ebuild:
+ EAPI=2
14 Oct 2008; Michael Sterrett <mr_bones_@gentoo.org> groundhog-1.4.ebuild:
add dev-util/pkgconfig dep (bug #239709)
diff --git a/games-puzzle/groundhog/groundhog-1.4.ebuild b/games-puzzle/groundhog/groundhog-1.4.ebuild
index c26c92047204..1783421d9a24 100644
--- a/games-puzzle/groundhog/groundhog-1.4.ebuild
+++ b/games-puzzle/groundhog/groundhog-1.4.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/groundhog-1.4.ebuild,v 1.21 2008/10/14 18:20:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/groundhog-1.4.ebuild,v 1.22 2009/09/11 00:25:45 mr_bones_ Exp $
+EAPI=2
inherit eutils autotools games
DEB_VER="9"
@@ -15,15 +16,15 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="nls"
-RDEPEND="=x11-libs/gtk+-2*
+RDEPEND="x11-libs/gtk+:2
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- epatch "${WORKDIR}"/groundhog_${PV}-${DEB_VER}.diff
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch groundhog_${PV}-${DEB_VER}.diff
cd "${S}"
epatch $(sed -e 's:^:debian/patches/:' debian/patches/series)
AT_M4DIR="m4" eautoreconf
@@ -32,9 +33,12 @@ src_unpack() {
|| die "sed failed"
}
-src_compile() {
+src_configure() {
egamesconf $(use_enable nls) || die
- emake CXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_compile() {
+ emake -j1 || die
}
src_install() {