summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-11-09 09:06:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-11-09 09:06:13 +0000
commitb508a7ce6bba1807770ae6befc8b8740c31d5ba5 (patch)
tree52ec0eb09b82117e9cbfa6d77db1cbd8168f64e4 /games-puzzle/arrows/arrows-0.6.ebuild
parentAdd patch from upstream bugzilla to fix crash. Reported by Florian Loitsch vi... (diff)
downloadgentoo-2-b508a7ce6bba1807770ae6befc8b8740c31d5ba5.tar.gz
gentoo-2-b508a7ce6bba1807770ae6befc8b8740c31d5ba5.tar.bz2
gentoo-2-b508a7ce6bba1807770ae6befc8b8740c31d5ba5.zip
tidy; prep for bug #69614
Diffstat (limited to 'games-puzzle/arrows/arrows-0.6.ebuild')
-rw-r--r--games-puzzle/arrows/arrows-0.6.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-puzzle/arrows/arrows-0.6.ebuild b/games-puzzle/arrows/arrows-0.6.ebuild
index 2abaf443a3f2..3429faea61f9 100644
--- a/games-puzzle/arrows/arrows-0.6.ebuild
+++ b/games-puzzle/arrows/arrows-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/arrows/arrows-0.6.ebuild,v 1.2 2004/06/24 23:02:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/arrows/arrows-0.6.ebuild,v 1.3 2004/11/09 09:06:13 mr_bones_ Exp $
inherit games
@@ -13,13 +13,11 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.4.0"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+DEPEND=">=x11-libs/gtk+-2.4.0"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Modify path to data
sed -i \
@@ -27,10 +25,12 @@ src_unpack() {
-e 's:nm\[9:nm[35:' \
-e 's:nm\[6:nm[30:' \
-e 's:nm\[7:nm[31:' \
- game.c || die "sed game.c failed"
+ game.c \
+ || die "sed game.c failed"
}
src_compile() {
+ make clean || die "make clean failed"
emake CCOPTS="${CFLAGS}" || die "emake failed"
}