summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-08 23:58:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-08 23:58:27 +0000
commit2ef622d86c9d08c3788ed9e49c657edc1dabda49 (patch)
treecf675002782622a0b10be0056f516103835e2e5c /games-mud
parentFixed digest. Upstream changed to version 0.3.4.1 without renumbering tarball (diff)
downloadgentoo-2-2ef622d86c9d08c3788ed9e49c657edc1dabda49.tar.gz
gentoo-2-2ef622d86c9d08c3788ed9e49c657edc1dabda49.tar.bz2
gentoo-2-2ef622d86c9d08c3788ed9e49c657edc1dabda49.zip
add patch for gcc34 (bug #61313)
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/kmuddy/ChangeLog6
-rw-r--r--games-mud/kmuddy/files/0.6.1-gcc34.patch22
-rw-r--r--games-mud/kmuddy/kmuddy-0.6.1.ebuild10
3 files changed, 35 insertions, 3 deletions
diff --git a/games-mud/kmuddy/ChangeLog b/games-mud/kmuddy/ChangeLog
index 483dd5dc6e26..beda4e0bdbc5 100644
--- a/games-mud/kmuddy/ChangeLog
+++ b/games-mud/kmuddy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-mud/kmuddy
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/kmuddy/ChangeLog,v 1.6 2004/06/24 23:00:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/kmuddy/ChangeLog,v 1.7 2004/09/08 23:58:27 mr_bones_ Exp $
+
+ 08 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.6.1-gcc34.patch, kmuddy-0.6.1.ebuild:
+ add patch for gcc34 (bug #61313)
*kmuddy-0.6.1 (09 Feb 2004)
diff --git a/games-mud/kmuddy/files/0.6.1-gcc34.patch b/games-mud/kmuddy/files/0.6.1-gcc34.patch
new file mode 100644
index 000000000000..e87849a766d0
--- /dev/null
+++ b/games-mud/kmuddy/files/0.6.1-gcc34.patch
@@ -0,0 +1,22 @@
+--- ctelnet.h.orig 2004-09-08 15:05:22.000000000 -0700
++++ ctelnet.h 2004-09-08 15:05:55.000000000 -0700
+@@ -267,7 +267,7 @@
+ for more information... */
+ bool announcedState[256];
+ /** whether the server has already announced his WILL/WON'T */
+- bool heAnnouncedState[256];;
++ bool heAnnouncedState[256];
+ /** whether we have tried to enable this option */
+ bool triedToEnable[256];
+ /** amount of bytes sent up to now */
+--- cdownloader.h.orig 2004-09-08 15:05:30.000000000 -0700
++++ cdownloader.h 2004-09-08 15:06:11.000000000 -0700
+@@ -30,7 +30,7 @@
+ #endif
+
+ //forward declaration for KIO::Job
+-namespace KIO { class Job; };
++namespace KIO { class Job; }
+
+ /**
+ Class used to download stuff.
diff --git a/games-mud/kmuddy/kmuddy-0.6.1.ebuild b/games-mud/kmuddy/kmuddy-0.6.1.ebuild
index d4cbe9263fe5..fdb789d515a0 100644
--- a/games-mud/kmuddy/kmuddy-0.6.1.ebuild
+++ b/games-mud/kmuddy/kmuddy-0.6.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/kmuddy/kmuddy-0.6.1.ebuild,v 1.3 2004/09/08 22:00:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/kmuddy/kmuddy-0.6.1.ebuild,v 1.4 2004/09/08 23:58:27 mr_bones_ Exp $
-inherit kde
+inherit eutils kde
need-kde 3
DESCRIPTION="MUD client for KDE"
@@ -13,3 +13,9 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+
+src_unpack() {
+ kde_src_unpack
+ cd "${S}/kmuddy"
+ epatch "${FILESDIR}/${PV}-gcc34.patch"
+}