summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2013-08-02 05:24:31 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2013-08-02 05:24:31 +0000
commit2dff57c1ca6692b35c26e43e41949d2efdd3d75a (patch)
tree54f2232fbdf1ded92b888077625e8c683974573c /games-misc
parentVersion bump. Convert to distutils-r1 and enable python3 support. (diff)
downloadgentoo-2-2dff57c1ca6692b35c26e43e41949d2efdd3d75a.tar.gz
gentoo-2-2dff57c1ca6692b35c26e43e41949d2efdd3d75a.tar.bz2
gentoo-2-2dff57c1ca6692b35c26e43e41949d2efdd3d75a.zip
Version bumped. Switched to EAPI=5.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 0xAA792A6A)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/fortune-mod-flashrider/ChangeLog10
-rw-r--r--games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/games-misc/fortune-mod-flashrider/ChangeLog b/games-misc/fortune-mod-flashrider/ChangeLog
index 8abb9389e764..4fc036242ee9 100644
--- a/games-misc/fortune-mod-flashrider/ChangeLog
+++ b/games-misc/fortune-mod-flashrider/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-misc/fortune-mod-flashrider
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod-flashrider/ChangeLog,v 1.6 2012/02/16 18:42:13 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod-flashrider/ChangeLog,v 1.7 2013/08/02 05:24:31 zzam Exp $
+
+*fortune-mod-flashrider-1.10 (02 Aug 2013)
+
+ 02 Aug 2013; Matthias Schwarzott <zzam@gentoo.org>
+ +fortune-mod-flashrider-1.10.ebuild:
+ Version bumped. Switched to EAPI=5.
16 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
fortune-mod-flashrider-1.00.ebuild:
diff --git a/games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10.ebuild b/games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10.ebuild
new file mode 100644
index 000000000000..cc1013ca223e
--- /dev/null
+++ b/games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10.ebuild,v 1.1 2013/08/02 05:24:31 zzam Exp $
+
+EAPI=5
+
+MY_PN="${PN/-mod/s}"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Quotes from Prolinux articles and comments"
+HOMEPAGE="http://downloads.nanolx.org/index.php?dir=fortunes-flashrider"
+SRC_URI="http://downloads.nanolx.org/fortunes-flashrider/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="games-misc/fortune-mod"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare()
+{
+ sed -e 's#INSTALLDIR = .*#INSTALLDIR = /share/fortune#' -i Makefile
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}"/usr DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog README
+}