summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-02 19:50:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-02 19:50:56 +0000
commitf56912cedf54ddf4d05bd4aaa9fdc2b932a89b6d (patch)
tree75d5b231c07f6b5fee4544dbe1ba2fb63d6ffaca /games-misc/qlife
parentVersion bump KDE 4.4.1 (diff)
downloadgentoo-2-f56912cedf54ddf4d05bd4aaa9fdc2b932a89b6d.tar.gz
gentoo-2-f56912cedf54ddf4d05bd4aaa9fdc2b932a89b6d.tar.bz2
gentoo-2-f56912cedf54ddf4d05bd4aaa9fdc2b932a89b6d.zip
Version bump wrt #264711, thanks to Markos Chandras for reporting.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'games-misc/qlife')
-rw-r--r--games-misc/qlife/ChangeLog9
-rw-r--r--games-misc/qlife/qlife-1.1.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/games-misc/qlife/ChangeLog b/games-misc/qlife/ChangeLog
index d880198d99fd..65b1cdd64f44 100644
--- a/games-misc/qlife/ChangeLog
+++ b/games-misc/qlife/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/qlife
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/qlife/ChangeLog,v 1.10 2008/08/14 17:18:48 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/qlife/ChangeLog,v 1.11 2010/03/02 19:50:56 ssuominen Exp $
+
+*qlife-1.1 (02 Mar 2010)
+
+ 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> +qlife-1.1.ebuild:
+ Version bump wrt #264711, thanks to Markos Chandras for reporting.
14 Aug 2008; nixnut <nixnut@gentoo.org> qlife-0.9.ebuild:
Stable on ppc wrt bug 234453
diff --git a/games-misc/qlife/qlife-1.1.ebuild b/games-misc/qlife/qlife-1.1.ebuild
new file mode 100644
index 000000000000..404b40e90700
--- /dev/null
+++ b/games-misc/qlife/qlife-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/qlife/qlife-1.1.ebuild,v 1.1 2010/03/02 19:50:56 ssuominen Exp $
+
+EAPI=2
+inherit eutils qt4-r2 games
+
+MY_PN=${PN/ql/QL}
+
+DESCRIPTION="Simulates the classical Game of Life invented by John Conway"
+HOMEPAGE="http://open-maker.tuxfamily.org/blog/index.php?post/2009/03/28/QLife"
+SRC_URI="http://open-maker.tuxfamily.org/blog/public/${PN}_linux.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4"
+
+S=${WORKDIR}/${MY_PN}/sources
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ dogamesbin ${MY_PN} || die
+ newicon data/egg.png ${PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN}
+ prepgamesdirs
+}