summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-11-14 17:04:24 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-11-14 17:04:24 +0000
commitda77edd4f6a3343506f766086073bd28dd5f19a3 (patch)
treef64e42227dd4a2c264546f9a7867943eb7cd7dd4 /games-fps
parentDelete older ebuild. (diff)
downloadgentoo-2-da77edd4f6a3343506f766086073bd28dd5f19a3.tar.gz
gentoo-2-da77edd4f6a3343506f766086073bd28dd5f19a3.tar.bz2
gentoo-2-da77edd4f6a3343506f766086073bd28dd5f19a3.zip
Workaround bug #285448; fix textrels on x86
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/warsow/ChangeLog9
-rw-r--r--games-fps/warsow/files/warsow-0.5-build.patch18
-rw-r--r--games-fps/warsow/files/warsow-0.5-pic.patch11
-rw-r--r--games-fps/warsow/warsow-0.5-r1.ebuild (renamed from games-fps/warsow/warsow-0.5.ebuild)20
4 files changed, 39 insertions, 19 deletions
diff --git a/games-fps/warsow/ChangeLog b/games-fps/warsow/ChangeLog
index e731c0f46255..7f9a538d2455 100644
--- a/games-fps/warsow/ChangeLog
+++ b/games-fps/warsow/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-fps/warsow
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.24 2009/10/05 17:46:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.25 2009/11/14 17:04:23 nyhm Exp $
+
+*warsow-0.5-r1 (14 Nov 2009)
+
+ 14 Nov 2009; Tristan Heaven <nyhm@gentoo.org> -warsow-0.5.ebuild,
+ +warsow-0.5-r1.ebuild, files/warsow-0.5-build.patch,
+ +files/warsow-0.5-pic.patch:
+ Workaround bug #285448; fix textrels on x86
05 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org> warsow-0.5.ebuild:
The code seems fragile. strip-flags to fix at least bug #285448 and
diff --git a/games-fps/warsow/files/warsow-0.5-build.patch b/games-fps/warsow/files/warsow-0.5-build.patch
index 84666db65b5f..b5989e582786 100644
--- a/games-fps/warsow/files/warsow-0.5-build.patch
+++ b/games-fps/warsow/files/warsow-0.5-build.patch
@@ -1,17 +1,17 @@
--- libsrcs/angelscript/angelSVN/sdk/angelscript/projects/gnuc/makefile
+++ libsrcs/angelscript/angelSVN/sdk/angelscript/projects/gnuc/makefile
-@@ -12,8 +12,8 @@
+@@ -12,7 +12,9 @@
INCDIR = ../../include
OBJDIR = obj
-CXX = gcc
--CXXFLAGS = -g -Wall -fPIC
-+CC ?= gcc
-+CFLAGS += -Wall -fPIC -fno-strict-aliasing
++CXX ?= g++
++# FIXME: https://bugs.gentoo.org/show_bug.cgi?id=285448
++#CXXFLAGS += -Wall -fPIC -fno-strict-aliasing
+ CXXFLAGS = -g -Wall -fPIC
DELETER = rm -f
COPIER = cp
-
-@@ -59,13 +59,13 @@
+@@ -59,8 +61,8 @@
all: $(BIN)
$(BIN): $(OBJ)
@@ -22,12 +22,6 @@
@echo -------------------------------------------------------------------
@echo Done. As root, type 'make install' to install the library.
- $(OBJDIR)/%.o: $(SRCDIR)/%.cpp
-- $(CXX) $(CXXFLAGS) -o $@ -c $<
-+ $(CC) $(CFLAGS) -o $@ -c $<
-
-
- clean:
--- source/Makefile
+++ source/Makefile
@@ -52,7 +52,7 @@
diff --git a/games-fps/warsow/files/warsow-0.5-pic.patch b/games-fps/warsow/files/warsow-0.5-pic.patch
new file mode 100644
index 000000000000..71c4d8eed690
--- /dev/null
+++ b/games-fps/warsow/files/warsow-0.5-pic.patch
@@ -0,0 +1,11 @@
+--- source/snd_qf/snd_mix.c
++++ source/snd_qf/snd_mix.c
+@@ -27,7 +27,7 @@
+ int *snd_p, snd_linear_count, snd_vol, music_vol;
+ short *snd_out;
+
+-#if !defined ( id386 ) || defined ( __MACOSX__ )
++#if defined ( PIC ) || !defined ( id386 ) || defined ( __MACOSX__ )
+ #ifdef _WIN32
+ #pragma warning( push )
+ #pragma warning( disable : 4310 ) // cast truncates constant value
diff --git a/games-fps/warsow/warsow-0.5.ebuild b/games-fps/warsow/warsow-0.5-r1.ebuild
index 3e3a7a6d91c5..9f1c0420aace 100644
--- a/games-fps/warsow/warsow-0.5.ebuild
+++ b/games-fps/warsow/warsow-0.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/warsow-0.5.ebuild,v 1.2 2009/10/05 17:46:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/warsow-0.5-r1.ebuild,v 1.1 2009/11/14 17:04:23 nyhm Exp $
EAPI=2
-inherit flag-o-matic eutils toolchain-funcs versionator games
+inherit eutils toolchain-funcs versionator games
MY_P=${PN}_${PV}
DESCRIPTION="Multiplayer FPS based on the QFusion engine (evolved from Quake 2)"
@@ -47,10 +47,11 @@ src_prepare() {
|| die "sed files.c failed"
cd "${WORKDIR}"
+ rm -rf docs/old
epatch \
"${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-openal.patch
- strip-flags
+ "${FILESDIR}"/${P}-openal.patch \
+ "${FILESDIR}"/${P}-pic.patch
}
src_compile() {
@@ -63,15 +64,22 @@ src_compile() {
use openal && openal="YES"
fi
- tc-export CC AR RANLIB
-
if use angelscript ; then
+ tc-export AR RANLIB
emake \
-C ../libsrcs/angelscript/angelSVN/sdk/angelscript/projects/gnuc \
|| die "emake angelscript failed"
fi
+ local arch
+ if use amd64 ; then
+ arch=x86_64
+ elif use x86 ; then
+ arch=i386
+ fi
+
emake \
+ BASE_ARCH=${arch} \
BINDIR=bin \
BUILD_CLIENT=${client} \
BUILD_SERVER=$(yesno dedicated) \