summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-11-03 23:28:31 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-11-03 23:28:31 +0000
commitb46c836f438b44d98b9627fe35b3d6481275ef78 (patch)
tree33dce9e2482cdc187b50b92c17f8f9482d2355d4 /games-fps
parentVersion bump, thanks Sebastian Mingramm for testing (diff)
downloadgentoo-2-b46c836f438b44d98b9627fe35b3d6481275ef78.tar.gz
gentoo-2-b46c836f438b44d98b9627fe35b3d6481275ef78.tar.bz2
gentoo-2-b46c836f438b44d98b9627fe35b3d6481275ef78.zip
Version bump, bug #290121
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alienarena/ChangeLog7
-rw-r--r--games-fps/alienarena/alienarena-20091016.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/games-fps/alienarena/ChangeLog b/games-fps/alienarena/ChangeLog
index 87c19e0291a9..e2932d22896f 100644
--- a/games-fps/alienarena/ChangeLog
+++ b/games-fps/alienarena/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/alienarena
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/ChangeLog,v 1.15 2009/10/14 18:34:20 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/ChangeLog,v 1.16 2009/11/03 23:28:31 nyhm Exp $
+
+*alienarena-20091016 (03 Nov 2009)
+
+ 03 Nov 2009; Tristan Heaven <nyhm@gentoo.org> +alienarena-20091016.ebuild:
+ Version bump, bug #290121
*alienarena-20091006 (14 Oct 2009)
diff --git a/games-fps/alienarena/alienarena-20091016.ebuild b/games-fps/alienarena/alienarena-20091016.ebuild
new file mode 100644
index 000000000000..c7790e1acfab
--- /dev/null
+++ b/games-fps/alienarena/alienarena-20091016.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/alienarena-20091016.ebuild,v 1.1 2009/11/03 23:28:31 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_PN=alienarena7_32
+DESCRIPTION="Fast-paced multiplayer deathmatch game"
+HOMEPAGE="http://red.planetarena.org/"
+SRC_URI="http://icculus.org/${PN}/Files/${PN}-linux${PV}.zip"
+
+LICENSE="GPL-2 free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+
+UIRDEPEND="media-libs/jpeg
+ media-libs/openal
+ media-libs/libvorbis
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm"
+RDEPEND="opengl? ( ${UIRDEPEND} )
+ !opengl? ( !dedicated? ( ${UIRDEPEND} ) )
+ net-misc/curl"
+UIDEPEND="x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto"
+DEPEND="${RDEPEND}
+ opengl? ( ${UIDEPEND} )
+ !opengl? ( !dedicated? ( ${UIDEPEND} ) )
+ dev-util/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_PN}/source
+
+src_prepare() {
+ rm -f ../*/*.so
+ sed -i \
+ -e 's:\($(SHLIBLDFLAGS)\):$(LDFLAGS) \1:' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ ARCH="unknown" \
+ OSTYPE="linux" \
+ OPTIMIZED_CFLAGS=no \
+ WITH_DATADIR=yes \
+ WITH_LIBDIR=yes \
+ DATADIR="${GAMES_DATADIR}"/${PN} \
+ LIBDIR="$(games_get_libdir)"/${PN} \
+ $(use opengl && ! use dedicated && echo BUILD=CLIENT) \
+ $(! use opengl && use dedicated && echo BUILD=DEDICATED) \
+ $(use opengl && use dedicated && echo BUILD=ALL) \
+ $(use opengl || use dedicated || echo BUILD=CLIENT) \
+ || die "emake failed"
+}
+
+src_install() {
+ cd release
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe game.so || die "doexe failed"
+ dosym . "$(games_get_libdir)"/${PN}/arena
+ dosym . "$(games_get_libdir)"/${PN}/data1
+
+ if use opengl || ! use dedicated ; then
+ newgamesbin crx ${PN} || die "newgamesbin crx failed"
+ make_desktop_entry ${PN} "Alien Arena"
+ fi
+
+ if use dedicated ; then
+ newgamesbin crded ${PN}-ded || die "newgamesbin crded failed"
+ fi
+
+ cd "${WORKDIR}"/${MY_PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r arena botinfo data1 || die "doins failed"
+ newicon aa.png ${PN}.png || die "newicon failed"
+ dodoc docs/README.txt
+
+ prepgamesdirs
+}