summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-05-21 12:31:13 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-05-21 12:31:13 +0000
commita4c34742fbc97a584df761796af2fba4476ffbf5 (patch)
tree50c2397a87c1b1c282cfea624e77eda14becbfd5 /games-fps
parentupdate (Manifest recommit) (diff)
downloadgentoo-2-a4c34742fbc97a584df761796af2fba4476ffbf5.tar.gz
gentoo-2-a4c34742fbc97a584df761796af2fba4476ffbf5.tar.bz2
gentoo-2-a4c34742fbc97a584df761796af2fba4476ffbf5.zip
Hoping to have fixed the CD/DVD detection in pkg_setup.
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2004/ChangeLog5
-rw-r--r--games-fps/ut2004/ut2004-3204.ebuild8
2 files changed, 6 insertions, 7 deletions
diff --git a/games-fps/ut2004/ChangeLog b/games-fps/ut2004/ChangeLog
index 2b85ccb7befb..262c2baed178 100644
--- a/games-fps/ut2004/ChangeLog
+++ b/games-fps/ut2004/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/ut2004
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.1 2004/05/20 20:39:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.2 2004/05/21 12:31:13 wolf31o2 Exp $
+
+ 21 May 2004; Chris Gianelloni <wolf31o2@gentoo.org> ut2004-3204.ebuild:
+ Hoping to have fixed the CD/DVD detection in pkg_setup.
*ut2004-3204 (20 May 2004)
diff --git a/games-fps/ut2004/ut2004-3204.ebuild b/games-fps/ut2004/ut2004-3204.ebuild
index 2e00341080c2..eb76260ca321 100644
--- a/games-fps/ut2004/ut2004-3204.ebuild
+++ b/games-fps/ut2004/ut2004-3204.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ut2004-3204.ebuild,v 1.1 2004/05/20 20:39:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ut2004-3204.ebuild,v 1.2 2004/05/21 12:31:13 wolf31o2 Exp $
inherit games
@@ -33,13 +33,9 @@ pkg_setup() {
if [ -n "${CD_ROOT}" ]; then
[ -d "${CD_ROOT}/CD1" ] && USE_DVD=1
else
- local cd_dir="$(dirname ${@})"
- local file="$(basename ${@})"
local mline=""
for mline in `mount | egrep -e '(iso|cdrom)' | awk '{print $3}'` ; do
- [ -d "${mline}/${cd_dir}" ] || continue
- [ ! -z "$(find ${mline}/${cd_dir} -iname ${file} -maxdepth 1)" ] \
- && [ -d "${mline}/CD1" ] && USE_DVD=1
+ [ -d "${mline}/CD1" ] && USE_DVD=1
done
fi
if [ ${USE_DVD} ]; then