summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-12-11 14:39:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-12-11 14:39:51 +0000
commita43ad1f742d3b4a263b9d6b866eabe7374b1e870 (patch)
treeb9dd1fb716d0146d809b895c2e16b33dcaaa6f30 /games-fps
parentFix bug #246568. (diff)
downloadgentoo-2-a43ad1f742d3b4a263b9d6b866eabe7374b1e870.tar.gz
gentoo-2-a43ad1f742d3b4a263b9d6b866eabe7374b1e870.tar.bz2
gentoo-2-a43ad1f742d3b4a263b9d6b866eabe7374b1e870.zip
old
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone/alephone-20061228.ebuild66
-rw-r--r--games-fps/alephone/files/alephone-20061228-configure.patch38
2 files changed, 0 insertions, 104 deletions
diff --git a/games-fps/alephone/alephone-20061228.ebuild b/games-fps/alephone/alephone-20061228.ebuild
deleted file mode 100644
index 830d04b53842..000000000000
--- a/games-fps/alephone/alephone-20061228.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20061228.ebuild,v 1.4 2007/07/05 20:04:34 corsair Exp $
-
-inherit autotools eutils games
-
-DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
-HOMEPAGE="http://source.bungie.org/"
-SRC_URI="mirror://sourceforge/marathon/AlephOne-${PV}-nolibs.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE="lua opengl speex"
-
-DEPEND="lua? ( dev-lang/lua )
- opengl? ( virtual/opengl )
- speex? ( media-libs/speex )
- dev-libs/boost
- media-libs/smpeg
- media-libs/libsdl
- media-libs/sdl-image
- media-libs/sdl-sound
- media-libs/sdl-net"
-
-S=${WORKDIR}/AlephOne-${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
- "${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \
- || die "sed failed"
- epatch "${FILESDIR}"/${P}-configure.patch
- eautoreconf
-}
-
-src_compile() {
- egamesconf \
- --disable-dependency-tracking \
- $(use_enable lua) \
- $(use_enable opengl) \
- $(use_enable speex) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dogamesbin "${T}"/${PN}.sh || die "dogamesbin failed"
- dodoc AUTHORS README docs/Cheat_Codes
- dohtml docs/MML.html
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- elog "Read the docs and install the data files accordingly to play."
- echo
- elog "If you only want to install one scenario, read"
- elog "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Single_scenario_3"
- elog "If you want to install multiple scenarios, read"
- elog "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Multiple_scenarios_3"
- echo
-}
diff --git a/games-fps/alephone/files/alephone-20061228-configure.patch b/games-fps/alephone/files/alephone-20061228-configure.patch
deleted file mode 100644
index c4b81e966361..000000000000
--- a/games-fps/alephone/files/alephone-20061228-configure.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- configure.ac
-+++ configure.ac
-@@ -15,6 +15,8 @@
-
- dnl Configure options.
- AC_ARG_ENABLE(opengl, [ --enable-opengl use OpenGL for rendering [default=yes]], , enable_opengl=yes)
-+AC_ARG_ENABLE(lua, , , enable_lua=yes)
-+AC_ARG_ENABLE(speex, , , enable_speex=yes)
-
- dnl Checks for programs.
- AC_PROG_CC
-@@ -98,6 +100,7 @@
- ])
- ])
-
-+if [[ "x$enable_lua" = "xyes" ]]; then
- dnl Check for Lua.
- AC_ARG_VAR(LUA_CFLAGS, [C compiler flags for Lua])
- AC_ARG_VAR(LUA_LIBS, [linker flags for Lua])
-@@ -124,14 +127,18 @@
- AC_DEFINE(HAVE_LUA_H, 1, [Assuming <lua.h> is present])
- AC_DEFINE(HAVE_LUALIB_H, 1, [Assuing <lualib.h> is present])
- fi
-+fi
-
-+if [[ "x$enable_speex" = "xyes" ]]; then
- dnl Check for Speex
-+CPPFLAGS="$CPPFLAGS -I/usr/include/speex"
- AC_CHECK_HEADERS(speex.h, [
- AC_CHECK_LIB(speex, speex_decoder_init, [
- LIBS="-lspeex $LIBS"
- AC_DEFINE(SPEEX, 1, [Speex support is enabled])
- ])
- ])
-+fi
-
- dnl Figure out which OpenGL library to use
- case "$target" in