summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-28 03:30:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-28 03:30:33 +0000
commit8f854b89cab04117c660eed96f65abb9d8919c40 (patch)
tree206e7ddd2d8e53ce1c29edef5947b783c138fec8 /games-fps
parentinitial ebuild #59642 by Dirk-Jan Heijs (Manifest recommit) (diff)
downloadgentoo-2-8f854b89cab04117c660eed96f65abb9d8919c40.tar.gz
gentoo-2-8f854b89cab04117c660eed96f65abb9d8919c40.tar.bz2
gentoo-2-8f854b89cab04117c660eed96f65abb9d8919c40.zip
Add install fixes by Erdroh Moshan #66437.
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake3/ChangeLog5
-rw-r--r--games-fps/quake3/quake3-1.31.ebuild19
2 files changed, 16 insertions, 8 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 5d095b77d580..ba2223f681e5 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/quake3
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.12 2004/09/01 20:31:51 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.13 2004/12/28 03:30:33 vapier Exp $
+
+ 27 Dec 2004; Mike Frysinger <vapier@gentoo.org> quake3-1.31.ebuild:
+ Add install fixes by Erdroh Moshan #66437.
01 Sep 2004; Chris Gianelloni <wolf31o2@gentoo.org> files/q3ded.rc:
Changing dedicated server user to games from games-ded.
diff --git a/games-fps/quake3/quake3-1.31.ebuild b/games-fps/quake3/quake3-1.31.ebuild
index ac17bfbf0912..4220ca3a73af 100644
--- a/games-fps/quake3/quake3-1.31.ebuild
+++ b/games-fps/quake3/quake3-1.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.31.ebuild,v 1.11 2004/07/14 14:44:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.31.ebuild,v 1.12 2004/12/28 03:30:33 vapier Exp $
inherit games
@@ -10,16 +10,23 @@ SRC_URI="ftp://ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-${PV}.x86.r
LICENSE="Q3AEULA"
SLOT="0"
-KEYWORDS="-* x86"
+KEYWORDS="-* amd64 x86"
IUSE="X dedicated opengl"
RESTRICT="nostrip"
RDEPEND="virtual/libc
opengl? ( virtual/opengl )
X? ( virtual/x11 )
- dedicated? ( app-misc/screen )"
+ dedicated? ( app-misc/screen )
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-nvidia
+ )"
S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
pkg_setup() {
check_license
@@ -31,19 +38,17 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
dodir ${dir}
insinto ${dir}/baseq3
doins baseq3/*.pk3
- mv Docs ${D}/${dir}/
+ mv Help ${Ddir}/
insinto ${dir}/missionpack
doins missionpack/*.pk3
- mv pb ${D}/${dir}/
exeinto ${dir}
insinto ${dir}
- doexe bin/Linux/x86/{quake3.x86,q3ded}
+ doexe bin/x86/{quake3.x86,q3ded}
doins quake3.xpm README* Q3A_EULA.txt
games_make_wrapper quake3 ./quake3.x86 ${dir}
games_make_wrapper q3ded ./q3ded ${dir}