summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-10-15 08:50:20 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-10-15 08:50:20 +0000
commit6d6f8789cfb45a26bdc0cd956c6d0847613d66c7 (patch)
tree648297d06819e45110385de31dc98d23a2bd6404 /games-fps
parentVersion bump. (diff)
downloadgentoo-2-6d6f8789cfb45a26bdc0cd956c6d0847613d66c7.tar.gz
gentoo-2-6d6f8789cfb45a26bdc0cd956c6d0847613d66c7.tar.bz2
gentoo-2-6d6f8789cfb45a26bdc0cd956c6d0847613d66c7.zip
Fix build with gcc-4.7 Bug #423037
(Portage version: 2.1.11.26/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone/ChangeLog7
-rw-r--r--games-fps/alephone/alephone-20100424.ebuild11
-rw-r--r--games-fps/alephone/files/alephone-20100424-gcc47.patch11
3 files changed, 22 insertions, 7 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index dea7df5d9ef1..2823a51ae4d7 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/alephone
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.40 2012/06/23 04:25:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.41 2012/10/15 08:50:20 tupone Exp $
+
+ 15 Oct 2012; Tupone Alfredo <tupone@gentoo.org> alephone-20100424.ebuild,
+ +files/alephone-20100424-gcc47.patch:
+ Fix build with gcc-4.7 Bug #423037 by Samuli Suominen
+ Moved to EAPI 4
23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> alephone-20100424.ebuild:
Fix building with sys-devel/automake >= 1.12 wrt #422557
diff --git a/games-fps/alephone/alephone-20100424.ebuild b/games-fps/alephone/alephone-20100424.ebuild
index d1c033509c72..fd38c8fb212a 100644
--- a/games-fps/alephone/alephone-20100424.ebuild
+++ b/games-fps/alephone/alephone-20100424.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20100424.ebuild,v 1.6 2012/06/23 04:25:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20100424.ebuild,v 1.7 2012/10/15 08:50:20 tupone Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils games
MY_P=AlephOne-${PV}
@@ -57,6 +57,7 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-boost_145.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-png15.patch
eautoreconf
@@ -64,7 +65,6 @@ src_prepare() {
src_configure() {
egamesconf \
- --disable-dependency-tracking \
--enable-lua \
$(use_enable alsa) \
$(use_enable mad) \
@@ -77,10 +77,9 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dogamesbin "${T}"/${PN}.sh || die "dogamesbin failed"
+ default
+ dogamesbin "${T}"/${PN}.sh
doman docs/${PN}.6
- dodoc AUTHORS ChangeLog README
dohtml docs/*.html
prepgamesdirs
}
diff --git a/games-fps/alephone/files/alephone-20100424-gcc47.patch b/games-fps/alephone/files/alephone-20100424-gcc47.patch
new file mode 100644
index 000000000000..1347d64592f9
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20100424-gcc47.patch
@@ -0,0 +1,11 @@
+--- Source_Files/Lua/lua_templates.h.old 2012-10-15 09:55:32.395310163 +0200
++++ Source_Files/Lua/lua_templates.h 2012-10-15 09:56:14.991129122 +0200
+@@ -496,7 +496,7 @@
+ static index_t ToIndex(lua_State *L, int index) {
+ index_t to;
+ if(lua_isnil(L, index)) return -1;
+- else if(_lookup(L, index, to)) return to;
++ else if(L_LazyEnum::_lookup(L, index, to)) return to;
+ else {
+ std::string error;
+ if(lua_isnumber(L, index) || lua_isstring(L, index))