summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-07 21:20:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-07 21:20:56 +0000
commit687022e924ee7b43a3b1e045568515c367507e7b (patch)
treeb569a351db37d4001d29fec6421851919031d77e /games-fps
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-687022e924ee7b43a3b1e045568515c367507e7b.tar.gz
gentoo-2-687022e924ee7b43a3b1e045568515c367507e7b.tar.bz2
gentoo-2-687022e924ee7b43a3b1e045568515c367507e7b.zip
punt alsa since it's incomplete (bug #110374)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-icculus/ChangeLog6
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild25
2 files changed, 15 insertions, 16 deletions
diff --git a/games-fps/quake2-icculus/ChangeLog b/games-fps/quake2-icculus/ChangeLog
index 73d08d1aae91..6879ad5e97db 100644
--- a/games-fps/quake2-icculus/ChangeLog
+++ b/games-fps/quake2-icculus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/quake2-icculus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.38 2009/11/19 18:39:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.39 2009/12/07 21:20:56 mr_bones_ Exp $
+
+ 07 Dec 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ quake2-icculus-0.16.1-r1.ebuild:
+ punt alsa since it's incomplete (bug #110374)
19 Nov 2009; Raúl Porcel <armin76@gentoo.org>
quake2-icculus-0.16.1-r1.ebuild:
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
index 96fa08161eac..32d1f2231142 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.18 2009/11/19 18:39:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.19 2009/12/07 21:20:56 mr_bones_ Exp $
+EAPI=2
inherit eutils toolchain-funcs games
MY_P="quake2-r${PV}"
@@ -15,13 +16,12 @@ SRC_URI="http://icculus.org/quake2/files/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ppc sparc x86 ~x86-fbsd"
-IUSE="aalib alsa cdinstall dedicated demo ipv6 joystick opengl qmax rogue sdl svga X xatrix"
+IUSE="aalib cdinstall dedicated demo ipv6 joystick opengl qmax rogue sdl svga X xatrix"
UIDEPEND="aalib? ( media-libs/aalib )
- alsa? ( media-libs/alsa-lib )
opengl? ( virtual/opengl )
svga? ( media-libs/svgalib )
- sdl? ( media-libs/libsdl )
+ sdl? ( media-libs/libsdl[audio,joystick?,video] )
X? (
x11-libs/libXxf86dga
x11-libs/libXxf86vm
@@ -47,13 +47,6 @@ pkg_setup() {
alert_user=y
fi
- if ! use sdl ; then
- ewarn "The ALSA sound driver for this game is broken."
- ewarn "The 'sdl' USE flag is recommended instead."
- echo
- alert_user=y
- fi
-
if [[ -n "${alert_user}" ]] ; then
ebeep
epause
@@ -64,9 +57,11 @@ src_unpack() {
unpack ${MY_P}.tar.gz
cd "${S}"
sed -i -e 's:BUILD_SOFTX:BUILD_X11:' Makefile || die
- epatch "${FILESDIR}"/${P}-amd64.patch # make sure this is still needed in future versions
- epatch "${FILESDIR}"/${P}-gentoo-paths.patch
- epatch "${FILESDIR}"/${P}-no-asm-io.patch #193107
+ # -amd64.patch # make sure this is still needed in future versions
+ epatch \
+ "${FILESDIR}"/${P}-amd64.patch \
+ "${FILESDIR}"/${P}-gentoo-paths.patch \
+ "${FILESDIR}"/${P}-no-asm-io.patch #193107
# Now we deal with the silly rogue / xatrix addons ... this is ugly :/
ln -s $(type -P echo) "${T}"/more
@@ -131,7 +126,7 @@ src_compile() {
BUILD_QMAX=${BUILD_QMAX} \
HAVE_IPV6=$(yesno ipv6) \
BUILD_ARTS=NO \
- BUILD_ALSA=$(yesno alsa) \
+ BUILD_ALSA=NO \
SDLDIR=/usr/lib \
DEFAULT_BASEDIR="${GAMES_DATADIR}/quake2" \
DEFAULT_LIBDIR="$(games_get_libdir)/${PN}${libsuffix}" \