summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-11-15 07:11:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-11-15 07:11:13 +0000
commit240cb4fbc080fa47370448fd8a1e63f7bc064811 (patch)
tree3bb50a5d1c3abc78d07771debeadf5406b0456b0 /games-fps
parentFix eclass inherit order so autotools-utils does not stomp on xorg-2 setup #5... (diff)
downloadgentoo-2-240cb4fbc080fa47370448fd8a1e63f7bc064811.tar.gz
gentoo-2-240cb4fbc080fa47370448fd8a1e63f7bc064811.tar.bz2
gentoo-2-240cb4fbc080fa47370448fd8a1e63f7bc064811.zip
old
(Portage version: 2.2.8-r2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/xonotic/ChangeLog5
-rw-r--r--games-fps/xonotic/xonotic-0.6.0.ebuild109
2 files changed, 4 insertions, 110 deletions
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
index c66db4c3ece2..88500303d7ca 100644
--- a/games-fps/xonotic/ChangeLog
+++ b/games-fps/xonotic/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/xonotic
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.15 2014/10/12 08:46:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.16 2014/11/15 07:11:13 mr_bones_ Exp $
+
+ 15 Nov 2014; Michael Sterrett <mr_bones_@gentoo.org> -xonotic-0.6.0.ebuild:
+ old
12 Oct 2014; Agostino Sarubbo <ago@gentoo.org> xonotic-0.7.0.ebuild:
Stable for x86, wrt bug #503928
diff --git a/games-fps/xonotic/xonotic-0.6.0.ebuild b/games-fps/xonotic/xonotic-0.6.0.ebuild
deleted file mode 100644
index 7ce885daadb4..000000000000
--- a/games-fps/xonotic/xonotic-0.6.0.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.6.0.ebuild,v 1.5 2014/05/15 16:47:18 ulm Exp $
-
-EAPI=3
-inherit eutils check-reqs games
-
-MY_PN="${PN^}"
-DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
-HOMEPAGE="http://www.xonotic.org/"
-SRC_URI="http://dl.xonotic.org/${P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="alsa debug dedicated doc sdl"
-
-UIRDEPEND="
- media-libs/libogg
- media-libs/libtheora
- media-libs/libvorbis
- media-libs/libmodplug
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXpm
- x11-libs/libXext
- x11-libs/libXdmcp
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm
- virtual/opengl
- media-libs/freetype:2
- alsa? ( media-libs/alsa-lib )
- sdl? ( media-libs/libsdl[X,sound,joystick,opengl,video,alsa?] )"
-UIDEPEND="
- x11-proto/xextproto
- x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto
- x11-proto/xproto"
-RDEPEND="
- sys-libs/zlib
- virtual/jpeg
- media-libs/libpng
- net-misc/curl
- ~dev-libs/d0_blind_id-0.5
- !dedicated? ( ${UIRDEPEND} )"
-DEPEND="${RDEPEND}
- !dedicated? ( ${UIDEPEND} )"
-
-S=${WORKDIR}/${MY_PN}
-
-pkg_setup() {
- CHECKREQS_DISK_BUILD="1200M"
- CHECKREQS_DISK_USR="950M"
- check-reqs_pkg_setup
- games_pkg_setup
-}
-
-src_prepare() {
- rm -rf misc/buildfiles/ # use system libs
-
- sed -i \
- -e "/^EXE_/s:darkplaces:${PN}:" \
- -e "s:-O3:${CFLAGS}:" \
- -e "/-lm/s:$: ${LDFLAGS}:" \
- -e '/^STRIP/s/strip/true/' \
- source/darkplaces/makefile.inc || die
-
- if ! use alsa; then
- sed -i \
- -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
- source/darkplaces/makefile || die
- fi
-}
-
-src_compile() {
- local t="$(use debug && echo debug || echo release)"
- local d
-
- for d in sv-${t} $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})")
- do
- emake \
- DP_LINK_TO_LIBJPEG=1 DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
- -C source/darkplaces ${d} || die
- done
-}
-
-src_install() {
- if ! use dedicated; then
- dogamesbin source/darkplaces/${PN}-glx || die
- newicon misc/logos/${PN}_icon.svg ${PN}.svg
- make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
-
- if use sdl; then
- dogamesbin source/darkplaces/${PN}-sdl || die
- make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
- fi
- fi
- dogamesbin source/darkplaces/${PN}-dedicated || die
-
- dodoc Docs/*.txt
- use doc && dohtml -r Docs
-
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r key_0.d0pk server data || die
- prepgamesdirs
-
- einfo "If you are using opensource drivers you should condider installing: "
- einfo " media-libs/libtxc_dxtn"
-}