summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
commitc22ea1f9962983b3583d00085024413d77102212 (patch)
treeacd80fa59d92f27b0609b3d58893ef500cd09925 /games-fps/unreal-tournament-bonuspacks
parentNew version 'n cleanup (diff)
downloadgentoo-2-c22ea1f9962983b3583d00085024413d77102212.tar.gz
gentoo-2-c22ea1f9962983b3583d00085024413d77102212.tar.bz2
gentoo-2-c22ea1f9962983b3583d00085024413d77102212.zip
games-fps uNF uNF uNF
Diffstat (limited to 'games-fps/unreal-tournament-bonuspacks')
-rw-r--r--games-fps/unreal-tournament-bonuspacks/ChangeLog10
-rw-r--r--games-fps/unreal-tournament-bonuspacks/Manifest3
-rw-r--r--games-fps/unreal-tournament-bonuspacks/files/digest-unreal-tournament-bonuspacks-4365
-rw-r--r--games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild44
4 files changed, 62 insertions, 0 deletions
diff --git a/games-fps/unreal-tournament-bonuspacks/ChangeLog b/games-fps/unreal-tournament-bonuspacks/ChangeLog
new file mode 100644
index 000000000000..e3711fc44fae
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-games/unreal-tournament-bonuspacks
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-bonuspacks/ChangeLog,v 1.1 2003/09/09 18:10:15 vapier Exp $
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
+*unreal-tournament-bonuspacks-436 (23 Oct 2002)
+
+ 23 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-fps/unreal-tournament-bonuspacks/Manifest b/games-fps/unreal-tournament-bonuspacks/Manifest
new file mode 100644
index 000000000000..c5b128cdc0c9
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/Manifest
@@ -0,0 +1,3 @@
+MD5 c453276b776dbe01e68995c13509674d files/digest-unreal-tournament-bonuspacks-436 321
+MD5 237a8afc852dcfa1decf2998375b14b4 unreal-tournament-bonuspacks-436.ebuild 1345
+MD5 7cc5420bfd359387c5b8cf4b19cc4200 ChangeLog 482
diff --git a/games-fps/unreal-tournament-bonuspacks/files/digest-unreal-tournament-bonuspacks-436 b/games-fps/unreal-tournament-bonuspacks/files/digest-unreal-tournament-bonuspacks-436
new file mode 100644
index 000000000000..0c2bd155a4de
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/files/digest-unreal-tournament-bonuspacks-436
@@ -0,0 +1,5 @@
+MD5 3b13b271208fe72022e265960cda66ad umodpack-0.5b16-nogui.tar.gz 115424
+MD5 e79b05b8a302593b53721e2a4295c6c0 UTBonusPack.zip 14487626
+MD5 5cf174dab9f91827da9935231c8d1ea6 utbonuspack2.zip 1594927
+MD5 a6623e58a505e26001de46085a98c10f utinoxxpack.zip 5071105
+MD5 c9e7373ee15472ec53e62a7199f33966 UTBonusPack4.zip 14916708
diff --git a/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
new file mode 100644
index 000000000000..a30ec798ff13
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild,v 1.1 2003/09/09 18:10:15 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Futuristic FPS (bonus packs)"
+HOMEPAGE="http://www.unrealtournament.com/"
+# UT has 4 official bonus packs ...
+# [UTBonusPack] -> loki put into app-games/unreal-tournament
+# [UTBonusPack2] -> loki put into app-games/unreal-tournament
+# [UTiNoxxPack] -> loki put into app-games/unreal-tournament
+# [UTBonusPack4] -> none of this is in app-games/unreal-tournament
+SRC_URI="http://fileserver.talkware.net/ut/bonuspacks/UTBonusPack4.zip
+ http://www.dices.de/dices/files/UTBonusPack4.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -alpha"
+IUSE="X"
+
+DEPEND="app-arch/unzip
+ || ( app-games/unreal-tournament app-games/unreal-tournament-goty )
+ app-games/umodpack"
+RDEPEND="X? ( virtual/x11 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # unpack the UTBonusPack4 umod
+ umod -v -b `pwd` -x UTBonusPack4.umod || die "could not unpack UTBonusPack4.umod"
+
+ # move stuff around
+ rm UTBonusPack4.umod
+ mv system System
+ mv textures Textures
+
+ # install it all
+ local dir=${GAMES_PREFIX_OPT}/unreal-tournament
+ dodir ${dir}
+ mv * ${D}/${dir}/
+
+ prepgamesdirs
+}