summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-01-14 14:34:59 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-01-14 14:34:59 +0000
commit50ac34a029564b47f2ba0085430c8011af4b01a1 (patch)
tree3ebe865a47b5c76a179d35802d76802dec889304 /games-fps/quakeforge
parentStable on Alpha. (diff)
downloadgentoo-2-50ac34a029564b47f2ba0085430c8011af4b01a1.tar.gz
gentoo-2-50ac34a029564b47f2ba0085430c8011af4b01a1.tar.bz2
gentoo-2-50ac34a029564b47f2ba0085430c8011af4b01a1.zip
Fix for console_client fails. Bug #93880
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-fps/quakeforge')
-rw-r--r--games-fps/quakeforge/ChangeLog10
-rw-r--r--games-fps/quakeforge/files/digest-quakeforge-0.5.5-r13
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.5.5-keys.patch103
-rw-r--r--games-fps/quakeforge/quakeforge-0.5.5-r1.ebuild132
4 files changed, 246 insertions, 2 deletions
diff --git a/games-fps/quakeforge/ChangeLog b/games-fps/quakeforge/ChangeLog
index 556e8fc21d13..322b6d1759e1 100644
--- a/games-fps/quakeforge/ChangeLog
+++ b/games-fps/quakeforge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quakeforge
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.14 2006/12/05 17:24:01 wolf31o2 Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.15 2007/01/14 14:34:59 tupone Exp $
+
+*quakeforge-0.5.5-r1 (14 Jan 2007)
+
+ 14 Jan 2007; <tupone@gentoo.org> +files/quakeforge-0.5.5-keys.patch,
+ +quakeforge-0.5.5-r1.ebuild:
+ Fix for console_client fails. Bug #93880 by Jordan
05 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
quakeforge-0.5.5.ebuild:
diff --git a/games-fps/quakeforge/files/digest-quakeforge-0.5.5-r1 b/games-fps/quakeforge/files/digest-quakeforge-0.5.5-r1
new file mode 100644
index 000000000000..e2b268f899bc
--- /dev/null
+++ b/games-fps/quakeforge/files/digest-quakeforge-0.5.5-r1
@@ -0,0 +1,3 @@
+MD5 b750b491ce24135f1a4a1360029de3a2 quakeforge-0.5.5.tar.bz2 1954072
+RMD160 1caf8d7b272c9e588708ac39841d46aac2c5df79 quakeforge-0.5.5.tar.bz2 1954072
+SHA256 9ff29340f571fc26d19992a32f58e767e1b811248688f383083bc2ccb263ec6a quakeforge-0.5.5.tar.bz2 1954072
diff --git a/games-fps/quakeforge/files/quakeforge-0.5.5-keys.patch b/games-fps/quakeforge/files/quakeforge-0.5.5-keys.patch
new file mode 100644
index 000000000000..fb027dd03c04
--- /dev/null
+++ b/games-fps/quakeforge/files/quakeforge-0.5.5-keys.patch
@@ -0,0 +1,103 @@
+--- nq/source/sys_sdl.c.old 2007-01-14 12:34:48.000000000 +0100
++++ nq/source/sys_sdl.c 2007-01-14 12:35:43.000000000 +0100
+@@ -63,6 +63,7 @@
+ #include "QF/console.h"
+ #include "QF/qargs.h"
+ #include "QF/sys.h"
++#include "QF/progs.h"
+
+ #include "client.h"
+ #include "compat.h"
+@@ -107,6 +108,9 @@
+ #endif
+ }
+
++extern void Key_Progs_Init (progs_t *pr);
++void (*x)() = Key_Progs_Init;
++
+ #ifndef SDL_main
+ # define SDL_main main
+ #endif
+--- qw/source/cl_sys_sdl.c.old 2007-01-14 12:29:25.000000000 +0100
++++ qw/source/cl_sys_sdl.c 2007-01-14 12:30:50.000000000 +0100
+@@ -63,6 +63,7 @@
+ #include "QF/console.h"
+ #include "QF/qargs.h"
+ #include "QF/sys.h"
++#include "QF/progs.h"
+
+ #include "client.h"
+ #include "compat.h"
+@@ -108,6 +109,9 @@
+ #endif
+ }
+
++extern void Key_Progs_Init (progs_t *pr);
++void (*x)() = Key_Progs_Init;
++
+ #ifndef SDL_main
+ # define SDL_main main
+ #endif
+--- qw/source/cl_sys_unix.c.old 2007-01-14 12:33:15.000000000 +0100
++++ qw/source/cl_sys_unix.c 2007-01-14 12:34:02.000000000 +0100
+@@ -56,6 +56,7 @@
+ #include "QF/console.h"
+ #include "QF/qargs.h"
+ #include "QF/sys.h"
++#include "QF/progs.h"
+
+ #include "host.h"
+ #include "netchan.h"
+@@ -73,6 +74,9 @@
+
+ int skipframes;
+
++extern void Key_Progs_Init (progs_t *pr);
++void (*x)() = Key_Progs_Init;
++
+ int
+ main (int c, const char *v[])
+ {
+--- nq/source/sys_unix.c.old 2007-01-14 13:01:20.000000000 +0100
++++ nq/source/sys_unix.c 2007-01-14 13:01:38.000000000 +0100
+@@ -69,6 +69,9 @@
+ fcntl (0, F_SETFL, fcntl (0, F_GETFL, 0) & ~O_NONBLOCK);
+ }
+
++extern void Key_Progs_Init (progs_t *pr);
++void (*x)() = Key_Progs_Init;
++
+ int
+ main (int c, const char *v[])
+ {
+--- configure.old 2007-01-14 14:06:22.000000000 +0100
++++ configure 2007-01-14 14:06:43.000000000 +0100
+@@ -22733,7 +22733,7 @@
+ int
+ main ()
+ {
+-void *(*foo)(size_t) = alloca;
++void *foo = alloca(sizeof(void));
+ ;
+ return 0;
+ }
+@@ -32304,7 +32304,7 @@
+
+
+ if test "x$BUILD_SW" = xyes; then
+- VID_REND_NOINST_TARGETS="$VID_REND_NOINST_TARGETS libQFrenderer_sw.la"
++ VID_REND_TARGETS="$VID_REND_TARGETS libQFrenderer_sw.la"
+ VID_MODEL_TARGETS="$VID_MODEL_TARGETS libQFmodels_sw.la"
+ fi
+ if test "x$BUILD_SW32" = xyes; then
+--- libs/video/renderer/Makefile.in.old 2007-01-14 15:00:14.000000000 +0100
++++ libs/video/renderer/Makefile.in 2007-01-14 15:02:08.000000000 +0100
+@@ -409,7 +409,7 @@
+ libQFrenderer_gl_la_LIBADD = gl/libgl.la
+ libQFrenderer_gl_la_SOURCES = $(common_sources)
+ libQFrenderer_gl_la_DEPENDENCIES = gl/libgl.la
+-libQFrenderer_sw_la_LDFLAGS = @STATIC@
++libQFrenderer_sw_la_LDFLAGS = -version-info 1:0:0 -rpath $(libdir)
+ libQFrenderer_sw_la_LIBADD = sw/libsw.la
+ libQFrenderer_sw_la_SOURCES = $(common_sources)
+ libQFrenderer_sw_la_DEPENDENCIES = sw/libsw.la
diff --git a/games-fps/quakeforge/quakeforge-0.5.5-r1.ebuild b/games-fps/quakeforge/quakeforge-0.5.5-r1.ebuild
new file mode 100644
index 000000000000..8953056959eb
--- /dev/null
+++ b/games-fps/quakeforge/quakeforge-0.5.5-r1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.5-r1.ebuild,v 1.1 2007/01/14 14:34:59 tupone Exp $
+
+inherit eutils autotools games
+
+DESCRIPTION="A new 3d engine based off of id Softwares's legendary Quake and QuakeWorld game engine"
+HOMEPAGE="http://www.quakeforge.net/"
+SRC_URI="mirror://sourceforge/quake/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="cdinstall debug 3dfx fbcon opengl sdl svga X ncurses vorbis zlib ipv6 xv dga alsa oss"
+RESTRICT="userpriv"
+
+RDEPEND="3dfx? ( media-libs/glide-v3 )
+ opengl? ( virtual/opengl )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm )
+ ncurses? ( sys-libs/ncurses )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ zlib? ( sys-libs/zlib )
+ xv? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm )
+ dga? ( x11-libs/libXxf86dga )
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}
+ cdinstall? ( games-fps/quake1-data )
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}"-ipv6.patch \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-keys.patch
+}
+
+src_compile() {
+ #i should do this at some point :x ... i guess if you disable all shared stuff
+ #and enable all the static options explicitly, static works ... (or so ive been told)
+ #if ! use static ; then
+ # myconf="${myconf} --enable-shared=yes --enable-static=no"
+ #else
+ # myconf="${myconf} --enable-shared=no --enable-static=yes"
+ #fi
+
+ local debugopts
+ use debug \
+ && debugopts="--enable-debug --disable-optimize --enable-profile" \
+ || debugopts="--disable-debug --disable-profile"
+
+ local clients=${QF_CLIENTS}
+ use 3dfx && clients="${clients},3dfx"
+ use fbcon && clients="${clients},fbdev"
+ use opengl && clients="${clients},glx"
+ use sdl && clients="${clients},sdl,sdl32"
+ use sdl && use opengl && clients="${clients},sgl"
+ use svga && clients="${clients},svga"
+ use X && clients="${clients},x11"
+ use X && use opengl && clients="${clients},wgl"
+ [ "${clients:0:1}" == "," ] && clients=${clients:1}
+
+ local servers=${QF_SERVERS:-master,nq,qw,qtv}
+
+ local tools=${QF_TOOLS:-all}
+
+ local svgaconf # use old school way for broken conf opts
+ use svga \
+ && svgaconf="--with-svga=/usr" \
+ || svgaconf="--without-svga"
+
+ addpredict ${GAMES_LIBDIR}
+ egamesconf \
+ $(use_enable ncurses curses) \
+ $(use_enable vorbis) \
+ $(use_enable zlib) \
+ $(use_with ipv6) \
+ $(use_with fbcon fbdev) \
+ ${svgaconf} \
+ $(use_with X x) \
+ $(use_enable xv vidmode) \
+ $(use_enable dga) \
+ $(use_enable sdl) \
+ --disable-xmms \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ --enable-sound \
+ --disable-optimize \
+ ${debugopts} \
+ --with-global-cfg=${GAMES_SYSCONFDIR}/quakeforge.conf \
+ --with-sharepath=${GAMES_DATADIR}/quake1 \
+ --with-clients=${clients} \
+ --with-servers=${servers} \
+ --with-tools=${tools} \
+ || die
+ make || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ mv ${D}/${GAMES_PREFIX}/include ${D}/usr/
+ dodoc ChangeLog NEWS TODO doc/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ # same warning used in quake1 / quakeforge / nprquake-sdl
+ games_pkg_postinst
+ echo
+ einfo "Before you can play, you must make sure"
+ einfo "${PN} can find your Quake .pak files"
+ echo
+ einfo "You have 2 choices to do this"
+ einfo "1 Copy pak*.pak files to ${GAMES_DATADIR}/quake1/id1"
+ einfo "2 Symlink pak*.pak files in ${GAMES_DATADIR}/quake1/id1"
+ echo
+ einfo "Example:"
+ einfo "my pak*.pak files are in /mnt/secondary/Games/Quake/Id1/"
+ einfo "ln -s /mnt/secondary/Games/Quake/Id1/pak0.pak ${GAMES_DATADIR}/quake1/id1/pak0.pak"
+ echo
+ einfo "You only need pak0.pak to play the demo version,"
+ einfo "the others are needed for registered version"
+}