summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-29 10:50:33 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-29 10:50:33 +0000
commitae9313095c12d6684742d89b2347499080ab071e (patch)
treeea9b18ebd9822ac931b4afd9b76ee3a0f036603a /games-fps/industri
parentAdded reference on upstream bug report. (diff)
downloadgentoo-2-ae9313095c12d6684742d89b2347499080ab071e.tar.gz
gentoo-2-ae9313095c12d6684742d89b2347499080ab071e.tar.bz2
gentoo-2-ae9313095c12d6684742d89b2347499080ab071e.zip
Fix build with new (?) glext.h Bug #365013
(Portage version: 2.1.9.46/cvs/Linux i686)
Diffstat (limited to 'games-fps/industri')
-rw-r--r--games-fps/industri/ChangeLog8
-rw-r--r--games-fps/industri/files/industri-1.01-glext.patch18
-rw-r--r--games-fps/industri/industri-1.01.ebuild7
3 files changed, 28 insertions, 5 deletions
diff --git a/games-fps/industri/ChangeLog b/games-fps/industri/ChangeLog
index 718478768f23..a72e0ca2f040 100644
--- a/games-fps/industri/ChangeLog
+++ b/games-fps/industri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/industri
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/ChangeLog,v 1.12 2010/10/13 09:53:58 tupone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/ChangeLog,v 1.13 2011/04/29 10:50:33 tupone Exp $
+
+ 29 Apr 2011; Tupone Alfredo <tupone@gentoo.org> industri-1.01.ebuild,
+ +files/industri-1.01-glext.patch:
+ Fix build with new (?) glext.h Bug #365013 by Diego Elio Pettenò
13 Oct 2010; Tupone Alfredo <tupone@gentoo.org> industri-1.01.ebuild,
+files/industri-1.01-ldflags.patch:
diff --git a/games-fps/industri/files/industri-1.01-glext.patch b/games-fps/industri/files/industri-1.01-glext.patch
new file mode 100644
index 000000000000..8a5042e431f2
--- /dev/null
+++ b/games-fps/industri/files/industri-1.01-glext.patch
@@ -0,0 +1,18 @@
+--- glquake.h.old 2011-04-29 12:36:53.000000000 +0200
++++ glquake.h 2011-04-29 12:44:39.000000000 +0200
+@@ -977,6 +977,7 @@
+ #define GL_MAP2_VERTEX_ATTRIB15_4_NV 0x867F
+
+ /* NV_vertex_program */
++#ifndef GL_NV_vertex_program
+ typedef GLboolean (APIENTRY * PFNGLAREPROGRAMSRESIDENTNVPROC) (GLsizei n, const GLuint *programs, GLboolean *residences);
+ typedef void (APIENTRY * PFNGLBINDPROGRAMNVPROC) (GLenum target, GLuint id);
+ typedef void (APIENTRY * PFNGLDELETEPROGRAMSNVPROC) (GLsizei n, const GLuint *programs);
+@@ -1040,6 +1041,7 @@
+ typedef void (APIENTRY * PFNGLVERTEXATTRIBS4FVNVPROC) (GLuint index, GLsizei count, const GLfloat *v);
+ typedef void (APIENTRY * PFNGLVERTEXATTRIBS4SVNVPROC) (GLuint index, GLsizei count, const GLshort *v);
+ typedef void (APIENTRY * PFNGLVERTEXATTRIBS4UBVNVPROC) (GLuint index, GLsizei count, const GLubyte *v);
++#endif
+
+ extern PFNGLAREPROGRAMSRESIDENTNVPROC qglAreProgramsResidentNV ;
+ extern PFNGLBINDPROGRAMNVPROC qglBindProgramNV ;
diff --git a/games-fps/industri/industri-1.01.ebuild b/games-fps/industri/industri-1.01.ebuild
index 67ffd25a7d27..066c1ebb83a6 100644
--- a/games-fps/industri/industri-1.01.ebuild
+++ b/games-fps/industri/industri-1.01.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.18 2010/10/13 21:25:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.19 2011/04/29 10:50:33 tupone Exp $
EAPI=2
inherit eutils toolchain-funcs games
@@ -50,7 +50,8 @@ src_prepare() {
gl_warp.c || die
epatch "${FILESDIR}"/${P}-exec-stack.patch \
- "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-glext.patch
}
src_compile() {