summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-02-13 22:16:11 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-02-13 22:16:11 +0000
commitff55546bddc548f1765dacaeac8ea9295f839e89 (patch)
tree6b148bfdd45ef06ba71793a23f7732a315707c1e /games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild
parentModular X dependencies. (diff)
downloadgentoo-2-ff55546bddc548f1765dacaeac8ea9295f839e89.tar.gz
gentoo-2-ff55546bddc548f1765dacaeac8ea9295f839e89.tar.bz2
gentoo-2-ff55546bddc548f1765dacaeac8ea9295f839e89.zip
modular X dep fix and Bug 106706
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild')
-rw-r--r--games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild40
1 files changed, 31 insertions, 9 deletions
diff --git a/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild b/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild
index 62f21a0cfa01..92352010a4d0 100644
--- a/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild
+++ b/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild,v 1.3 2005/11/05 22:47:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/fuhquake-bin/fuhquake-bin-0.31.ebuild,v 1.4 2006/02/13 22:16:11 tupone Exp $
inherit games
@@ -13,12 +13,24 @@ SRC_URI="http://www.fuhquake.net/files/releases/v${PV}/fuhquake-linux-v${PV}.zip
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-IUSE="opengl svga X"
+IUSE="opengl svga"
-DEPEND="app-arch/unzip"
-RDEPEND="virtual/x11
+RDEPEND="!svga? (
+ || (
+ x11-libs/libXext
+ virtual/x11
+ )
+ )
svga? ( media-libs/svgalib )
- opengl? ( virtual/opengl )"
+ opengl? (
+ virtual/opengl
+ || (
+ x11-libs/libXext
+ virtual/x11
+ )
+ )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}
@@ -30,15 +42,25 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
+ local dir=${GAMES_PREFIX_OPT}/${PN} BINS
dodir "${dir}"
exeinto "${dir}"
- doexe fuhquake-gl.glx fuhquake.svga fuhquake.x11 fuhquake-security.so || die "doexe"
+ if use opengl; then
+ BINS="fuhquake-gl.glx fuhquake.x11"
+ elif ! use svga; then
+ # X will be built if neither opengl nor svga
+ BINS="fuhquake.x11"
+ fi
+ if use svga; then
+ BINS="${BINS} fuhquake.svga"
+ fi
+
+ doexe ${BINS} fuhquake-security.so || die "doexe"
cp -r fuhquake qw "${D}/${dir}"/ || die "cp data"
dosym "${GAMES_DATADIR}"/quake1/id1 "${dir}"/id1
- for x in fuhquake-gl.glx fuhquake.svga fuhquake.x11 ; do
+ for x in ${BINS}; do
games_make_wrapper ${x} ./${x} "${dir}"
done