summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-09-04 05:07:50 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-09-04 05:07:50 +0000
commitebb881cd7608d8c698e361baf5c56e278932e3d3 (patch)
tree682cae83549ee9caf57fd6af514706e3efedcc6a /games-emulation
parentRemove old (diff)
downloadgentoo-2-ebb881cd7608d8c698e361baf5c56e278932e3d3.tar.gz
gentoo-2-ebb881cd7608d8c698e361baf5c56e278932e3d3.tar.bz2
gentoo-2-ebb881cd7608d8c698e361baf5c56e278932e3d3.zip
Build with latest zlib. Bug #431118
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gngeo/ChangeLog8
-rw-r--r--games-emulation/gngeo/files/gngeo-0.7-zlib.patch45
-rw-r--r--games-emulation/gngeo/gngeo-0.7.ebuild19
3 files changed, 61 insertions, 11 deletions
diff --git a/games-emulation/gngeo/ChangeLog b/games-emulation/gngeo/ChangeLog
index 466cc6b25890..e06f97047b70 100644
--- a/games-emulation/gngeo/ChangeLog
+++ b/games-emulation/gngeo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/gngeo
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/ChangeLog,v 1.21 2009/01/17 18:21:17 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/ChangeLog,v 1.22 2012/09/04 05:07:50 tupone Exp $
+
+ 04 Sep 2012; Alfredo Tupone <tupone@gentoo.org> gngeo-0.7.ebuild,
+ +files/gngeo-0.7-zlib.patch:
+ Build with latest zlib. Bug #431118 by Diego Elio Pettenò
17 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> gngeo-0.7.ebuild:
Doesn't work with latest nasm so disable that for now (bug #249834)
diff --git a/games-emulation/gngeo/files/gngeo-0.7-zlib.patch b/games-emulation/gngeo/files/gngeo-0.7-zlib.patch
new file mode 100644
index 000000000000..872b2e67601a
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.7-zlib.patch
@@ -0,0 +1,45 @@
+--- src/Makefile.am.old 2012-09-04 06:43:21.415398601 +0200
++++ src/Makefile.am 2012-09-04 06:43:37.227461006 +0200
+@@ -58,8 +58,8 @@
+ blitter.h font.h memory.h raze_interf.c \
+ timer.c effect.h frame_skip.c messages.c \
+ screen.c timer.h emu.c frame_skip.h \
+- messages.h screen.h unzip.c emu.h \
+- neocrypt.c sound.c unzip.h generator68k_interf.c \
++ messages.h screen.h emu.h \
++ neocrypt.c sound.c generator68k_interf.c \
+ debug.c debug.h neocrypt.h state.c \
+ state.h video_template.h conf.c conf.h \
+ transpack.h transpack.c pbar.h pbar.c \
+--- src/fileio.c.old 2012-09-04 06:42:03.956194155 +0200
++++ src/fileio.c 2012-09-04 06:42:32.299098500 +0200
+@@ -30,7 +30,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <zlib.h>
+-#include "unzip.h"
++#include <minizip/unzip.h>
+ #include "memory.h"
+ #include "video.h"
+ #include "emu.h"
+--- src/driver.c.old 2012-09-04 06:49:28.418057327 +0200
++++ src/driver.c 2012-09-04 06:49:58.161055744 +0200
+@@ -29,7 +29,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <zlib.h>
+-#include "unzip.h"
++#include <minizip/unzip.h>
+ #include "driver.h"
+ #include "conf.h"
+ #include "pbar.h"
+--- configure.in.old 2012-09-04 06:55:46.998493962 +0200
++++ configure.in 2012-09-04 06:56:23.705960317 +0200
+@@ -66,6 +66,7 @@
+ fi
+
+ AC_CHECK_LIB([SDL_image], [IMG_Load])
++AC_CHECK_LIB([minizip], [unzReadCurrentFile])
+
+ AC_CHECK_FUNCS(getopt_long , , [ AC_LIBOBJ(getopt) AC_LIBOBJ(getopt1) ])
+ AC_CHECK_FUNCS(scandir)
diff --git a/games-emulation/gngeo/gngeo-0.7.ebuild b/games-emulation/gngeo/gngeo-0.7.ebuild
index 17b6fafa6cc3..bad245d7966d 100644
--- a/games-emulation/gngeo/gngeo-0.7.ebuild
+++ b/games-emulation/gngeo/gngeo-0.7.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/gngeo-0.7.ebuild,v 1.6 2009/01/17 18:21:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/gngeo-0.7.ebuild,v 1.7 2012/09/04 05:07:50 tupone Exp $
+EAPI=2
inherit eutils autotools games
@@ -15,21 +16,21 @@ IUSE=""
DEPEND="virtual/opengl
media-libs/sdl-image
- media-libs/libsdl"
+ media-libs/libsdl
+ sys-libs/zlib[minizip]"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/${P}-build.patch \
"${FILESDIR}"/${P}-execstacks.patch \
- "${FILESDIR}"/${P}-concurrentMake.patch
+ "${FILESDIR}"/${P}-concurrentMake.patch \
+ "${FILESDIR}"/${P}-zlib.patch
+
eautoreconf
}
-src_compile() {
+src_configure() {
egamesconf --disable-i386asm || die "egamesconf failed"
- emake || die "emake failed"
}
src_install() {