summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-08 23:06:15 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-08 23:06:15 +0000
commitac2dd1ade69bfb79b394cc365a2edbceb05ce4f4 (patch)
tree3b41e1cba6909aae583e60b10048b797ac7e6a06 /games-emulation
parentVersion bump and fix for bug #135337 (diff)
downloadgentoo-2-ac2dd1ade69bfb79b394cc365a2edbceb05ce4f4.tar.gz
gentoo-2-ac2dd1ade69bfb79b394cc365a2edbceb05ce4f4.tar.bz2
gentoo-2-ac2dd1ade69bfb79b394cc365a2edbceb05ce4f4.zip
Use qt3 eclass
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-alsasnd/ChangeLog5
-rw-r--r--games-emulation/mupen64-alsasnd/files/digest-mupen64-alsasnd-0.42
-rw-r--r--games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild20
3 files changed, 12 insertions, 15 deletions
diff --git a/games-emulation/mupen64-alsasnd/ChangeLog b/games-emulation/mupen64-alsasnd/ChangeLog
index d762df37974c..a32a68386625 100644
--- a/games-emulation/mupen64-alsasnd/ChangeLog
+++ b/games-emulation/mupen64-alsasnd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/mupen64-alsasnd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.10 2006/06/24 04:56:28 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.11 2006/10/08 23:06:15 nyhm Exp $
+
+ 08 Oct 2006; Tristan Heaven <nyhm@gentoo.org> mupen64-alsasnd-0.4.ebuild:
+ Use qt3 eclass
24 Jun 2006; Doug Goldstein <cardoe@gentoo.org>
mupen64-alsasnd-0.4.ebuild:
diff --git a/games-emulation/mupen64-alsasnd/files/digest-mupen64-alsasnd-0.4 b/games-emulation/mupen64-alsasnd/files/digest-mupen64-alsasnd-0.4
index 7a7eb943e3ca..6fda5768f84f 100644
--- a/games-emulation/mupen64-alsasnd/files/digest-mupen64-alsasnd-0.4
+++ b/games-emulation/mupen64-alsasnd/files/digest-mupen64-alsasnd-0.4
@@ -1 +1,3 @@
MD5 4b65325e4d31032cb1fc2c704105fa94 alsa-plugin-0.4fix.tar.bz2 26455
+RMD160 4de1e0406625b7115fd612400d305e98375f77f1 alsa-plugin-0.4fix.tar.bz2 26455
+SHA256 3d0b6eeb1c193ca4ef87da9b302eb87dc6619effe1be261bd81e0664be1261f8 alsa-plugin-0.4fix.tar.bz2 26455
diff --git a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
index da6cb08dae8b..f24b1a2f1162 100644
--- a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
+++ b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.15 2006/06/24 04:56:28 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.16 2006/10/08 23:06:15 nyhm Exp $
-inherit eutils games
+inherit eutils qt3 games
DESCRIPTION="Alsa plugin for the mupen64 N64 emulator"
HOMEPAGE="http://www.emutalk.net/showthread.php?threadid=16895"
@@ -14,20 +14,12 @@ KEYWORDS="-* x86"
IUSE="gtk qt3"
DEPEND=">=media-libs/alsa-lib-0.9.0
- || (
- gtk? ( =x11-libs/gtk+-2* )
- qt3? ( =x11-libs/qt-3* )
- =x11-libs/gtk+-2*
- )"
+ gtk? ( =x11-libs/gtk+-2* )
+ qt3? ( $(qt_min_version 3.3) )
+ !gtk? ( !qt3? ( =x11-libs/gtk+-2* ) )"
S=${WORKDIR}/alsa_plugin
-pkg_nofetch() {
- einfo "Please visit this page to download the tarball:"
- einfo "http://www.emutalk.net/showpost.php?postid=170173&postcount=12"
- einfo "Then just put ${A} in ${DISTDIR} !"
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -40,7 +32,7 @@ src_compile() {
export GRAPHICAL_INTERFACE=gtk2
use qt3 && export GRAPHICAL_INTERFACE=qt3
use gtk && export GRAPHICAL_INTERFACE=gtk2
- emake || die "make failed"
+ emake || die "emake failed"
}
src_install() {