summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-30 17:16:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-30 17:16:38 +0000
commita4a651f57e50fca809a20924cd2fd09a0c46f7db (patch)
tree0ba8a5edbc5c277056bd2eaa2eb29705a861096f /games-emulation
parentStable for amd64 wrt bug #518184 (diff)
downloadgentoo-2-a4a651f57e50fca809a20924cd2fd09a0c46f7db.tar.gz
gentoo-2-a4a651f57e50fca809a20924cd2fd09a0c46f7db.tar.bz2
gentoo-2-a4a651f57e50fca809a20924cd2fd09a0c46f7db.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog8
-rw-r--r--games-emulation/stella/stella-3.9.ebuild7
-rw-r--r--games-emulation/stella/stella-4.0.ebuild70
3 files changed, 81 insertions, 4 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index 70345d738670..f79734908772 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/stella
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.80 2014/06/26 22:01:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.81 2014/07/30 17:16:38 mr_bones_ Exp $
+
+*stella-4.0 (30 Jul 2014)
+
+ 30 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org> +stella-4.0.ebuild,
+ stella-3.9.ebuild:
+ version bump
26 Jun 2014; Michael Sterrett <mr_bones_@gentoo.org> stella-3.9.ebuild:
make sure libsdl has X support (bug #514388)
diff --git a/games-emulation/stella/stella-3.9.ebuild b/games-emulation/stella/stella-3.9.ebuild
index 80e98861278d..e50657feff37 100644
--- a/games-emulation/stella/stella-3.9.ebuild
+++ b/games-emulation/stella/stella-3.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.9.ebuild,v 1.2 2014/06/26 22:01:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.9.ebuild,v 1.3 2014/07/30 17:16:38 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils gnome2-utils games
DESCRIPTION="Stella Atari 2600 VCS Emulator"
@@ -22,6 +22,7 @@ DEPEND="media-libs/libsdl[joystick?,opengl?,X,video]
virtual/opengl
virtual/glu
)"
+RDEPEND=${DEPEND}
src_prepare() {
sed -i \
@@ -52,7 +53,7 @@ src_install() {
newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
done
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
domenu src/unix/stella.desktop
dohtml -r docs/*
dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
diff --git a/games-emulation/stella/stella-4.0.ebuild b/games-emulation/stella/stella-4.0.ebuild
new file mode 100644
index 000000000000..e459d4dff5f9
--- /dev/null
+++ b/games-emulation/stella/stella-4.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-4.0.ebuild,v 1.1 2014/07/30 17:16:38 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stella/${P}-src.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick"
+
+DEPEND="media-libs/libsdl2[joystick?,opengl,video]
+ media-libs/libpng:0
+ sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
+ Makefile || die
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ local i
+ for i in 16 22 24 32 48 64 128 ; do
+ newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
+ done
+
+ emake DESTDIR="${D}" install
+ domenu src/unix/stella.desktop
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}