summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-09-22 19:54:06 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-09-22 19:54:06 +0000
commit4a78f12ebbf5f705c7ced663ad4a6f736eb1fab9 (patch)
treead694ebaaaf756b963f8db659f3960fb39345681 /games-emulation
parent[profiles/updates] add move for glusterfs (diff)
downloadgentoo-2-4a78f12ebbf5f705c7ced663ad4a6f736eb1fab9.tar.gz
gentoo-2-4a78f12ebbf5f705c7ced663ad4a6f736eb1fab9.tar.bz2
gentoo-2-4a78f12ebbf5f705c7ced663ad4a6f736eb1fab9.zip
Override Makefile arch detection; add ~x86 keyword
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64plus/ChangeLog5
-rw-r--r--games-emulation/mupen64plus/mupen64plus-1.5.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/games-emulation/mupen64plus/ChangeLog b/games-emulation/mupen64plus/ChangeLog
index 6556d3ce8d8a..c32baf94f0d0 100644
--- a/games-emulation/mupen64plus/ChangeLog
+++ b/games-emulation/mupen64plus/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/mupen64plus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.2 2009/08/31 21:49:20 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.3 2009/09/22 19:54:06 nyhm Exp $
+
+ 22 Sep 2009; Tristan Heaven <nyhm@gentoo.org> mupen64plus-1.5.ebuild:
+ Override Makefile arch detection; add ~x86 keyword
31 Aug 2009; Tristan Heaven <nyhm@gentoo.org>
files/mupen64plus-1.5-flags.patch:
diff --git a/games-emulation/mupen64plus/mupen64plus-1.5.ebuild b/games-emulation/mupen64plus/mupen64plus-1.5.ebuild
index f4d21a5d93a1..0ae78a217383 100644
--- a/games-emulation/mupen64plus/mupen64plus-1.5.ebuild
+++ b/games-emulation/mupen64plus/mupen64plus-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5.ebuild,v 1.1 2009/08/28 07:50:00 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5.ebuild,v 1.2 2009/09/22 19:54:06 nyhm Exp $
EAPI="2"
@@ -14,7 +14,7 @@ SRC_URI="http://mupen64plus.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="+gtk libsamplerate lirc qt4 sse"
# GTK+ is currently required by plugins even if no GUI support is enabled
@@ -49,7 +49,7 @@ pkg_setup() {
src_prepare() {
# unbundle bzip2
epatch "${FILESDIR}"/${P}-unbundle-bzip2.patch
- # XXX: try to unbundle more?
+ # XXX: try to unbundle more
# fix compilation with gcc4.4
epatch "${FILESDIR}"/${P}-glide64-gcc44.patch
@@ -72,6 +72,10 @@ src_prepare() {
}
get_opts() {
+ if use amd64 || use x86 ; then
+ echo -n "CPU=X86 ARCH=64BITS$(use x86 && echo -n _32) "
+ fi
+
use libsamplerate || echo -n "NO_RESAMP=1 "
use lirc && echo -n "LIRC=1 "
use sse || echo -n "NO_ASM=1 "
@@ -87,6 +91,7 @@ get_opts() {
}
src_compile() {
+ use x86 && use sse && append-flags -fomit-frame-pointer
emake $(get_opts) all || die "make failed"
}