summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-16 16:54:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-16 16:54:52 +0000
commit46a6c36c61c7e830bab452773011ea6576cd70c6 (patch)
tree193eba1c26ace5b2436e9125e9d15ae752b7dbf0 /games-emulation
parentx86 stable per bug 324031 (diff)
downloadgentoo-2-46a6c36c61c7e830bab452773011ea6576cd70c6.tar.gz
gentoo-2-46a6c36c61c7e830bab452773011ea6576cd70c6.tar.bz2
gentoo-2-46a6c36c61c7e830bab452773011ea6576cd70c6.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-3.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index 4d01889cbe48..c83159fd67f0 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.55 2010/11/04 11:00:39 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.56 2010/11/16 16:54:52 mr_bones_ Exp $
+
+*stella-3.3 (16 Nov 2010)
+
+ 16 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org> +stella-3.3.ebuild:
+ version bump
04 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> stella-3.2.2.ebuild:
x86 stable wrt bug #343451
diff --git a/games-emulation/stella/stella-3.3.ebuild b/games-emulation/stella/stella-3.3.ebuild
new file mode 100644
index 000000000000..71b71026b682
--- /dev/null
+++ b/games-emulation/stella/stella-3.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.3.ebuild,v 1.1 2010/11/16 16:54:52 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="joystick opengl"
+
+DEPEND="media-libs/libsdl[joystick?,video]
+ x11-libs/libX11
+ media-libs/libpng
+ sys-libs/zlib
+ opengl? ( virtual/opengl )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.png
+ make_desktop_entry stella Stella
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-GP2X.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}