summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-24 00:26:56 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-24 00:26:56 +0000
commit3c603e13f13fef09195c26d89c4edc68deecc677 (patch)
tree973fb8162820e3b30133e0a7963ca5995bfb366e /games-emulation
parent0.26 bump (diff)
downloadgentoo-2-3c603e13f13fef09195c26d89c4edc68deecc677.tar.gz
gentoo-2-3c603e13f13fef09195c26d89c4edc68deecc677.tar.bz2
gentoo-2-3c603e13f13fef09195c26d89c4edc68deecc677.zip
fix build time issues, revbump: bump eapi, add icon/desktop-entry
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fakenes/ChangeLog10
-rw-r--r--games-emulation/fakenes/fakenes-0.5.8-r1.ebuild10
-rw-r--r--games-emulation/fakenes/fakenes-0.5.8-r2.ebuild79
3 files changed, 92 insertions, 7 deletions
diff --git a/games-emulation/fakenes/ChangeLog b/games-emulation/fakenes/ChangeLog
index e96f805972ae..c6d45d592d5d 100644
--- a/games-emulation/fakenes/ChangeLog
+++ b/games-emulation/fakenes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/fakenes
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/ChangeLog,v 1.22 2012/05/04 04:38:40 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/ChangeLog,v 1.23 2013/01/24 00:26:56 hasufell Exp $
+
+ 24 Jan 2013; Julian Ospald <hasufell@gentoo.org> fakenes-0.5.8-r1.ebuild,
+ +fakenes-0.5.8-r2.ebuild:
+ fix build time issues, revbump: bump eapi, add icon/desktop-entry
+
+*fakenes-0.5.8-r2 (24 Jan 2013)
04 May 2012; Jeff Horelick <jdhore@gentoo.org> fakenes-0.5.8-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/games-emulation/fakenes/fakenes-0.5.8-r1.ebuild b/games-emulation/fakenes/fakenes-0.5.8-r1.ebuild
index 2f2f41c37a2b..1de0b9d85005 100644
--- a/games-emulation/fakenes/fakenes-0.5.8-r1.ebuild
+++ b/games-emulation/fakenes/fakenes-0.5.8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/fakenes-0.5.8-r1.ebuild,v 1.7 2012/05/04 04:38:40 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/fakenes-0.5.8-r1.ebuild,v 1.8 2013/01/24 00:26:56 hasufell Exp $
EAPI="2"
@@ -33,7 +33,7 @@ src_prepare() {
sed -i \
-e "s:LIBAGL = agl:LIBAGL = alleggl:" \
build/alleggl.cbd || die
- epatch "${FILESDIR}"/${P}-underlink.patch
+ epatch "${FILESDIR}"/${P}-{underlink,zlib}.patch
}
src_compile() {
@@ -41,13 +41,13 @@ src_compile() {
append-ldflags -Wl,-z,noexecstack
- $(tc-getCC) ${CFLAGS} cbuild.c -o cbuild || die "cbuild build failed"
+ $(tc-getBUILD_CC) cbuild.c -o cbuild || die "cbuild build failed"
use openal || myconf="$myconf -openal"
use opengl || myconf="$myconf -alleggl"
use zlib || myconf="$myconf -zlib"
- ./cbuild ${myconf} --verbose || die "cbuild failed"
+ LD="$(tc-getCC) ${CFLAGS}" ./cbuild ${myconf} --verbose || die "cbuild failed"
}
src_install() {
diff --git a/games-emulation/fakenes/fakenes-0.5.8-r2.ebuild b/games-emulation/fakenes/fakenes-0.5.8-r2.ebuild
new file mode 100644
index 000000000000..64484433a161
--- /dev/null
+++ b/games-emulation/fakenes/fakenes-0.5.8-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/fakenes-0.5.8-r2.ebuild,v 1.1 2013/01/24 00:26:56 hasufell Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs gnome2-utils games
+
+DESCRIPTION="portable, Open Source NES emulator which is written mostly in C"
+HOMEPAGE="http://fakenes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fakenes/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="openal opengl zlib"
+
+RDEPEND=">=media-libs/allegro-4.4.1.1:0[opengl?]
+ dev-games/hawknl
+ openal? (
+ media-libs/openal
+ media-libs/freealut
+ )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e "s:openal-config:pkg-config openal:" \
+ build/openal.cbd || die
+
+ sed -i \
+ -e "s:LIBAGL = agl:LIBAGL = alleggl:" \
+ build/alleggl.cbd || die
+ epatch "${FILESDIR}"/${P}-{underlink,zlib}.patch
+}
+
+src_compile() {
+ local myconf
+
+ append-ldflags -Wl,-z,noexecstack
+
+ echo "$(tc-getBUILD_CC) cbuild.c -o cbuild"
+ $(tc-getBUILD_CC) cbuild.c -o cbuild || die "cbuild build failed"
+
+ use openal || myconf="$myconf -openal"
+ use opengl || myconf="$myconf -alleggl"
+ use zlib || myconf="$myconf -zlib"
+
+ LD="$(tc-getCC) ${CFLAGS}" ./cbuild ${myconf} --verbose || die "cbuild failed"
+}
+
+src_install() {
+ dogamesbin fakenes
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins support/*
+ dodoc docs/{CHANGES,README}
+ dohtml docs/faq.html
+
+ newicon -s 32 support/icon-32x32.png ${PN}.png
+ make_desktop_entry ${PN} "FakeNES"
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}