summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-06-02 05:23:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-06-02 05:23:22 +0000
commitd11cb386cf5b70e6048abc174f70dd31a4502baf (patch)
treeb4db56499fbd5d04414f249d85d5fda7631da93f /games-emulation/yabause
parentwhitespace (diff)
downloadgentoo-2-d11cb386cf5b70e6048abc174f70dd31a4502baf.tar.gz
gentoo-2-d11cb386cf5b70e6048abc174f70dd31a4502baf.tar.bz2
gentoo-2-d11cb386cf5b70e6048abc174f70dd31a4502baf.zip
version bump
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'games-emulation/yabause')
-rw-r--r--games-emulation/yabause/ChangeLog8
-rw-r--r--games-emulation/yabause/yabause-0.9.10.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/games-emulation/yabause/ChangeLog b/games-emulation/yabause/ChangeLog
index d9e4d2c56eb5..76c5b240389b 100644
--- a/games-emulation/yabause/ChangeLog
+++ b/games-emulation/yabause/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/yabause
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.29 2009/01/13 03:43:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.30 2009/06/02 05:23:22 mr_bones_ Exp $
+
+*yabause-0.9.10 (02 Jun 2009)
+
+ 02 Jun 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +yabause-0.9.10.ebuild:
+ version bump
*yabause-0.9.9 (13 Jan 2009)
diff --git a/games-emulation/yabause/yabause-0.9.10.ebuild b/games-emulation/yabause/yabause-0.9.10.ebuild
new file mode 100644
index 000000000000..c90ee3b95a0e
--- /dev/null
+++ b/games-emulation/yabause/yabause-0.9.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.9.10.ebuild,v 1.1 2009/06/02 05:23:22 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="A Sega Saturn emulator"
+HOMEPAGE="http://yabause.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="openal sdl"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/gtkglext
+ virtual/opengl
+ virtual/glu
+ virtual/glut
+ openal? ( media-libs/openal )
+ sdl? ( media-libs/libsdl[opengl?,video] )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --datadir=/usr/share \
+ --with-port=gtk \
+ $(use_with sdl) \
+ $(use_with openal)
+}
+
+src_compile() {
+ emake -C src/c68k gen68k || die "emake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog GOALS README README.LIN
+ prepgamesdirs
+}