summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-07-14 06:29:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-07-14 06:29:20 +0000
commit33f15bdbd267c0a984b327c962471ca76485f607 (patch)
tree977d6ce6c0cf1e8d172eada4eca6fef2b4335d95 /games-emulation/xe/xe-2.16.2.ebuild
parentold (diff)
downloadgentoo-2-33f15bdbd267c0a984b327c962471ca76485f607.tar.gz
gentoo-2-33f15bdbd267c0a984b327c962471ca76485f607.tar.bz2
gentoo-2-33f15bdbd267c0a984b327c962471ca76485f607.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation/xe/xe-2.16.2.ebuild')
-rw-r--r--games-emulation/xe/xe-2.16.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-emulation/xe/xe-2.16.2.ebuild b/games-emulation/xe/xe-2.16.2.ebuild
new file mode 100644
index 000000000000..d972afb47a1f
--- /dev/null
+++ b/games-emulation/xe/xe-2.16.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xe/xe-2.16.2.ebuild,v 1.1 2009/07/14 06:29:20 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="a multi system emulator for many console and handheld video game systems"
+HOMEPAGE="http://www.xe-emulator.com/"
+SRC_URI="http://www.xe-emulator.com/files/${PN}-x86-32-bin.${PV}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="x11-libs/libXv
+ x11-libs/libXinerama
+ x11-libs/libXxf86vm
+ sys-libs/zlib
+ media-libs/alsa-lib
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-x86
+
+src_prepare() {
+ sed -i \
+ -e '/strip/d' \
+ -e '/^CC/d' \
+ -e '/CC/s/$/ $(LDFLAGS)/' \
+ -e 's/@//' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ newgamesbin xe xe.bin || die "newgamesbin failed"
+ newgamesbin "${FILESDIR}"/xe-${PV} xe || die "newgamesbin failed"
+ sed -i \
+ -e "s:GENTOODIR:$(games_get_libdir)/${PN}:" "${D}/${GAMES_BINDIR}/xe" \
+ || die "sed failed"
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r modules/ rc/ || die "doins failed"
+ keepdir "$(games_get_libdir)"/${PN}/bios
+ dodoc README.txt
+ dohtml manual.html
+ prepgamesdirs
+}