summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2010-05-16 20:38:39 +0000
committerChristian Birchinger <joker@gentoo.org>2010-05-16 20:38:39 +0000
commit3d91a63ca966345b8160e59570a61e50b42a4da3 (patch)
tree05e0bab1a6b1c4aa6062984dfb90ce8c76246b16 /games-emulation/mupen64plus
parentFix implicit declaration of function png_set_gray_1_2_4_to_8 with libpng14. (diff)
downloadgentoo-2-3d91a63ca966345b8160e59570a61e50b42a4da3.tar.gz
gentoo-2-3d91a63ca966345b8160e59570a61e50b42a4da3.tar.bz2
gentoo-2-3d91a63ca966345b8160e59570a61e50b42a4da3.zip
Added a patch to fix FTBFS due to glib gvariant type definitions. Should only affect people that try to build it with a newer glib version.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/mupen64plus')
-rw-r--r--games-emulation/mupen64plus/ChangeLog7
-rw-r--r--games-emulation/mupen64plus/files/ftbfs-gvariant-type-conflicts.patch27
-rw-r--r--games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild5
3 files changed, 37 insertions, 2 deletions
diff --git a/games-emulation/mupen64plus/ChangeLog b/games-emulation/mupen64plus/ChangeLog
index 05f87149ccc2..71051383f022 100644
--- a/games-emulation/mupen64plus/ChangeLog
+++ b/games-emulation/mupen64plus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/mupen64plus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.10 2010/03/11 15:30:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.11 2010/05/16 20:38:39 joker Exp $
+
+ 16 May 2010; Christian Birchinger <joker@gentoo.org>
+ mupen64plus-1.5-r1.ebuild, +files/ftbfs-gvariant-type-conflicts.patch:
+ Added a patch to fix FTBFS due to glib gvariant type definitions. Should
+ only affect people that try to build it with a newer glib version.
11 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
mupen64plus-1.5-r1.ebuild, +files/mupen64plus-1.5-libpng14.patch:
diff --git a/games-emulation/mupen64plus/files/ftbfs-gvariant-type-conflicts.patch b/games-emulation/mupen64plus/files/ftbfs-gvariant-type-conflicts.patch
new file mode 100644
index 000000000000..e76da1707285
--- /dev/null
+++ b/games-emulation/mupen64plus/files/ftbfs-gvariant-type-conflicts.patch
@@ -0,0 +1,27 @@
+Description: Fix FTBFS due to glib gvariant type definitions
+Forwarded: not-needed
+Bug-Debian: http://bugs.debian.org/577329
+Author: Sven Eckelmann <sven.eckelmann@gmx.de>
+
+---
+diff --git a/rice_video/typedefs.h b/rice_video/typedefs.h
+index 4cded542b06445f043fa1fabf77e4d20c9d52920..b7e16e9c4ba3248f9fed9762f79349c137ee2026 100644
+--- a/rice_video/typedefs.h
++++ b/rice_video/typedefs.h
+@@ -20,10 +20,12 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #ifndef _TYPEDEFS_H_
+ #define _TYPEDEFS_H_
+
+-#define uchar unsigned char
+-#define uint16 unsigned short
+-#define uint32 unsigned int
+-#define uint64 unsigned long long
++#include <stdint.h>
++
++typedef uint8_t uchar;
++typedef uint16_t uint16;
++typedef uint32_t uint32;
++typedef uint64_t uint64;
+
+ typedef unsigned char uint8;
+
diff --git a/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild b/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild
index bcc0b83e13e0..d77d7eb4aa75 100644
--- a/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild
+++ b/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild,v 1.8 2010/03/11 15:30:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild,v 1.9 2010/05/16 20:38:39 joker Exp $
EAPI="2"
@@ -55,6 +55,9 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-libpng14.patch
+ # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=577329
+ epatch "${FILESDIR}"/ftbfs-gvariant-type-conflicts.patch
+
sed -i \
-e "s:/usr/local/share/mupen64plus:${GAMES_DATADIR}/mupen64plus:" \
-e "s:%PUT_PLUGIN_PATH_HERE%:$(games_get_libdir)/${PN}/plugins/:" \