summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 01:49:34 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 01:49:34 +0000
commit1fe5197a2c88ab69802d5da205a7bad125514b70 (patch)
treed1f6bb2d6f188c5ea8f8771e45adced09578cb89 /games-emulation/fceux
parentold (diff)
downloadgentoo-2-1fe5197a2c88ab69802d5da205a7bad125514b70.tar.gz
gentoo-2-1fe5197a2c88ab69802d5da205a7bad125514b70.tar.bz2
gentoo-2-1fe5197a2c88ab69802d5da205a7bad125514b70.zip
old
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation/fceux')
-rw-r--r--games-emulation/fceux/ChangeLog7
-rw-r--r--games-emulation/fceux/fceux-2.1.5.ebuild58
-rw-r--r--games-emulation/fceux/files/fceux-2.1.5-gcc46.patch11
-rw-r--r--games-emulation/fceux/files/fceux-2.1.5-gcc47.patch22
-rw-r--r--games-emulation/fceux/files/fceux-2.1.5-underlink.patch13
5 files changed, 6 insertions, 105 deletions
diff --git a/games-emulation/fceux/ChangeLog b/games-emulation/fceux/ChangeLog
index 55f4ba91e2d1..c86181ec2ace 100644
--- a/games-emulation/fceux/ChangeLog
+++ b/games-emulation/fceux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/fceux
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.20 2015/02/10 10:09:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.21 2015/02/19 01:49:34 mr_bones_ Exp $
+
+ 19 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> -fceux-2.1.5.ebuild,
+ -files/fceux-2.1.5-gcc46.patch, -files/fceux-2.1.5-gcc47.patch,
+ -files/fceux-2.1.5-underlink.patch:
+ old
10 Feb 2015; Agostino Sarubbo <ago@gentoo.org> fceux-2.2.2.ebuild:
Stable for x86, wrt bug #539070
diff --git a/games-emulation/fceux/fceux-2.1.5.ebuild b/games-emulation/fceux/fceux-2.1.5.ebuild
deleted file mode 100644
index 3fa83866cc51..000000000000
--- a/games-emulation/fceux/fceux-2.1.5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.5.ebuild,v 1.4 2012/10/26 07:31:49 tupone Exp $
-
-EAPI=4
-inherit eutils scons-utils games
-
-DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
-HOMEPAGE="http://fceux.com/"
-SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+lua +opengl"
-
-RDEPEND="lua? ( dev-lang/lua )
- media-libs/libsdl[opengl?,video]
- opengl? ( virtual/opengl )
- x11-libs/gtk+:2
- sys-libs/zlib
- gnome-extra/zenity"
-DEPEND="${RDEPEND}"
-
-# Note: zenity is "almost" optional. It is possible to compile and run fceux
-# without zenity, but file dialogs will not work.
-
-S=${WORKDIR}/fceu${PV}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-underlink.patch \
- "${FILESDIR}"/${P}-gcc46.patch \
- "${FILESDIR}"/${P}-gcc47.patch
- # mentioned in bug #335836
- if ! use lua ; then
- sed -i -e '/_S9XLUA_H/d' SConstruct || die
- fi
-}
-
-src_compile() {
- escons \
- CREATE_AVI=1 \
- $(use_scons opengl OPENGL) \
- $(use_scons lua LUA)
-}
-
-src_install() {
- dogamesbin bin/fceux
-
- doman documentation/fceux.6
- docompress -x /usr/share/doc/${PF}/documentation
- docompress -x /usr/share/doc/${PF}/fceux.chm
- dodoc -r Authors.txt changelog.txt TODO-PROJECT bin/fceux.chm documentation
- rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
-
- prepgamesdirs
-}
diff --git a/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch b/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch
deleted file mode 100644
index 8062f946518a..000000000000
--- a/games-emulation/fceux/files/fceux-2.1.5-gcc46.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/fceu2.1.5/src/file.cpp
-+++ b/fceu2.1.5/src/file.cpp
-@@ -310,7 +310,7 @@
- if(magic==0x088b1f) {
- // maybe gzip...
-
-- void* gzfile = gzopen(fileToOpen.c_str(),"rb");
-+ gzFile gzfile = gzopen(fileToOpen.c_str(),"rb");
- if(gzfile) {
- delete fp;
-
diff --git a/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch b/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch
deleted file mode 100644
index de32c5f35b73..000000000000
--- a/games-emulation/fceux/files/fceux-2.1.5-gcc47.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/utils/endian.h.old
-+++ src/utils/endian.h
-@@ -93,19 +93,6 @@
- }
- }
-
--template<typename T>
--int writele(T *Bufo, EMUFILE*os)
--{
-- CTASSERT(sizeof(T)==1||sizeof(T)==2||sizeof(T)==4||sizeof(T)==8);
-- switch(sizeof(T)) {
-- case 1: return write8le((uint8*)Bufo,os);
-- case 2: return write16le((uint16*)Bufo,os);
-- case 4: return write32le((uint32*)Bufo,os);
-- case 8: return write64le((uint64*)Bufo,os);
-- default:
-- return 0;
-- }
--}
-
- #endif //__FCEU_ENDIAN
-
diff --git a/games-emulation/fceux/files/fceux-2.1.5-underlink.patch b/games-emulation/fceux/files/fceux-2.1.5-underlink.patch
deleted file mode 100644
index 9e98967227d4..000000000000
--- a/games-emulation/fceux/files/fceux-2.1.5-underlink.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- SConstruct.org
-+++ SConstruct
-@@ -70,6 +70,10 @@
- env.ParseConfig('pkg-config --cflags --libs gtk+-3.0')
- env.Append(CPPDEFINES=["_GTK3"])
- env.Append(CCFLAGS = ["-D_GTK"])
-+ env.Append(LIBS =["-lz"])
-+ env.Append(LIBS =["-ldl"])
-+ env.Append(LIBS =["-lX11"])
-+
- ### Lua platform defines
- ### Applies to all files even though only lua needs it, but should be ok
- if env['LUA']: