summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-09-03 23:50:46 +0000
committerSven Wegener <swegener@gentoo.org>2004-09-03 23:50:46 +0000
commitcf72acda0fc7736173cd83084daa67edaa468f6a (patch)
treec3421356de404f6d8fc237a83c3ea186a46ec3dc /games-emulation/darcnes
parentKeyword modification, see changelog for details (Manifest recommit) (diff)
downloadgentoo-2-cf72acda0fc7736173cd83084daa67edaa468f6a.tar.gz
gentoo-2-cf72acda0fc7736173cd83084daa67edaa468f6a.tar.bz2
gentoo-2-cf72acda0fc7736173cd83084daa67edaa468f6a.zip
Fixed compilation errors with gcc-3.4. Thanks to Anthony Mirabella <mirabeaj@notes.udayton.edu> and Bjarke Istrup Pedersen <Bjarke.ip@tekpunkt.dk> in bug #58718.
Diffstat (limited to 'games-emulation/darcnes')
-rw-r--r--games-emulation/darcnes/ChangeLog9
-rw-r--r--games-emulation/darcnes/darcnes-0401-r1.ebuild11
-rw-r--r--games-emulation/darcnes/darcnes-0401-r2.ebuild11
-rw-r--r--games-emulation/darcnes/files/darcnes-0401-gcc34.patch11
4 files changed, 38 insertions, 4 deletions
diff --git a/games-emulation/darcnes/ChangeLog b/games-emulation/darcnes/ChangeLog
index 23d399f94af5..41240af6cfdc 100644
--- a/games-emulation/darcnes/ChangeLog
+++ b/games-emulation/darcnes/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/darcnes
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.7 2004/06/24 22:25:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.8 2004/09/03 23:50:46 swegener Exp $
+
+ 04 Sep 2004; Sven Wegener <swegener@gentoo.org>
+ +files/darcnes-0401-gcc34.patch, darcnes-0401-r1.ebuild,
+ darcnes-0401-r2.ebuild:
+ Fixed compilation errors with gcc-3.4. Thanks to Anthony Mirabella
+ <mirabeaj@notes.udayton.edu> and Bjarke Istrup Pedersen
+ <Bjarke.ip@tekpunkt.dk> in bug #58718.
06 Jun 2004; Aron Griffis <agriffis@gentoo.org> darcnes-0401-r1.ebuild,
darcnes-0401-r2.ebuild:
diff --git a/games-emulation/darcnes/darcnes-0401-r1.ebuild b/games-emulation/darcnes/darcnes-0401-r1.ebuild
index b382eeb400ef..bf85cb41fe44 100644
--- a/games-emulation/darcnes/darcnes-0401-r1.ebuild
+++ b/games-emulation/darcnes/darcnes-0401-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r1.ebuild,v 1.4 2004/06/24 22:25:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r1.ebuild,v 1.5 2004/09/03 23:50:46 swegener Exp $
+
+inherit eutils
DESCRIPTION="A multi-system emulator"
SRC_URI="http://www.dridus.com/~nyef/darcnes/download/dn9b${PV}.tgz"
@@ -17,6 +19,13 @@ DEPEND=">=media-libs/svgalib-1.4.2
S=${WORKDIR}/${PN}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
src_compile() {
cp cd_unix.c cd_unix.c.orig
diff --git a/games-emulation/darcnes/darcnes-0401-r2.ebuild b/games-emulation/darcnes/darcnes-0401-r2.ebuild
index 82d0058a7996..b8d8ceec9292 100644
--- a/games-emulation/darcnes/darcnes-0401-r2.ebuild
+++ b/games-emulation/darcnes/darcnes-0401-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.5 2004/06/24 22:25:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.6 2004/09/03 23:50:46 swegener Exp $
-inherit games
+inherit games eutils
DESCRIPTION="A multi-system emulator"
HOMEPAGE="http://www.dridus.com/~nyef/darcnes/"
@@ -29,6 +29,13 @@ pkg_setup() {
use X && build_X=true
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
src_compile() {
if use svga ; then
emake TARGET=Linux_svgalib OPTFLAGS="${CFLAGS}" || \
diff --git a/games-emulation/darcnes/files/darcnes-0401-gcc34.patch b/games-emulation/darcnes/files/darcnes-0401-gcc34.patch
new file mode 100644
index 000000000000..4f79fb1dce97
--- /dev/null
+++ b/games-emulation/darcnes/files/darcnes-0401-gcc34.patch
@@ -0,0 +1,11 @@
+diff -Naur old/video_x.c new/video_x.c
+--- old/video_x.c 2004-09-04 01:26:41.102187277 +0200
++++ new/video_x.c 2004-09-04 01:27:51.586427427 +0200
+@@ -366,6 +366,7 @@
+ }
+
+ default:
++ break;
+ }
+ }
+