summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-19 06:32:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-19 06:32:16 +0000
commit2a0e830afde78895ed6a9150bf13e058ab3b743a (patch)
tree4b2339b7ed265f20f7f2ad60338998ffc48b6447 /games-emulation/advancemame
parentKeyworded x86 and ppc for GNOME 2.8.1 (Manifest recommit) (diff)
downloadgentoo-2-2a0e830afde78895ed6a9150bf13e058ab3b743a.tar.gz
gentoo-2-2a0e830afde78895ed6a9150bf13e058ab3b743a.tar.bz2
gentoo-2-2a0e830afde78895ed6a9150bf13e058ab3b743a.zip
Version bump with PIC patch #74899.
Diffstat (limited to 'games-emulation/advancemame')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/advancemame-0.88.0.ebuild11
-rw-r--r--games-emulation/advancemame/advancemame-0.89.0.ebuild84
-rw-r--r--games-emulation/advancemame/files/0.89.0-pic.patch13
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.89.01
5 files changed, 111 insertions, 6 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 17c5a9a7d5c6..17683aa256d2 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.20 2004/12/01 01:23:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.21 2004/12/19 06:32:16 vapier Exp $
+
+*advancemame-0.89.0 (19 Dec 2004)
+
+ 19 Dec 2004; Mike Frysinger <vapier@gentoo.org> +files/0.89.0-pic.patch,
+ advancemame-0.88.0.ebuild, +advancemame-0.89.0.ebuild:
+ Version bump with PIC patch #74899.
*advancemame-0.88.0 (30 Nov 2004)
diff --git a/games-emulation/advancemame/advancemame-0.88.0.ebuild b/games-emulation/advancemame/advancemame-0.88.0.ebuild
index 640acc87ff15..191ef830bc23 100644
--- a/games-emulation/advancemame/advancemame-0.88.0.ebuild
+++ b/games-emulation/advancemame/advancemame-0.88.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.88.0.ebuild,v 1.1 2004/12/01 01:23:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.88.0.ebuild,v 1.2 2004/12/19 06:32:16 vapier Exp $
-inherit eutils games
+inherit games flag-o-matic
DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
HOMEPAGE="http://advancemame.sourceforge.net/"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
LICENSE="GPL-2 xmame"
SLOT="0"
-KEYWORDS="x86 ppc ~amd64"
+KEYWORDS="~amd64 ppc x86"
IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
RDEPEND="virtual/libc
@@ -39,7 +39,9 @@ src_unpack() {
}
src_compile() {
- PATH="${PATH}:${T}"
+ local myconf=""
+ is-flags -fPIC || myconf="$(use_enable x86 asm)"
+ env PATH="${PATH}:${T}" \
egamesconf \
$(use_enable alsa) \
$(use_enable expat) \
@@ -51,7 +53,6 @@ src_compile() {
$(use_enable svga svgalib) \
$(use_enable truetype freetype) \
$(use_enable zlib) \
- $(use_enable x86 asm) \
--with-emu=${PN/advance} \
|| die
emake || die "emake failed"
diff --git a/games-emulation/advancemame/advancemame-0.89.0.ebuild b/games-emulation/advancemame/advancemame-0.89.0.ebuild
new file mode 100644
index 000000000000..a8ab93f8c4d0
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.89.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.89.0.ebuild,v 1.1 2004/12/19 06:32:16 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="virtual/libc
+ app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-pic.patch #74899
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/0.89.0-pic.patch b/games-emulation/advancemame/files/0.89.0-pic.patch
new file mode 100644
index 000000000000..049befbfac2c
--- /dev/null
+++ b/games-emulation/advancemame/files/0.89.0-pic.patch
@@ -0,0 +1,13 @@
+--- ./advance/blit/blit.c.orig 2004-12-19 01:01:46.039956536 -0500
++++ ./advance/blit/blit.c 2004-12-19 01:01:19.566981040 -0500
+@@ -28,6 +28,10 @@
+ * do so, delete this exception statement from your version.
+ */
+
++#if defined(USE_ASM_INLINE) && defined(__PIC__)
++# undef USE_ASM_INLINE
++#endif
++
+ #include "portable.h"
+
+ #include "blit.h"
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.89.0 b/games-emulation/advancemame/files/digest-advancemame-0.89.0
new file mode 100644
index 000000000000..7324c5439261
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.89.0
@@ -0,0 +1 @@
+MD5 80841649560369e64239cc9b2a2ed818 advancemame-0.89.0.tar.gz 13865948