summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-02 23:17:43 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-02 23:17:43 +0000
commit0fc8d0203ea19f19d5f942d002459f4a9f057526 (patch)
tree6db92fce4d6e37dfcce4a8243b8df27ffe3aa351 /games-board/xfreecell
parentFix building with gcc-4.3 (diff)
downloadgentoo-2-0fc8d0203ea19f19d5f942d002459f4a9f057526.tar.gz
gentoo-2-0fc8d0203ea19f19d5f942d002459f4a9f057526.tar.bz2
gentoo-2-0fc8d0203ea19f19d5f942d002459f4a9f057526.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-board/xfreecell')
-rw-r--r--games-board/xfreecell/ChangeLog8
-rw-r--r--games-board/xfreecell/files/xfreecell-1.0.5b-gcc43.patch59
-rw-r--r--games-board/xfreecell/xfreecell-1.0.5b.ebuild12
3 files changed, 72 insertions, 7 deletions
diff --git a/games-board/xfreecell/ChangeLog b/games-board/xfreecell/ChangeLog
index 69189911ddcd..40918c38a8f6 100644
--- a/games-board/xfreecell/ChangeLog
+++ b/games-board/xfreecell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/xfreecell
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xfreecell/ChangeLog,v 1.9 2007/02/06 02:30:11 dang Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xfreecell/ChangeLog,v 1.10 2008/05/02 23:17:43 nyhm Exp $
+
+ 02 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/xfreecell-1.0.5b-gcc43.patch, xfreecell-1.0.5b.ebuild:
+ Fix building with gcc-4.3
06 Feb 2007; Daniel Gryniewicz <dang@gentoo.org> xfreecell-1.0.5b.ebuild:
Marked stable on amd64 for bug #162573
diff --git a/games-board/xfreecell/files/xfreecell-1.0.5b-gcc43.patch b/games-board/xfreecell/files/xfreecell-1.0.5b-gcc43.patch
new file mode 100644
index 000000000000..cf7e899d2856
--- /dev/null
+++ b/games-board/xfreecell/files/xfreecell-1.0.5b-gcc43.patch
@@ -0,0 +1,59 @@
+--- card.cpp
++++ card.cpp
+@@ -1,5 +1,6 @@
++#include <cstdlib>
+ #include <cstdio>
+-#include <math.h>
++#include <cmath>
+ #ifdef SHAPE
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+--- freecell.cpp
++++ freecell.cpp
+@@ -1,6 +1,7 @@
+ #include <dirent.h>
+ #include <fcntl.h>
+-#include <stdlib.h>
++#include <cstdlib>
++#include <cstring>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
+--- option.cpp
++++ option.cpp
+@@ -3,7 +3,9 @@
+ #include <fcntl.h>
+ #include <dirent.h>
+ #include <unistd.h>
+-#include <stdio.h>
++#include <cstdlib>
++#include <cstdio>
++#include <cstring>
+
+ #include "general.h"
+ #include "option.h"
+--- subwindows.cpp
++++ subwindows.cpp
+@@ -3,7 +3,8 @@
+ #include <fcntl.h>
+ #include <dirent.h>
+ #include <unistd.h>
+-#include <stdio.h>
++#include <cstdlib>
++#include <cstdio>
+
+ #include "general.h"
+ #include "subwindows.h"
+--- widget/widget.h
++++ widget/widget.h
+@@ -4,7 +4,9 @@
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+ #include <X11/keysym.h>
+-#include <stdio.h>
++#include <cstdlib>
++#include <cstdio>
++#include <cstring>
+ #include <vector>
+ #include <string>
+
diff --git a/games-board/xfreecell/xfreecell-1.0.5b.ebuild b/games-board/xfreecell/xfreecell-1.0.5b.ebuild
index 6b97c20782d8..1e304801eb71 100644
--- a/games-board/xfreecell/xfreecell-1.0.5b.ebuild
+++ b/games-board/xfreecell/xfreecell-1.0.5b.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xfreecell/xfreecell-1.0.5b.ebuild,v 1.12 2007/02/06 02:30:11 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/xfreecell/xfreecell-1.0.5b.ebuild,v 1.13 2008/05/02 23:17:43 nyhm Exp $
inherit eutils games
@@ -23,13 +23,15 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
}
src_install() {
dogamesbin xfreecell || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins "${WORKDIR}/MSNumbers" || die "doins failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins "${WORKDIR}"/MSNumbers || die "doins failed"
dodoc CHANGES README mshuffle.txt
doman xfreecell.6
prepgamesdirs