summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-04-30 21:50:37 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-04-30 21:50:37 +0000
commite786ffce8f3c05bdd530f4fe88338aad474ada17 (patch)
treed9eb6630cb9d39a8ab604890882c7bbd472f76fa /games-board/slibo
parentUpdate to 6.1_rc1 ensuring that the includes from the same package are used. (diff)
downloadgentoo-2-e786ffce8f3c05bdd530f4fe88338aad474ada17.tar.gz
gentoo-2-e786ffce8f3c05bdd530f4fe88338aad474ada17.tar.bz2
gentoo-2-e786ffce8f3c05bdd530f4fe88338aad474ada17.zip
Fixing gcc-4.1 building, bug #131829
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'games-board/slibo')
-rw-r--r--games-board/slibo/ChangeLog8
-rw-r--r--games-board/slibo/files/digest-slibo-0.4.42
-rw-r--r--games-board/slibo/files/slibo-0.4.4-gcc41.patch13
-rw-r--r--games-board/slibo/slibo-0.4.4.ebuild10
4 files changed, 24 insertions, 9 deletions
diff --git a/games-board/slibo/ChangeLog b/games-board/slibo/ChangeLog
index 46df7bf1abed..cbb4a0f8fbd0 100644
--- a/games-board/slibo/ChangeLog
+++ b/games-board/slibo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/slibo
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/ChangeLog,v 1.7 2004/12/30 00:41:23 mr_bones_ Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/ChangeLog,v 1.8 2006/04/30 21:50:37 tupone Exp $
+
+ 30 Apr 2006; <Tupone@gentoo.org> +files/slibo-0.4.4-gcc41.patch,
+ slibo-0.4.4.ebuild:
+ Fix for gcc-4.1, bug #131829 by me
29 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org>
+files/0.4.4-gcc34.patch, slibo-0.4.4.ebuild:
diff --git a/games-board/slibo/files/digest-slibo-0.4.4 b/games-board/slibo/files/digest-slibo-0.4.4
index 827915e518e9..3b1053fab299 100644
--- a/games-board/slibo/files/digest-slibo-0.4.4
+++ b/games-board/slibo/files/digest-slibo-0.4.4
@@ -1 +1,3 @@
MD5 145a2bcf3d1e9769ccd30b8f1d1ee8ea slibo-0.4.4.tar.bz2 897532
+RMD160 b8b3d000b6124b548cd310b5981cdd846b81a953 slibo-0.4.4.tar.bz2 897532
+SHA256 83aef936812f9499be0c12a9f9ed76041679e6991bc860572a2e4dd0083ce853 slibo-0.4.4.tar.bz2 897532
diff --git a/games-board/slibo/files/slibo-0.4.4-gcc41.patch b/games-board/slibo/files/slibo-0.4.4-gcc41.patch
new file mode 100644
index 000000000000..dfb84f01cbc7
--- /dev/null
+++ b/games-board/slibo/files/slibo-0.4.4-gcc41.patch
@@ -0,0 +1,13 @@
+--- src/sliboengine/search.c 2006-04-30 01:47:33.000000000 +0200
++++ src/sliboengine/search.c.new 2006-04-30 01:56:28.000000000 +0200
+@@ -282,7 +282,9 @@
+ inCheckSig(b);
+ b->color = -b->color;
+ Move *lastMove = movegen((constBoard *)b, firstMove);
+- (ply <= 0) ? stats.qPos : stats.pos += lastMove - firstMove;
++ if (ply > 0) {
++ stats.pos += lastMove - firstMove;
++ }
+
+ Move bestMove;
+ #ifdef PREHASH
diff --git a/games-board/slibo/slibo-0.4.4.ebuild b/games-board/slibo/slibo-0.4.4.ebuild
index adcb8ecb1a3f..c743e582c010 100644
--- a/games-board/slibo/slibo-0.4.4.ebuild
+++ b/games-board/slibo/slibo-0.4.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/slibo-0.4.4.ebuild,v 1.9 2004/12/30 00:41:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/slibo-0.4.4.ebuild,v 1.10 2006/04/30 21:50:37 tupone Exp $
inherit eutils kde
@@ -16,11 +16,7 @@ IUSE=""
DEPEND="=dev-db/sqlite-2*"
need-kde 3
-src_unpack() {
- kde_src_unpack
- cd "${S}"
- epatch "${FILESDIR}/${PV}-gcc34.patch"
-}
+PATCHES="${FILESDIR}/${PV}-gcc34.patch ${FILESDIR}/${P}-gcc41.patch"
pkg_postinst() {
einfo "If you updated from an older version, please do a"