summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-14 18:13:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-14 18:13:21 +0000
commit28b495b3addf9816da1bc9fc47a3b133aafeb1dc (patch)
tree60c5e6ee40f6ed520cb3c7e4df0ce7bb05a85c33 /games-board/pokerth
parentVersion bump. (diff)
downloadgentoo-2-28b495b3addf9816da1bc9fc47a3b133aafeb1dc.tar.gz
gentoo-2-28b495b3addf9816da1bc9fc47a3b133aafeb1dc.tar.bz2
gentoo-2-28b495b3addf9816da1bc9fc47a3b133aafeb1dc.zip
Fix building with GCC 4.5 wrt #318591 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'games-board/pokerth')
-rw-r--r--games-board/pokerth/ChangeLog6
-rw-r--r--games-board/pokerth/files/pokerth-0.7.1-gcc45.patch105
-rw-r--r--games-board/pokerth/pokerth-0.7.1.ebuild4
3 files changed, 113 insertions, 2 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index 5b0eaa380ca8..e72228ae336e 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.12 2010/05/04 05:33:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.13 2010/05/14 18:13:21 ssuominen Exp $
+
+ 14 May 2010; Samuli Suominen <ssuominen@gentoo.org> pokerth-0.7.1.ebuild,
+ +files/pokerth-0.7.1-gcc45.patch:
+ Fix building with GCC 4.5 wrt #318591 by Kacper Kowalik.
04 May 2010; Michael Sterrett <mr_bones_@gentoo.org> pokerth-0.7.1.ebuild:
Allow newer boost and steal boost-related code from wesnoth ebuild
diff --git a/games-board/pokerth/files/pokerth-0.7.1-gcc45.patch b/games-board/pokerth/files/pokerth-0.7.1-gcc45.patch
new file mode 100644
index 000000000000..612771c74cb1
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-0.7.1-gcc45.patch
@@ -0,0 +1,105 @@
+Fixing build with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318591
+
+--- src/gui/qt/gametable/gametableimpl.cpp
++++ src/gui/qt/gametable/gametableimpl.cpp
+@@ -811,7 +811,7 @@
+ for (it_c=currentHand->getSeatsList()->begin(); it_c!=currentHand->getSeatsList()->end(); it_c++) {
+ if((*it_c)->getMyActiveStatus()) {
+
+- if((*it_c)->getMyAvatar() == "" || !QFile::QFile(QString::fromUtf8((*it_c)->getMyAvatar().c_str())).exists()) {
++ if((*it_c)->getMyAvatar() == "" || !QFile(QString::fromUtf8((*it_c)->getMyAvatar().c_str())).exists()) {
+ playerAvatarLabelArray[(*it_c)->getMyID()]->setPixmap(QPixmap::fromImage(QImage(myGameTableStyle->getDefaultAvatar())));
+ }
+ else {
+@@ -821,7 +821,7 @@
+ else {
+ if((myStartWindow->getSession()->getGameType() == Session::GAME_TYPE_INTERNET || myStartWindow->getSession()->getGameType() == Session::GAME_TYPE_NETWORK)) {
+ if((*it_c)->getMyStayOnTableStatus() == TRUE && (*it_c)->getMyType() != PLAYER_TYPE_COMPUTER) {
+- if((*it_c)->getMyAvatar() == "" || !QFile::QFile(QString::fromUtf8((*it_c)->getMyAvatar().c_str())).exists()) {
++ if((*it_c)->getMyAvatar() == "" || !QFile(QString::fromUtf8((*it_c)->getMyAvatar().c_str())).exists()) {
+ playerAvatarLabelArray[(*it_c)->getMyID()]->setPixmap(QPixmap::fromImage(QImage(myGameTableStyle->getDefaultAvatar())), TRUE);
+ }
+ else {
+@@ -847,7 +847,7 @@
+ boost::shared_ptr<PlayerInterface> tmpPlayer = myStartWindow->getSession()->getCurrentGame()->getPlayerByUniqueId(myID);
+ if (tmpPlayer.get()) {
+
+- if(QFile::QFile(myAvatar).exists()) {
++ if(QFile(myAvatar).exists()) {
+ playerAvatarLabelArray[tmpPlayer->getMyID()]->setPixmap(myAvatar);
+ tmpPlayer->setMyAvatar(myAvatar.toUtf8().constData());
+ }
+--- src/gui/qt/gametable/log/log.cpp
++++ src/gui/qt/gametable/log/log.cpp
+@@ -54,13 +54,13 @@
+
+ if(myConfig->readConfigInt("LogOnOff")) {
+ //if write logfiles is enabled
+- if(myConfig->readConfigString("LogDir") != "" && QDir::QDir(QString::fromUtf8(myConfig->readConfigString("LogDir").c_str())).exists()) {
++ if(myConfig->readConfigString("LogDir") != "" && QDir(QString::fromUtf8(myConfig->readConfigString("LogDir").c_str())).exists()) {
+
+ myLogDir = new QDir(QString::fromUtf8(myConfig->readConfigString("LogDir").c_str()));
+ myLogFile = new QFile(myLogDir->absolutePath()+"/pokerth-log-"+QDateTime::currentDateTime().toString("yyyy-MM-dd_hh.mm.ss")+".html");
+
+ //Logo-Pixmap extrahieren
+- QPixmap::QPixmap(myAppDataPath +"gfx/gui/misc/logoChip3D.png").save(myLogDir->absolutePath()+"/logo.png");
++ QPixmap(myAppDataPath +"gfx/gui/misc/logoChip3D.png").save(myLogDir->absolutePath()+"/logo.png");
+
+ // myW->textBrowser_Log->append(myLogFile->fileName());
+
+--- src/gui/qt/gamelobbydialog/gamelobbydialogimpl.cpp
++++ src/gui/qt/gamelobbydialog/gamelobbydialogimpl.cpp
+@@ -716,7 +716,7 @@
+ if(mySession->getAvatarFile(playerInfo.avatar, myAvatarFileName)) {
+
+ QString myAvatarString(QString::fromUtf8(myAvatarFileName.c_str()));
+- if(QFile::QFile(myAvatarString).exists()) {
++ if(QFile(myAvatarString).exists()) {
+
+ QPixmap myAvatarPixmap(25,26);
+ myAvatarPixmap.fill(Qt::transparent);
+--- src/gui/qt/settingsdialog/selectavatardialog/selectavatardialogimpl.cpp
++++ src/gui/qt/settingsdialog/selectavatardialog/selectavatardialogimpl.cpp
+@@ -212,7 +212,7 @@
+ else return QString("");
+ }
+
+- if(groupBox_2->isChecked() && QFile::QFile(lineEdit->text()).exists() ) return externalAvatar;
++ if(groupBox_2->isChecked() && QFile(lineEdit->text()).exists() ) return externalAvatar;
+ else return QString("");
+ }
+
+@@ -232,9 +232,9 @@
+ }
+
+ if(groupBox_2->isChecked()) {
+- if(QFile::QFile(lineEdit->text()).exists()) {
++ if(QFile(lineEdit->text()).exists()) {
+
+- if(QFile::QFile(lineEdit->text()).size() <= 30720 ) {
++ if(QFile(lineEdit->text()).size() <= 30720 ) {
+ externalAvatar = lineEdit->text();
+ settingsCorrect = TRUE;
+ }
+--- src/gui/qt/settingsdialog/settingsdialogimpl.cpp
++++ src/gui/qt/settingsdialog/settingsdialogimpl.cpp
+@@ -559,7 +559,7 @@
+ myConfig->writeConfigInt("FlipsideOwn", radioButton_flipsideOwn->isChecked());
+
+ if(radioButton_flipsideOwn->isChecked()) {
+- if(QFile::QFile(lineEdit_OwnFlipsideFilename->text()).exists() && lineEdit_OwnFlipsideFilename->text() != "") {myConfig->writeConfigString("FlipsideOwnFile", lineEdit_OwnFlipsideFilename->text().toUtf8().constData()); }
++ if(QFile(lineEdit_OwnFlipsideFilename->text()).exists() && lineEdit_OwnFlipsideFilename->text() != "") {myConfig->writeConfigString("FlipsideOwnFile", lineEdit_OwnFlipsideFilename->text().toUtf8().constData()); }
+ else { QMessageBox::warning(this, tr("Settings Error"),
+ tr("The entered flipside picture doesn't exist.\n"
+ "Please enter an valid picture!"),
+@@ -615,7 +615,7 @@
+ myConfig->writeConfigInt("LogOnOff", groupBox_logOnOff->isChecked());
+ if (myConfig->readConfigInt("LogOnOff")) {
+ // if log On
+- if(QDir::QDir(lineEdit_logDir->text()).exists() && lineEdit_logDir->text() != "") { myConfig->writeConfigString("LogDir", lineEdit_logDir->text().toUtf8().constData()); }
++ if(QDir(lineEdit_logDir->text()).exists() && lineEdit_logDir->text() != "") { myConfig->writeConfigString("LogDir", lineEdit_logDir->text().toUtf8().constData()); }
+ else {
+ QMessageBox::warning(this, tr("Settings Error"),
+ tr("The log file directory doesn't exist.\n"
diff --git a/games-board/pokerth/pokerth-0.7.1.ebuild b/games-board/pokerth/pokerth-0.7.1.ebuild
index a5c4bec3982c..cc7199f80f19 100644
--- a/games-board/pokerth/pokerth-0.7.1.ebuild
+++ b/games-board/pokerth/pokerth-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.7.1.ebuild,v 1.6 2010/05/04 05:33:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.7.1.ebuild,v 1.7 2010/05/14 18:13:21 ssuominen Exp $
EAPI=2
inherit multilib flag-o-matic eutils qt4 games
@@ -29,6 +29,8 @@ DEPEND=">=dev-libs/boost-1.39
S=${WORKDIR}/${MY_P}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+
local boost_ver
if use dedicated ; then