summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-25 10:17:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-25 10:17:44 +0000
commitb820caffac5067fffbd3d10d7c32bfc9b3209e83 (patch)
tree0e05ac54074437ad11c8beda81d7c886450ff55b /games-arcade
parentmade ppc compatible (Manifest recommit) (diff)
downloadgentoo-2-b820caffac5067fffbd3d10d7c32bfc9b3209e83.tar.gz
gentoo-2-b820caffac5067fffbd3d10d7c32bfc9b3209e83.tar.bz2
gentoo-2-b820caffac5067fffbd3d10d7c32bfc9b3209e83.zip
initial commit - bug #54983
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/tuxdash/ChangeLog10
-rw-r--r--games-arcade/tuxdash/Manifest2
-rw-r--r--games-arcade/tuxdash/files/digest-tuxdash-0.81
-rw-r--r--games-arcade/tuxdash/metadata.xml5
-rw-r--r--games-arcade/tuxdash/tuxdash-0.8.ebuild50
5 files changed, 68 insertions, 0 deletions
diff --git a/games-arcade/tuxdash/ChangeLog b/games-arcade/tuxdash/ChangeLog
new file mode 100644
index 000000000000..53740e64beff
--- /dev/null
+++ b/games-arcade/tuxdash/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/tuxdash
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxdash/ChangeLog,v 1.1 2004/09/25 10:17:44 mr_bones_ Exp $
+
+*tuxdash-0.8 (25 Sep 2004)
+
+ 25 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +tuxdash-0.8.ebuild:
+ initial commit - bug #54983
+
diff --git a/games-arcade/tuxdash/Manifest b/games-arcade/tuxdash/Manifest
new file mode 100644
index 000000000000..dc53d412b1a8
--- /dev/null
+++ b/games-arcade/tuxdash/Manifest
@@ -0,0 +1,2 @@
+MD5 d1f270bd689e8f962368daf2018f636f tuxdash-0.8.ebuild 735
+MD5 b7e2423106e7098fc0c24abeee018863 files/digest-tuxdash-0.8 68
diff --git a/games-arcade/tuxdash/files/digest-tuxdash-0.8 b/games-arcade/tuxdash/files/digest-tuxdash-0.8
new file mode 100644
index 000000000000..0d187302bc35
--- /dev/null
+++ b/games-arcade/tuxdash/files/digest-tuxdash-0.8
@@ -0,0 +1 @@
+MD5 72975f87843fbbe555b45e390d366efb tuxdash_src_0.8.tar.bz2 447560
diff --git a/games-arcade/tuxdash/metadata.xml b/games-arcade/tuxdash/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/tuxdash/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/tuxdash/tuxdash-0.8.ebuild b/games-arcade/tuxdash/tuxdash-0.8.ebuild
new file mode 100644
index 000000000000..42204f6a2737
--- /dev/null
+++ b/games-arcade/tuxdash/tuxdash-0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxdash/tuxdash-0.8.ebuild,v 1.1 2004/09/25 10:17:44 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A simple BoulderDash clone"
+HOMEPAGE="http://www.tuxdash.de/index.php?language=EN"
+SRC_URI="http://www.tuxdash.de/ressources/downloads/${PN}_src_${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-ttf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f GPL TuxDash
+ sed -i \
+ -e '/^Fullscreen/ s/0/1/' \
+ -e "/^theme/ s:themes:${GAMES_DATADIR}/${PN}/themes:" \
+ config || die "sed failed"
+ sed -i \
+ -e '/PWD/d' \
+ -e '/CurrentDirectory;/d' \
+ -e "s:CurrentDirectory:\"${GAMES_DATADIR}/${PN}\":" \
+ src/main.cpp || die "sed failed"
+ sed -i \
+ -e 's/-Wall/$(E_CXXFLAGS)/' \
+ -e 's/TuxDash/tuxdash/g' \
+ src/Makefile || die "sed failed"
+ find . -type f -print0 | xargs -0 chmod a-x
+}
+
+src_compile() {
+ emake E_CXXFLAGS="${CXXFLAGS}" -C src || die "emake failed"
+}
+
+src_install() {
+ dogamesbin tuxdash || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r themes maps fonts savegames config "${D}/${GAMES_DATADIR}/${PN}" \
+ || die "cp failed"
+ dodoc README*
+ prepgamesdirs
+}