summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-09-01 22:10:03 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-09-01 22:10:03 +0000
commita46a31903884b0e1e39da4cf18b67d6321acdf03 (patch)
tree448e9a0c0ee3f5402d48307c01eb505b956b8b5a /games-arcade
parentAdded ~ppc64; bug #145893 (diff)
downloadgentoo-2-a46a31903884b0e1e39da4cf18b67d6321acdf03.tar.gz
gentoo-2-a46a31903884b0e1e39da4cf18b67d6321acdf03.tar.bz2
gentoo-2-a46a31903884b0e1e39da4cf18b67d6321acdf03.zip
Version bump. Bug #128660
(Portage version: 2.1-r2)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/conveysdl/ChangeLog9
-rw-r--r--games-arcade/conveysdl/conveysdl-1.3.ebuild51
-rw-r--r--games-arcade/conveysdl/files/digest-conveysdl-12
-rw-r--r--games-arcade/conveysdl/files/digest-conveysdl-1.33
4 files changed, 63 insertions, 2 deletions
diff --git a/games-arcade/conveysdl/ChangeLog b/games-arcade/conveysdl/ChangeLog
index f7f143156c2d..02906983b46e 100644
--- a/games-arcade/conveysdl/ChangeLog
+++ b/games-arcade/conveysdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/conveysdl
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/ChangeLog,v 1.3 2005/08/11 23:55:24 tester Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/ChangeLog,v 1.4 2006/09/01 22:10:03 tupone Exp $
+
+*conveysdl-1.3 (01 Sep 2006)
+
+ 01 Sep 2006; <tupone@gentoo.org> +conveysdl-1.3.ebuild:
+ Version bump requested with Bug #128660 by Alexandru Toma
11 Aug 2005; Olivier Crête <tester@gentoo.org> conveysdl-1.ebuild:
Marked ~amd64, closes bug #102163, thanks to meetra for testing
diff --git a/games-arcade/conveysdl/conveysdl-1.3.ebuild b/games-arcade/conveysdl/conveysdl-1.3.ebuild
new file mode 100644
index 000000000000..e97df83bca93
--- /dev/null
+++ b/games-arcade/conveysdl/conveysdl-1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/conveysdl-1.3.ebuild,v 1.1 2006/09/01 22:10:03 tupone Exp $
+
+inherit games
+
+DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs, if you miss any you go round again"
+HOMEPAGE="http://www.cloudsprinter.com/software/conveysdl/"
+SRC_URI="http://www.cloudsprinter.com/software/conveysdl/${P/-/.}.tar"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl
+ >=media-libs/sdl-mixer"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir "${S}"
+ cd "${S}"
+ unpack ${A}
+
+ # Incomplete readme
+ sed -i \
+ -e 's:I k:use -nosound to disable sound\n\nI k:' \
+ readme || die "sed readme failed"
+
+ sed -i \
+ -e 's:SDL_Mi:SDL_mi:' \
+ main.c || die "sed main.c failed"
+ mv main.c ${PN}.c
+}
+
+src_compile() {
+ CFLAGS="${CFLAGS} `sdl-config --cflags`"
+ CFLAGS="${CFLAGS} -DDATA_PREFIX=\\\"${GAMES_DATADIR}/${PN}/\\\""
+ CFLAGS="${CFLAGS} -DENABLE_SOUND"
+ emake "${PN}" LDLIBS="-lSDL_mixer `sdl-config --libs`" \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${PN}" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r gfx sounds levels || die "installing data failed"
+ dodoc readme || die "installing docs failed"
+ prepgamesdirs
+}
diff --git a/games-arcade/conveysdl/files/digest-conveysdl-1 b/games-arcade/conveysdl/files/digest-conveysdl-1
index 93685d7c20b4..54c2870ea5b1 100644
--- a/games-arcade/conveysdl/files/digest-conveysdl-1
+++ b/games-arcade/conveysdl/files/digest-conveysdl-1
@@ -1 +1,3 @@
MD5 e563d8f0659e1a555e2bd9f4dfcaa61c conveysdl-1.tar.bz2 51789
+RMD160 4dd16bf63dfcab6bfdd3ed93b657097f879353a9 conveysdl-1.tar.bz2 51789
+SHA256 b11a01ff6e377ed9f9c56e4235615c722bdb4947fd9ac313f6ba12c87adebf4a conveysdl-1.tar.bz2 51789
diff --git a/games-arcade/conveysdl/files/digest-conveysdl-1.3 b/games-arcade/conveysdl/files/digest-conveysdl-1.3
new file mode 100644
index 000000000000..a79a2448546b
--- /dev/null
+++ b/games-arcade/conveysdl/files/digest-conveysdl-1.3
@@ -0,0 +1,3 @@
+MD5 4e909daa1e6611f5a4dc473c7b950ba6 conveysdl.1.3.tar 429568
+RMD160 dc214567c3d5dd349c03d02005a9b50bc52901e9 conveysdl.1.3.tar 429568
+SHA256 d0de3f8435b6189d2f40fbe5a28f903fbd46d94b53daf10efa53b879346c81cf conveysdl.1.3.tar 429568