summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-12 13:29:48 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-12 13:29:48 +0000
commit774d0ec3eccb2f3a348fc4c56c0be93f510a2cc8 (patch)
tree9326ba3ddf7eafd13c9de7285b4c0f977fe9f1ce /games-arcade
parentAdd support for amrwb and aac encodings via the libvo libraries. Bump libvpx ... (diff)
downloadgentoo-2-774d0ec3eccb2f3a348fc4c56c0be93f510a2cc8.tar.gz
gentoo-2-774d0ec3eccb2f3a348fc4c56c0be93f510a2cc8.tar.bz2
gentoo-2-774d0ec3eccb2f3a348fc4c56c0be93f510a2cc8.zip
Build with gcc-4.6.0 Bugs #363165
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/stepmania/ChangeLog6
-rw-r--r--games-arcade/stepmania/files/stepmania-3.9-gcc46.patch10
-rw-r--r--games-arcade/stepmania/stepmania-3.9-r2.ebuild3
3 files changed, 17 insertions, 2 deletions
diff --git a/games-arcade/stepmania/ChangeLog b/games-arcade/stepmania/ChangeLog
index 159f65a7954d..4c5dbec39660 100644
--- a/games-arcade/stepmania/ChangeLog
+++ b/games-arcade/stepmania/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/stepmania
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.36 2011/03/31 15:47:18 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.37 2011/04/12 13:29:48 tupone Exp $
+
+ 12 Apr 2011; Alfredo Tupone <tupone@gentoo.org> stepmania-3.9-r2.ebuild,
+ +files/stepmania-3.9-gcc46.patch:
+ Build with gcc-4.6.0 Bugs #363165 by Diego Elio Pettenò
31 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org> stepmania-3.9-r2.ebuild:
Depend on virtual/ffmpeg instead of media-video/ffmpeg.
diff --git a/games-arcade/stepmania/files/stepmania-3.9-gcc46.patch b/games-arcade/stepmania/files/stepmania-3.9-gcc46.patch
new file mode 100644
index 000000000000..5991d0c0f41d
--- /dev/null
+++ b/games-arcade/stepmania/files/stepmania-3.9-gcc46.patch
@@ -0,0 +1,10 @@
+--- src/crypto51/cryptlib.h.old 2011-04-12 14:50:28.000000000 +0200
++++ src/crypto51/cryptlib.h 2011-04-12 14:55:34.000000000 +0200
+@@ -297,6 +297,7 @@
+ class NullNameValuePairs : public NameValuePairs
+ {
+ public:
++ NullNameValuePairs() : NameValuePairs() {}
+ bool GetVoidValue(const char *name, const std::type_info &valueType, void *pValue) const {return false;}
+ };
+
diff --git a/games-arcade/stepmania/stepmania-3.9-r2.ebuild b/games-arcade/stepmania/stepmania-3.9-r2.ebuild
index ecab81fda310..2bb69c3d6223 100644
--- a/games-arcade/stepmania/stepmania-3.9-r2.ebuild
+++ b/games-arcade/stepmania/stepmania-3.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9-r2.ebuild,v 1.5 2011/03/31 15:47:18 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9-r2.ebuild,v 1.6 2011/04/12 13:29:48 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -39,6 +39,7 @@ src_prepare() {
"${FILESDIR}"/${P}-gentoo.patch > "${T}"/${P}.patch
EPATCH_SUFFIX=patch epatch "${T}"/${P}.patch "${WORKDIR}"/patches
+ epatch "${FILESDIR}"/${P}-gcc46.patch
sed -i \
-e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:' \