summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-01 07:43:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-01 07:43:30 +0000
commite2fc848cd90b5e82950ec8765dc0e4c5d9a5170d (patch)
tree2612cfea6342a0e3fabe54afb7786a3d1911c2ae /games-arcade/tomatoes
parentCorrecting gtk/gtk2 handling (bug #70053) (Manifest recommit) (diff)
downloadgentoo-2-e2fc848cd90b5e82950ec8765dc0e4c5d9a5170d.tar.gz
gentoo-2-e2fc848cd90b5e82950ec8765dc0e4c5d9a5170d.tar.bz2
gentoo-2-e2fc848cd90b5e82950ec8765dc0e4c5d9a5170d.zip
version that uses sdl-mixer instead of fmod for greater portability.
Diffstat (limited to 'games-arcade/tomatoes')
-rw-r--r--games-arcade/tomatoes/ChangeLog7
-rw-r--r--games-arcade/tomatoes/Manifest5
-rw-r--r--games-arcade/tomatoes/files/digest-tomatoes-1.552
-rw-r--r--games-arcade/tomatoes/tomatoes-1.55.ebuild62
4 files changed, 74 insertions, 2 deletions
diff --git a/games-arcade/tomatoes/ChangeLog b/games-arcade/tomatoes/ChangeLog
index f1f7b81e5a4d..f87d5f9de67b 100644
--- a/games-arcade/tomatoes/ChangeLog
+++ b/games-arcade/tomatoes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/tomatoes
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/ChangeLog,v 1.2 2004/10/19 02:35:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/ChangeLog,v 1.3 2004/12/01 07:43:30 mr_bones_ Exp $
+
+*tomatoes-1.55 (30 Nov 2004)
+
+ 30 Nov 2004; Michael Sterrett <mr_bones_@gentoo.org> +tomatoes-1.55.ebuild:
+ version that uses sdl-mixer instead of fmod for greater portability.
18 Oct 2004; Michael Sterrett <mr_bones_@gentoo.org> +files/1.5-gcc34.patch,
tomatoes-1.5.ebuild:
diff --git a/games-arcade/tomatoes/Manifest b/games-arcade/tomatoes/Manifest
index d2d5332dc38f..76a4d894a60d 100644
--- a/games-arcade/tomatoes/Manifest
+++ b/games-arcade/tomatoes/Manifest
@@ -1,5 +1,8 @@
-MD5 141957abaf30c10abd0014e5c62c2e9e tomatoes-1.5.ebuild 1775
+MD5 1b76be4f5d910155db7c43a39bf3ee8c tomatoes-1.55.ebuild 1792
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 989250c815fec245fecb52e392f73c7f ChangeLog 555
+MD5 141957abaf30c10abd0014e5c62c2e9e tomatoes-1.5.ebuild 1775
MD5 2c9494bdf746978eff80c55028b0e5dc files/digest-tomatoes-1.5 146
+MD5 e7264e50f8ef000802c7943781dd7d5b files/digest-tomatoes-1.55 147
MD5 541cb5f35391525048ce62e6d28a5f17 files/1.5-gcc34.patch 712
+MD5 541cb5f35391525048ce62e6d28a5f17 files/1.55-gcc34.patch 712
diff --git a/games-arcade/tomatoes/files/digest-tomatoes-1.55 b/games-arcade/tomatoes/files/digest-tomatoes-1.55
new file mode 100644
index 000000000000..40f1222d079e
--- /dev/null
+++ b/games-arcade/tomatoes/files/digest-tomatoes-1.55
@@ -0,0 +1,2 @@
+MD5 b0fa201bfb55d1cb402c52ab7e743086 tomatoes-linux-src-1.55.tar.bz2 62947
+MD5 a6a7ff71bb1098fd0a4098fd3d846339 tomatoes-linux-1.5.tar.bz2 8807421
diff --git a/games-arcade/tomatoes/tomatoes-1.55.ebuild b/games-arcade/tomatoes/tomatoes-1.55.ebuild
new file mode 100644
index 000000000000..8fd494f1605d
--- /dev/null
+++ b/games-arcade/tomatoes/tomatoes-1.55.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/tomatoes-1.55.ebuild,v 1.1 2004/12/01 07:43:30 mr_bones_ Exp $
+
+inherit eutils games
+
+DATA_PV=1.5
+DESCRIPTION="How many tomatoes can you smash in ten short minutes?"
+HOMEPAGE="http://tomatoes.sourceforge.net/about.html"
+SRC_URI="mirror://sourceforge/tomatoes/tomatoes-linux-src-${PV}.tar.bz2
+ mirror://sourceforge/tomatoes/tomatoes-linux-${DATA_PV}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ >=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2.2
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv ../tomatoes-1.5/* . || die "mv failed"
+
+ sed -i \
+ -e '/^CC/d' \
+ -e '/^MARCH/d' \
+ -e "/^CFLAGS/s/=.*$/= ${CFLAGS} \$(SDL_FLAGS)/" \
+ -e "/^MPKDIR = /s:./:${GAMES_DATADIR}/${PN}/:" \
+ -e "/^MUSICDIR = /s:./music/:${GAMES_DATADIR}/${PN}/music/:" \
+ -e "/^HISCOREDIR = /s:./:${GAMES_STATEDIR}/${PN}/:" \
+ -e "/^CONFIGDIR = /s:./:${GAMES_SYSCONFDIR}/${PN}/:" \
+ -e "/^OVERRIDEDIR = /s:./data/:${GAMES_DATADIR}/${PN}/data/:" \
+ makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin tomatoes || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}" "${GAMES_STATEDIR}/${PN}"
+ dodoc README README-src
+
+ cp -r tomatoes.mpk music/ "${D}${GAMES_DATADIR}/${PN}" \
+ || die "failed to copy game data"
+
+ insinto /usr/share/icons/
+ newins icon.png ${PN}.png
+ make_desktop_entry tomatoes "I Have No Tomatoes" ${PN}.png
+
+ touch "${D}${GAMES_STATEDIR}/${PN}/hiscore.lst" || die "touch failed"
+ fperms 660 "${GAMES_STATEDIR}/${PN}/hiscore.lst"
+
+ insinto "${GAMES_SYSCONFDIR}/${PN}/"
+ insopts -m0640
+ doins config.cfg || die "failed to copy game config"
+
+ prepgamesdirs
+}