summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-15 18:28:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-15 18:28:23 +0000
commitc8aee5009ce712b25bf401011b718ca6a60cc458 (patch)
treee366d39a2093cd1dd89a687b3a964899de156125 /games-arcade/performous
parentRemove mask for app-crypt/cryptoapi, cause package is removed from tree, bug ... (diff)
downloadgentoo-2-c8aee5009ce712b25bf401011b718ca6a60cc458.tar.gz
gentoo-2-c8aee5009ce712b25bf401011b718ca6a60cc458.tar.bz2
gentoo-2-c8aee5009ce712b25bf401011b718ca6a60cc458.zip
version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade/performous')
-rw-r--r--games-arcade/performous/ChangeLog11
-rw-r--r--games-arcade/performous/files/performous-0.7.0-desktop.patch18
-rw-r--r--games-arcade/performous/files/performous-0.7.0-gentoo.patch29
-rw-r--r--games-arcade/performous/files/performous-0.7.0-libav.patch41
-rw-r--r--games-arcade/performous/files/performous-0.7.0-linguas.patch15
-rw-r--r--games-arcade/performous/performous-0.7.0.ebuild106
6 files changed, 218 insertions, 2 deletions
diff --git a/games-arcade/performous/ChangeLog b/games-arcade/performous/ChangeLog
index ae0a81024d04..8b6f9ad9f297 100644
--- a/games-arcade/performous/ChangeLog
+++ b/games-arcade/performous/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-arcade/performous
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.10 2012/11/05 11:44:38 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.11 2012/11/15 18:28:23 mr_bones_ Exp $
+
+*performous-0.7.0 (15 Nov 2012)
+
+ 15 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/performous-0.7.0-desktop.patch, +files/performous-0.7.0-gentoo.patch,
+ +files/performous-0.7.0-libav.patch, +files/performous-0.7.0-linguas.patch,
+ +performous-0.7.0.ebuild:
+ version bump
05 Nov 2012; Tupone Alfredo <tupone@gentoo.org> performous-0.6.1.ebuild,
+files/performous-0.6.1-boost150.patch:
@@ -41,4 +49,3 @@
+files/performous-0.6.1-libpng.patch, +metadata.xml:
Version bump to 0.6.1 and rename from ultrastar-ng to performous. Bug #245452
by Vincent Le Ligeour
-
diff --git a/games-arcade/performous/files/performous-0.7.0-desktop.patch b/games-arcade/performous/files/performous-0.7.0-desktop.patch
new file mode 100644
index 000000000000..615af5f0a348
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.7.0-desktop.patch
@@ -0,0 +1,18 @@
+--- ./data/performous.desktop.orig 2012-11-15 12:31:30.686153241 -0500
++++ ./data/performous.desktop 2012-11-15 12:32:00.460142521 -0500
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Performous
+ Comment=A karaoke game
+ Comment[de]=Ein Karaoke Spiel
+@@ -10,7 +9,7 @@
+ Comment[ro]=Un joc de tip karaoke
+ Comment[se]=Ett karaoke-spel
+ Exec=performous
+-Icon=performous.xpm
++Icon=performous
+ Terminal=false
+ Type=Application
+-Categories=Application;Game;ArcadeGame;
++Categories=Game;ArcadeGame;
diff --git a/games-arcade/performous/files/performous-0.7.0-gentoo.patch b/games-arcade/performous/files/performous-0.7.0-gentoo.patch
new file mode 100644
index 000000000000..e9a6fe316b95
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.7.0-gentoo.patch
@@ -0,0 +1,29 @@
+--- game/CMakeLists.txt.old 2012-02-20 13:19:35.219635192 +0100
++++ game/CMakeLists.txt 2012-02-20 13:20:06.025469808 +0100
+@@ -149,5 +149,5 @@
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/config.cmake.hh" "${CMAKE_CURRENT_BINARY_DIR}/config.hh" @ONLY)
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}")
+
+-install(TARGETS performous DESTINATION bin)
++install(TARGETS performous DESTINATION @GENTOO_BINDIR@)
+
+--- game/fs.cc.old 2012-02-20 20:09:48.171892171 +0100
++++ game/fs.cc 2012-02-20 20:16:14.197400202 +0100
+@@ -195,6 +195,7 @@
+ if (root) config_list.push_back(std::string(root) + "/" SHARED_DATA_DIR + configFile.string());
+ fs::path exec = plugin::execname();
+ if (!exec.empty()) config_list.push_back(exec.parent_path().string() + "/../" SHARED_DATA_DIR + configFile.string());
++ config_list.push_back(SHARED_DATA_DIR + configFile.string());
+ ConfigList::const_iterator it = std::find_if(config_list.begin(), config_list.end(), static_cast<bool(&)(fs::path const&)>(fs::exists));
+ if (it == config_list.end()) {
+ throw std::runtime_error("Could not find default config file " + configFile.string());
+--- game/fs.cc.old 2012-02-20 20:49:35.610728056 +0100
++++ game/fs.cc 2012-02-20 20:57:03.117084432 +0100
+@@ -167,6 +167,7 @@
+
+ // Adding relative path from executable
+ dirs.push_back(plugin::execname().parent_path().parent_path() / shareDir);
++ dirs.push_back(shareDir);
+ #ifndef _WIN32
+ // Adding XDG_DATA_DIRS
+ {
diff --git a/games-arcade/performous/files/performous-0.7.0-libav.patch b/games-arcade/performous/files/performous-0.7.0-libav.patch
new file mode 100644
index 000000000000..b598dc0a488a
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.7.0-libav.patch
@@ -0,0 +1,41 @@
+diff -urN Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake
+--- Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:44:26.112930173 +0200
++++ Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:56:10.229914635 +0200
+@@ -25,9 +25,15 @@
+ if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
+ set(AVUtil_INCLUDE "${suffix}avutil.h")
+ endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
++ if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
++ set(AVUtilMath_INCLUDE "${suffix}mathematics.h")
++ endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
+ endif(NOT AVUtil_INCLUDE)
+ endforeach(suffix)
+
++ if(NOT AVUtilMath_INCLUDE)
++ message(FATAL_ERROR "Found mathematics.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
++ endif(NOT AVUtilMath_INCLUDE)
+ if(NOT AVUtil_INCLUDE)
+ message(FATAL_ERROR "Found avutil.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
+ endif(NOT AVUtil_INCLUDE)
+diff -urN Performous-0.6.1-Source.old/game/config.cmake.hh Performous-0.6.1-Source/game/config.cmake.hh
+--- Performous-0.6.1-Source.old/game/config.cmake.hh 2012-05-16 13:44:26.103930173 +0200
++++ Performous-0.6.1-Source/game/config.cmake.hh 2012-05-16 13:59:24.552910345 +0200
+@@ -15,6 +15,7 @@
+ #define AVCODEC_INCLUDE <@AVCodec_INCLUDE@>
+ #define AVFORMAT_INCLUDE <@AVFormat_INCLUDE@>
+ #define SWSCALE_INCLUDE <@SWScale_INCLUDE@>
++#define AVUTILMATH_INCLUDE <@AVUtilMath_INCLUDE@>
+
+ #endif
+
+diff -urN Performous-0.6.1-Source.old/game/ffmpeg.cc Performous-0.6.1-Source/game/ffmpeg.cc
+--- Performous-0.6.1-Source.old/game/ffmpeg.cc 2012-05-16 13:44:26.101930173 +0200
++++ Performous-0.6.1-Source/game/ffmpeg.cc 2012-05-16 14:00:38.278908717 +0200
+@@ -10,6 +10,7 @@
+ #include AVCODEC_INCLUDE
+ #include AVFORMAT_INCLUDE
+ #include SWSCALE_INCLUDE
++#include AVUTILMATH_INCLUDE
+ }
+
+ // #define USE_FFMPEG_CRASH_RECOVERY
diff --git a/games-arcade/performous/files/performous-0.7.0-linguas.patch b/games-arcade/performous/files/performous-0.7.0-linguas.patch
new file mode 100644
index 000000000000..21836766d878
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.7.0-linguas.patch
@@ -0,0 +1,15 @@
+--- lang/CMakeLists.txt
++++ lang/CMakeLists.txt
+@@ -7,5 +7,11 @@
+ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
+ add_custom_command(OUTPUT ${mofile} COMMAND ${Msgfmt_BIN} -v "${pofile}" -o ${mofile} MAIN_DEPENDENCY ${pofile} COMMENT "Building ${language} locale" VERBATIM)
+ add_custom_target(locale_${language} ALL DEPENDS ${mofile}) # Make sure the mofiles are always built
+- install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
+ endforeach(language)
++foreach(language $ENV{LINGUAS})
++ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
++ if (EXISTS ${pofile})
++ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
++ install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
++ endif()
++endforeach(language)
diff --git a/games-arcade/performous/performous-0.7.0.ebuild b/games-arcade/performous/performous-0.7.0.ebuild
new file mode 100644
index 000000000000..336fee3c13e6
--- /dev/null
+++ b/games-arcade/performous/performous-0.7.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-0.7.0.ebuild,v 1.1 2012/11/15 18:28:23 mr_bones_ Exp $
+
+EAPI=3
+inherit eutils flag-o-matic base cmake-utils games
+
+MY_PN=Performous
+MY_P=${MY_PN}-${PV}
+SONGS_PN=ultrastar-songs
+
+DESCRIPTION="SingStar GPL clone"
+HOMEPAGE="http://sourceforge.net/projects/performous/"
+SRC_URI="mirror://sourceforge/performous/${P}.tar.bz2
+ songs? (
+ mirror://sourceforge/performous/${SONGS_PN}-restricted-3.zip
+ mirror://sourceforge/performous/${SONGS_PN}-jc-1.zip
+ mirror://sourceforge/performous/${SONGS_PN}-libre-3.zip
+ mirror://sourceforge/performous/${SONGS_PN}-shearer-1.zip
+ )"
+
+LICENSE="GPL-2
+ songs? (
+ CCPL-Attribution-ShareAlike-NonCommercial-2.5
+ CCPL-Attribution-NonCommercial-NoDerivs-2.5
+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="songs tools"
+
+RDEPEND="dev-cpp/glibmm
+ dev-cpp/libxmlpp
+ media-libs/portaudio
+ >=dev-libs/boost-1.36
+ dev-libs/glib
+ dev-libs/libxml2
+ gnome-base/librsvg
+ media-gfx/imagemagick
+ virtual/jpeg
+ media-libs/libpng:0
+ media-libs/libsdl[joystick,video]
+ virtual/ffmpeg
+ virtual/opengl
+ virtual/glu
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ media-libs/glew
+ sys-apps/help2man"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libav.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-linguas.patch
+ "${FILESDIR}"/${P}-desktop.patch
+)
+
+src_prepare() {
+ base_src_prepare
+ sed -i \
+ -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
+ game/CMakeLists.txt \
+ || die
+
+ strip-linguas -u lang
+
+ # how do I hate boost? Let me count the ways...
+ local boost_ver=$(best_version ">=dev-libs/boost-1.36")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable tools TOOLS)
+ -DCMAKE_VERBOSE_MAKEFILE=TRUE
+ -DSHARE_INSTALL="${GAMES_DATADIR}"/${PN}
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use songs ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${WORKDIR}/songs" || die
+ fi
+ dodoc docs/{Authors,DeveloperReadme,instruments,TODO}.txt
+ prepgamesdirs
+}