summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-06-07 13:45:40 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-06-07 13:45:40 +0000
commit4fb28844ca46b00ba2605b14502bc5fbaa7f0bfb (patch)
tree57b616744e3142f0fff18a8c2bb858549838f86b /games-arcade/opentyrian
parentRevision bump. Patch from upstream fixes memory corruption for Android/Cyanog... (diff)
downloadgentoo-2-4fb28844ca46b00ba2605b14502bc5fbaa7f0bfb.tar.gz
gentoo-2-4fb28844ca46b00ba2605b14502bc5fbaa7f0bfb.tar.bz2
gentoo-2-4fb28844ca46b00ba2605b14502bc5fbaa7f0bfb.zip
Revision bump. Renaming the game binary for backwards compatibility was ill-advised as it broke the desktop launcher file. Diagnosed & fixed up by Alexandre Rostovtsev in bug #367979.
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/opentyrian')
-rw-r--r--games-arcade/opentyrian/ChangeLog9
-rw-r--r--games-arcade/opentyrian/opentyrian-20110517-r1.ebuild47
2 files changed, 55 insertions, 1 deletions
diff --git a/games-arcade/opentyrian/ChangeLog b/games-arcade/opentyrian/ChangeLog
index 28ea5f7245a3..dbe87bcae29c 100644
--- a/games-arcade/opentyrian/ChangeLog
+++ b/games-arcade/opentyrian/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/opentyrian
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/ChangeLog,v 1.9 2011/05/17 12:50:57 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/ChangeLog,v 1.10 2011/06/07 13:45:40 chainsaw Exp $
+
+*opentyrian-20110517-r1 (07 Jun 2011)
+
+ 07 Jun 2011; Tony Vroon <chainsaw@gentoo.org> +opentyrian-20110517-r1.ebuild:
+ Revision bump. Renaming the game binary for backwards compatibility was
+ ill-advised as it broke the desktop launcher file. Diagnosed & fixed up by
+ Alexandre Rostovtsev in bug #367979.
*opentyrian-20110517 (17 May 2011)
diff --git a/games-arcade/opentyrian/opentyrian-20110517-r1.ebuild b/games-arcade/opentyrian/opentyrian-20110517-r1.ebuild
new file mode 100644
index 000000000000..f2805279eb18
--- /dev/null
+++ b/games-arcade/opentyrian/opentyrian-20110517-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/opentyrian-20110517-r1.ebuild,v 1.1 2011/06/07 13:45:40 chainsaw Exp $
+
+inherit base games
+
+DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
+HOMEPAGE="http://code.google.com/p/opentyrian/"
+SRC_URI="http://darklomax.org/tyrian/tyrian21.zip
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}/${PN}"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-net"
+# Yes, mercurial is needed to set the build version stamp.
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-vcs/mercurial"
+PATCHES=(
+ "${FILESDIR}/${PV}-datapath.diff"
+ "${FILESDIR}/${PV}-cflag-idiocy.diff"
+)
+
+src_compile() {
+ emake DATA_PATH="${GAMES_DATADIR}/${PN}" || die "Compilation failed"
+}
+
+src_install() {
+ dogamesbin opentyrian || die "Failed to install game binary"
+ dosym "${GAMES_BINDIR}/opentyrian" "${GAMES_BINDIR}/tyrian" || die "Failed to symlink"
+ dodoc CREDITS NEWS README || die "Failed to install documentation"
+ domenu linux/opentyrian.desktop || die "Failed to install desktop file"
+ for i in linux/icons/*.png ; do
+ local size=`echo ${i} | sed -e 's:.*-\([0-9]\+\).png:\1:'`
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins ${i} opentyrian.png || die "Failed to install program icon"
+ done
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}/tyrian21"
+ doins * || die "Failed to install game data"
+ prepgamesdirs
+}